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1 Introduction

Welcome to Part 1 of the Altium Designer Workshop! In this two-part workshop, you will
learn the basics of creating schematics and PCBs in Altium Designer, as well as some tips
to help you take your designs to the next level. Part 1 of the workshop focuses solely on
getting you comfortable with Altium and showing you how to make a basic schematic.
Part 2 focuses on taking your schematic and making a two-layer PCB. This guide is de-
signed to go along with the workshop (so in case I go too fast or you miss something, you
can follow along here if needed). Oh and I should probably introduce myself. I’m Emily!
I am a third year EE major from Northern Virginia, and I have been doing PCB design
with Altium Designer for more than a year now in my VIP, summer internship, and for
the Hive! Feel free to ask me any questions you may have, and even if you need any help
after the workshop is over, you can always email me at emarshall33@gatech.edu, and I will
be happy to assist!

2 Project Introduction

In this workshop, you will be making a CAN transceiver. A sample of what your final
board may look like is shown in Figure 1. (Don’t worry if your components have differ-
ent names. In other words, your P1 might not be in the same spot as mine, which is okay
because we might name our components differently!). What is a CAN transceiver you ask?
Well let’s start by talking about CAN. CAN stands for ”Controller Area Network.” It’s
a communication protocol that is often used in the automotive industry due to its abil-
ity to be highly resistant to noise. A CAN bus has two wires, CAN H and CAN L, which
carry equal and opposite signals on differential traces, which helps improve noise immu-
nity. Several ”nodes” can communicate with each other over the CAN bus, and Figure
2 shows an example of the setup. Each node in this case is made up of a microcontroller
that has a built-in CAN controller. When one of the microcontrollers wants to send a sig-
nal out, it sends the single-ended signal to the CAN transceiver over the CAN TX line.
The CAN transceiver then converts this to a differential signal and sends it out onto the
CAN bus CAN H and CAN L lines. The signal travels to another CAN transceiver on
the bus, which converts the differential signal back to a single-ended signal (CAN RX this
time), which is then sent to the new microcontroller.
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Figure 1: Example of what your final CAN transceiver board may look like.

Figure 2: Diagram showing the interconnection of two CAN nodes on the CAN bus.

3 Schematic Basics

3.1 Getting Started

Let’s begin! Whenever you want to start working on a new schematic, you should make a
new Altium project and then a new Altium schematic.

3.1.1 Creating a New Project

To create a new Altium project, go to File→New→Project, as shown in Figure 3. Save
the project wherever you’d like, then click Create.
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Figure 3: Steps to create a new project

3.1.2 Creating a New Schematic

To create a new schematic in the project you just made, right click on the project then
select Add New to Project→Schematic, as shown in Figure 4.

Figure 4: Adding a new schematic to the project

3.1.3 Tasks

It’s your turn!

1. Create a new Altium project.

2. Add a new schematic to the project you created.

3. Make sure both are saved!

3.2 Adding Components

3.2.1 Using Library Loader

Before this workshop, you should have downloaded an awesome tool called Library Loader.
Library Loader interfaces with Altium and helps you import component symbols and foot-
prints so you don’t have to make them yourself. To use Library Loader, go to Tools→
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Symbols | Footprints | 3D Models, as shown in Figure 5. You can also just click the
little blue square with the black triangle in it that is located next to the Help button.

Figure 5: Accessing Library Loader

A new window should pop up (as shown in Figure 6) where you can either enter a generic
part description or a specific part number into a search bar. Enter what you are looking
for and click Search. Select the component you want to add. I recommend you make sure
that there is a Y in both the SYM/FP column and the 3D column. A Y in both of these
columns means that the component has a schematic symbol, footprint, and 3D model. At
the very least, make sure it has a Y in the SYM/FP column, otherwise it will be a pain
to place the component on your PCB design. If the component has an N in both columns,
you will unfortunately have to find the component models elsewhere on the internet or
make them yourself. Click Add to Design when you have highlighted your desired com-
ponent.
If you have never added the component you chose to Library Loader before, it will add it
automatically, and the component will appear in the bottom left corner of your schematic.
If you have added the component before, you will get a message saying you already have it
and to use the schematic library instead. In this case, you will need to do the following if
you have not already added the SamacSys.PcbLib and SamacSys.SchLib libraries to your
project libraries:

1. Go to the bottom right corner of the screen and click Panels→Components, as
shown in Figure 7.

2. The Components tab should appear. Select the button with the three horizontal
lines near the top of the sidebar, as shown in Figure 8.

3. Once you click the button, select File-based Libraries Preferences.

4. A new window will appear. Make sure you are in the Projects tab of the new win-
dow. Select Add Library on the new window then browse for the SamacSys.PcbLib
and SamacSys.SchLib libraries. It should now be possible to find the SamacSys.SchLib
library in the drop-down next to the button with the three horizontal lines.
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Figure 6: Library Loader window
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Figure 7: Navigating to Components window

Figure 8: Button to select to add libraries

3.2.2 Using a Library

Sometimes you may have an actual library instead of just Library Loader. You may be
working at a company that has libraries for you to use, or you could just be using one of
the built-in libraries like Miscellaneous Connectors. In any case, to add a library, you do
basically the same thing as you did to install the SamacSys libraries (see above subsec-
tion), except instead of being in the Project tab of the File-based Libraries Preferences
window, you need to be in the Installed tab. Once you are on that tab, click the Install
button, and navigate to the .IntLib file you would like to install. When this is complete,
you will be able to find the library in your drop-down on the Components sidebar. When-
ever you would like to add a component from a library, make sure the correct library is
selected in the drop-down so you can find it.
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3.2.3 Placing Components

To place components onto your schematic, go to the upper toolbar and select the Place
Part button, as shown in Figure 9. You can also access the same thing by going to Panels→
Components. Make sure you selected the right library in the drop-down when you reach
the Components tab. You can then search for any component in the library and either
double-click or click and drag the component from the sidebar to the schematic sheet. To
rotate a component, click and hold the component then hit the spacebar. To flip the com-
ponent, you can hold the component then hit either X or Y (depending on which way you
want to flip the component).

Figure 9: Toolbar with the part button highlighted

When you place a component, you will probably want to change some of its properties.
Double-click the component to open up the Properties tab. In the Designator field, name
the part whatever you would like (e.g. IC1, C3, R4, etc.), as shown in Figure 10. You
can also toggle what is shown on the part on the schematic by clicking the eye icon be-
side the fields. For example, in Figure 10, the Designator field is going to be shown on the
schematic, but the Comment field will not be (because the eye icon is crossed out).

Figure 10: Changing the designator for a component in its properties

In addition to physical components, you will also want to add power port symbols for
VCC and GND. These can be found on the upper toolbar, as shown in Figure 11. You can
click the power port button to place the power port shown, or right click it to select a dif-
ferent type of power port. If you are using a VCC power port, once you place it you need
to double click it and rename it to the voltage value you need (e.g. 5V).
While working with your schematic, you might find some of the following keyboard short-
cuts useful:

• Ctrl + Scroll = Zoom
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Figure 11: Power symbol location on toolbar

• Right Click + Drag = Move schematic/PCB

• Click and Hold + Space = Rotate component

• Backspace = Undo Net/Trace Segment (we’ll talk about nets shortly!)

• Esc = Exit active tool

3.2.4 Tasks

1. Download and install AltiumWorkshop.IntLib from tinyurl.com/AltiumWorkshopSpring2022.

2. Import and place the required components. You will need:

• (x3: P1, P2, P3) 2-pin headers (“Header 2”) from Miscellaneous Connectors
Library

• (x1: IC1) CAN Transceiver from workshop library

• (x1: C1) 0.1uF capacitor from workshop library

• (x2: C2, C3) 560pF capacitors from workshop library

• (x2: R1, R4) 100 Ohm resistors from workshop library

• (x1: R2) 4.7 kOhm resistor from workshop library

• (x1: R3) ERA-6AEB121V (120 Ohm resistor) from Library Loader

• (x5) Ground Power Port Symbol

• (x2) VCC Power Port Symbol

I recommend you place your components so that they are close to the locations of
the components in the example shown in Figure 12.

3. Place symbols for power and ground.
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Figure 12: Example CAN transceiver schematic

3.3 Connecting Components

You should now have all your components placed, so it’s time to wire everything up! You
can connect your components by using nets and/or net labels. Nets are wires that directly
connect the pins of different components. If two components are connected with a net,
they are electrically connected. This is fine on simple circuits or for components that are
close to each other on the schematic, but sometimes this can get very messy and confusing
if you only have directly connected nets. Another option is to use net labels. You can put
a small net on each pin you would like to connect, then add a net label. Any nets you give
the same net label to will be considered electrically connected. This is a good strategy for
more complicated schematics. Note that even if you are directly connecting everything
using just nets, it is still a good idea to use net labels to label the nets for clarity. It will
make your life easier when you go to design the PCB.

3.3.1 Using Nets

To add a net, go to the upper toolbar and select the wire tool, as shown in Figure 13.

Figure 13: Location of the wire tool on the upper toolbar

Click where you would like to place the first end of your connection (often on the pin of a
component). A small, blue X will likely appear there before you click. Move to wherever
you would like to place the other end of the wire and click to end the connection. Note
that if you are connecting components in this way, you don’t have to press Esc to stop
connecting, but if you are going to just put a little bit of wire on a pin to lengthen it, you
do have to press Esc so Altium doesn’t think you’re looking for something else to connect
to.
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3.3.2 Using Net Labels

To add a net label, go to the upper toolbar and right click the wire tool to open more op-
tions, as shown in Figure 14. Select the net label tool.

Figure 14: Accessing the net label tool

Click to place a net label on any net. Like a component, you can place multiple at one
time or you can press Esc to stop adding net labels. Like renaming a component, double
click the net label to rename it under Properties→Net Name in the panel that pops
up to the right, as shown in Figure 15. You can also just click and type a new name di-
rectly on the net label on the sheet. Make sure that when you place the net label that it
properly connects to the net it is on. To check this, select the net and verify that its name
matches the net label name.

Figure 15: Changing net name in net label properties

3.3.3 Tasks

1. Connect all components using either nets or net labels. If you use just nets, still add
net labels for clarity. For the CANH net, you must label it ”CAN P” and for the
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CANL net, you must label it ”CAN N” because these are the standards for differen-
tial pairs.

3.4 Special Symbols

You’re almost done with your schematic! There are just a couple more things to add.

3.4.1 Generic No ERC

Sometimes there are pins that we want to intentionally leave floating (component datasheets
will let you know which ones). When you leave a pin floating, Altium gets worried and
thinks you forgot to connect it. To make Altium happy, you have to put what is called
a Generic No ERC symbol on any pin that is intentionally left floating. The Generic No
ERC symbol looks like a little red X and just tells Altium to not worry about that pin on
the electrical rule check (ERC). To place a Generic No ERC symbol, go to the upper tool-
bar and right-click the third tool from the left to open up the options. Select the tool that
looks like a red X, as shown in Figure 16. Place the X on the end of any pin you want to
leave floating.

Figure 16: Generic No ERC tool

3.4.2 Differential Pair

When you are using a differential pair, you want to make sure Altium is aware of it so
that it can help you route it later on the PCB. To mark a pair of nets as a differential
pair, go up to the same tool as the Generic ERC, right-click, and select Differential Pair.
Place one of these symbols on each of the nets in the differential pair (one on CAN P and
one on CAN N).

3.4.3 Tasks

1. Add Generic No ERC symbols to any pins left floating (this should only be pin 5 on
the CAN transceiver IC).

2. Add differential pair symbols to the CAN P and CAN N nets.
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3. Your final schematic should look something like what is shown in Figure 17.

Figure 17: CAN transceiver schematic example
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4 Bonus Material: Hierarchical Schematics

Congratulations! You now know the basics of making a schematic in Altium Designer! In
this section, I will go over some more advanced techniques that will help you if you wanted
to make schematics for more complex PCB designs.

4.1 Creating Hierarchical Schematics

I suppose we should begin by talking about why hierarchical schematics are important. On
your previous schematic, you just made one schematic sheet, dropped in components, and
connected everything using nets and/or net labels. This is great for simple circuits, but
imagine having to take multiple schematics and put them together on one sheet. It will
get super crowded and will become difficult to read and understand. The best way to han-
dle this is by splitting your design up into sub-systems you can put into different ”boxes.”
All you need to focus on is how each box connects to the others. This is what hierarchical
schematics can do, and it greatly improves readability and makes the design more clear.
Don’t worry, making a hierarchical schematic isn’t much different from making a regular
schematic. Really all you need to know how to do is work with ports, sheet symbols, and
sheet entries.

4.1.1 Adding Ports

To make your schematic able to connect to other schematics off-sheet, you need to use
ports. Ports help you connect pins on one schematic to pins on another. It is sort of like
how you can name two nets the same thing to connect them. We’re doing a similar thing
here, but by using a port, we’re saying the connection will be on a different schematic
sheet. In the case of the CAN transceiver, it would be nice to have CAN TX and CAN RX
connect to a microcontroller schematic off-sheet. CAN TX would have an input port and
CAN RX would have an output port. To create a port, follow these steps:

1. Click the port tool, which is shown in Figure 18. It is located in the upper toolbar.

Figure 18: How to Locate the Port Tool

2. Go to the pin where you would like to add a port and click where you want the start
and end of the port symbol to go.

3. Double click the port to open up the settings, as shown in Figure 19. Change the
port name to the name of the net you would like. Set the I/O Type to either input,
output, or bidirectional depending on what the pin should be doing. Output ports
point away from the pin and input ports point toward the pin.

An example of the CAN transceiver schematic that includes ports is shown in Figure 20.
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Figure 19: Adjusting the Port Settings

Figure 20: Sample CAN transceiver schematic using ports

4.1.2 Adding Sheet Symbols

Once you have prepared your schematic with ports, you are ready to make a hierarchical
schematic. Add a new schematic to your project as you did earlier and make sure to save
it. This will be your new hierarchical schematic. To add sub-schematics to the sheet, you
need to add what is called a sheet symbol, which is a green box that represents the sub-
schematic. To add a sheet symbol to a schematic, go up to the upper toolbar and select
the little green box, as shown in Figure 21. Click somewhere on your schematic to place
the first corner of the sheet symbol then click the location where you want the diagonal
corner to go. Don’t worry if it isn’t the size or shape you want because you can always
readjust it by dragging the edges.

Figure 21: Screenshot showing the location of the sheet symbol tool on the upper toolbar

When you place the sheet symbol, it should look something like what is shown in Figure
22. Double click on the sheet symbol to bring up its properties, as shown in Figure 23.
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Figure 22: Generic sheet symbol

Figure 23: Screenshot of sheet symbol properties

You can add a descriptive designator in the Designator field of the sheet symbol proper-
ties if you would like, but it isn’t necessary (although it can be helpful). In the File Name
field, click the three dots on the right side of the field then browse for the schematic that
you would like this sheet symbol to represent. This will link the documents and will al-
low you to see the sub-schematic by doing Ctrl+Click on the sheet symbol. If you do this
correctly, the file name should show up on the sheet symbol, and the sub-schematic will
appear to be nested under the schematic you are working on (if you look in the Projects
panel).
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4.1.3 Adding Sheet Entries

Once you have created a sheet symbol, you now have to create sheet entries. These look a
lot like ports, but don’t get them confused! Ports are what you put on the ends of signals
on your sub-schematics to say that they will connect to off-sheet nets on other schemat-
ics. Sheet entries look like ports, but are different in that they sit inside the green sheet
symbol boxes. It is as if we boiled down your sub-schematic to just its ports (what is com-
ing into and out of the sub-system) and represented it using the sheet symbol. Using this
”black box” approach lets us focus on just the interfaces between subsystems, which is all
we need on the top-level design. To add a sheet entry to your sheet symbol, go up to the
top toolbar and right click the sheet symbol tool. Select Sheet Entry from the drop-down,
as shown in Figure 24.

Figure 24: Screenshot of sheet entry tool
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To place a sheet entry, simply click a location on the inner edge of the sheet symbol. The
sheet entries automatically rotate to align with the edges. When you have placed your
sheet entry, it will still appear as a solid yellow rectangle. Like with the ports, we want
to name this and set it as an input or output. Double click the sheet entry to pull up the
sheet entry properties, as shown in Figure 25. In the Name field, enter the name of the
sheet entry. This should match the name of one of your ports in the corresponding sub-
schematic! In the I/O Type drop-down, select either input, output, or bidirectional. This
should also match the corresponding port! For example, if you have an output port on
your schematic, the corresponding sheet symbol should have a sheet entry of the same
name that is also an output.

Figure 25: Screenshot of sheet entry properties

4.1.4 Tasks

Once you have sheet symbols and sheet entries, you are ready to complete the schematic
using the same techniques as before! You can connect the sheet entries as if they were pins
by using nets or matching net labels. This section does not have required tasks for you
to complete (the second part of the workshop only depends on the basic CAN transceiver
schematic we made earlier), but feel free to play around with what we have just discussed
by doing the following:

• Make a hierarchical schematic and add multiple sheet symbols for multiple CAN
transceiver schematics (this would be useful if you ever wanted to have multiple
CAN transceivers on one board).

• Add sheet entries to the sheet symbols.

• Play with connecting the sheet entries.
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5 Conclusion

Congratulations! You have officially completed Part 1 of the Altium Designer Workshop!
You now know how to make a project in Altium Designer, install a library, and place and
connect components in a schematic. You also have the tools to make hierarchical schemat-
ics, which will be useful if you want to make more complex designs. Great work today, see
you next week for Part 2! Please feel free to contact me with any questions, comments, or
concerns.
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