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1 Introduction

Welcome back! This is Part 2 of the Altium Designer workshop! If you are reading this,
I assume you have already completed your CAN transceiver schematic from Part 1 and
are ready to start the PCB layout. By the end of Part 2, you will have a completed PCB
design for a CAN transceiver board! Your final product should look something like this:

Figure 1: Sample 2D PCB Layout of the CAN Transceiver

Figure 2: Sample 3D PCB Layout of the CAN Transceiver

If you have any problems after the workshop and would like help with Altium, please feel
free to reach out to me at emarshall33@gatech.edu. But for now, let’s get started!
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2 Preparing the PCB

Sometimes the hardest part is just getting started! In this section, you will learn how to
set up your PCB file.

2.1 Adding New PCB to Project

When you first start making a new PCB, you need to right click on your .PrjPcb file on
the left panel and select Add New to Project→PCB, as shown in Figure 3.

Figure 3: Screenshot of steps to add a new PCB to the .PrjPcb project

Make sure that your schematic (.SchDoc) and PCB (.PcbDoc) are under the same .Pr-
jPcb file. If they are not, then you will not be able to move your schematic over to your
PCB in a later step. If you accidentally get them separated, all you need to do is instead
of selecting Add New to Project→PCB, just right click your .PrjPcb file and select Add
Existing to Project so you can add the existing file to your project. If your setup was
successful, you should now see a large black rectangle on the main part of your Altium
screen. You need to save your PCB file before you go any further, so simply right click the
.PcbDoc file, select Save As, and give it a meaningful name, as shown in Figure 4.

Figure 4: Screenshot of how to save .PcbDoc file
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2.2 Setting the Origin

Your PCB needs to have an origin to reference, so let’s set one! Go into the upper left cor-
ner to Edit→Origin→Set as shown in Figure 5.

Figure 5: Screenshot of menu navigation needed to set origin

Next, you need to select the bottom left corner of the black rectangle on the screen. This
will be our (0, 0) (just like in Cartesian coordinates). You can zoom in a bit to be more
precise, but once you are happy with your placement, click the spot to lock in the ori-
gin. The origin will be at the center of the white circle with a cross that appears. (Note
that if you make a mistake in placing the origin, just go back to the menu to set the origin
again). See Figures 6 and 7 for reference on placing the origin.

Figure 6: Screenshot of the green cross-hairs that mark where you will be placing the ori-
gin
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Figure 7: Screenshot of the white circle with the cross that marks the location of the ori-
gin once it is set

2.3 Editing Board Shape

While you are working with a .PcbDoc file, you have three different modes you can view.
By pressing 1 on your keyboard, you can access Board Planning Mode. By pressing 2
on your keyboard, you can access 2D Layout Mode. By pressing 3 on your keyboard,
you can access 3D Layout Mode. By default, the .PcbDoc opens in 2D Layout Mode
when it is first created. That is the mode we are in right now.

In order to edit the board shape, you want to be in Board Planning Mode, so press 1 on
your keyboard. Once you are in Board Planning Mode, you should see the black rectan-
gle on your screen is now green. In the upper left of your screen, go to Design→Edit
Board Shape, as shown in Figure 8.

Figure 8: Screenshot of steps to edit board shape from the menu

You should see a white border appear around the green rectangle. You can now drag the
edges of the board to make it the size that you want, as shown in Figure 9. Note that you
need to respect your origin, so make sure you are only adjusting the right and top edges
of the board. If you touch the other sides of the board, you will need to reset your origin.
As a note, if you need to set your board to a specific size, it helps to look at the bottom
left corner of your screen where you can find the coordinates of your cursor. For example,
if you wanted to make a board that was 800 mil x 500 mil, you could drag the right edge
inward until you reach an x value of 800 and drag the top edge downward until you reach
a y value of 500.
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Figure 9: Screenshot showing how to edit board shape by dragging board edges

2.4 Tasks

In this section, you are going to prepare a PCB file for your project. Using the techniques
discussed above, complete the following steps:

1. Add a new PCB file to your .PrjPcb file for your CAN transceiver project.

2. Set the origin to the bottom left corner of the black rectangle on the screen.

3. Press 1 on your keyboard to enter Board Planning Mode.

4. Change the dimensions of your board to be 940 mil horizontally and 610 mil
vertically. This is not a standard size, but is just what we will be using for this
practice project. (Hint: Look in the bottom left corner for your coordinates!). Note:
If for some reason your coordinates are in mm instead of mils, simply
press ’q’ on your keyboard to switch units.

5. Once you are done adjusting the dimensions of your board, press 2 on your keyboard
to return to 2D layout mode.
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3 Beginning Your PCB Layout

Yay! You have successfully set up your .PcbDoc file and are ready to move everything over
from your schematic to your new PCB! In this section, you will learn how to import from
your schematic and create a PCB layout. For this section, it is very important to make
sure that you have your schematic and PCB under the same .PrjPcb file, otherwise im-
porting won’t work.

3.1 Moving from Schematic to PCB Layout

To begin, you should be in 2D Layout Mode (press 2 on your keyboard if you are not in
2D Layout Mode already). Go up to the upper left of your screen and select Design→
Import Changes From [Your Project Name], as shown in Figure 10.

Figure 10: Screenshot of steps to import changes to PCB

Another window will pop up that is called the Engineering Change Order or ECO. Think
of it sort of like someone reading you back your order. The ECO just wants to make sure
it is going to be doing everything you would like before you go through with it.

3.1.1 Understanding the Engineering Change Order

Below are some example images (Figures 11 - 15) from an Engineering Change Order.
Note that you may have different sections in yours.

Figure 11: Screenshot of Engineering Change Order window
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In Figure 11 we see part of the ECO that pops up. It may seem overwhelming at first, but
we’ll break it down piece by piece.

Figure 12: Screenshot of ECO Adding Components

In Figure 12, the ECO is showing all the components that it is going to add to your schematic.
It’s basically saying, ”Hey, I noticed that all these components on your schematic are miss-
ing from your PCB. I’ll add them for you.” If this is okay (which it usually is), leave the
boxes checked.

Figure 13: Screenshot of ECO Adding Nets

In Figure 13, the ECO is showing all the nets that it is going to add to your schematic.
Like with the components, the ECO is trying to tell you, ”Hey, I’m going to add these
nets that I noticed are missing.” This is normal for your first time importing from the
schematic in a project. Leave the boxes checked.

Figure 14: Screenshot of Removing Rooms from ECO

In Figure 14 we see three different sections of the ECO. One is called ”Add Component
Classes.” To be honest, I’m not sure exactly what that one does. I’d just leave it. In gen-
eral, if you don’t know what an ECO section is doing, it is usually okay to just leave it.
The only ones I really uncheck (other than the rooms which I will mention in a moment)
are the ones where it is trying to change names of components I have already renamed in
the PCB. This is not shown in the above example, but I am just letting you know you
might see it. The second section shown in the figure is called ”Add Differential Pairs.”

10



This one is definitely important because you want to make sure your differential pairs
are routed correctly. If you are making a board that you expect to have differential pairs,
but you don’t see the ”Add Differential Pairs” section in the initial ECO, go back to your
schematic and make sure you marked and labeled the differential pair nets correctly. The
last section in the figure is called ”Add Rooms.” I almost always uncheck the box for this
one. Rooms basically collect all of your components for a particular schematic and import
them in a little box. It’s annoying for a board coming from one schematic because then
you just have to delete the room, but they are helpful for designs that involve multiple
schematics coming into one board because it improves organization.

Figure 15: Screenshot of a Successful ECO

In Figure 15, we see there are two columns of green check marks next to each row of the
ECO. When you see the ECO, you should scroll through and uncheck anything you don’t
need. Then click the Validate Changes in the bottom left corner of the window. The
first column of check marks should appear. If you see a red x instead of a green check,
that means that there is a problem and you should consider cancelling the ECO and go-
ing back to the schematic to see what’s wrong. However, sometimes a red x will appear
on the first time you run the ECO for a project because nothing is on the board yet. For
example, you will likely see a red x next to ”Add Differential Pairs” because it doesn’t
think those nets have been added yet, but once you execute the changes, it’ll realize it’s
okay. When you are satisfied with the ECO and have validated the changes, click Exe-
cute Changes, which is the button in the bottom left that is directly next to the Vali-
date Changes button. If you see all green check marks, you’re good to go. If you see any-
more x’s, no worries. Just Ctrl+Z it to get rid of what you just did and go back and fix
whatever upset the ECO. Sometimes it’s an iterative process. Note that anytime you up-
date the schematic (even if you already have things placed on the PCB), you need to im-
port your changes and run through a new ECO. Sometimes it will even ask you to match
nets if you have recently replaced components or changed net names. I usually like to do
this manually so that I can see what it is pairing up.
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3.2 Initial Layout

Once the ECO is complete, you should now see your components all gathered off to the
right of your board, as shown in Figure 16.

Figure 16: Screenshot showing components generated after ECO

The first thing you are going to want to do is to make a rough initial layout. This is where
you take a look at what you have on your schematic and you place components in the gen-
eral area they’ll need to be in. This is the time to think logically about how your board is
going to be connecting to other boards in the system. For this board, think about where
the power should come in, where the signals should come in, and where the signals should
leave. In this example, I recommend having the TXD/RXD signals coming in on the left,
the CAN signals leaving on the right, and power coming in near the bottom, just for this
example. You should also begin rotating components so that they are in a good orienta-
tion for connection. Line up pads that are on the same net so that the traces connecting
them can be shorter. You will see faint lines connecting the pads before you route them,
and these are called airwires. In general, you want to try to minimize the number of cross-
ing airwires because this will make it easier to route things later, but don’t stress about
uncrossing all of them, because that’s basically impossible in a lot of cases.

3.2.1 Helpful Shortcuts and Tips

1. It doesn’t have to be perfect yet! Don’t forget that this is just a rough draft of the
board layout.

2. Clicking and holding a component and pressing space at the same time will rotate it
just like it does in the schematic.

3. Right click and hold allows you to grab and move your PCB space.

4. Left clicking and dragging from right to left to select objects allows you to select an
entire object by only touching part of it.

5. Left clicking and dragging a from left to right to select objects allows you to select
an entire object only by dragging over the entire object. This is useful when there
are components spaced tightly together and you want to move only one or two of
them.
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6. Clicking the mouse wheel and moving the mouse up/down lets you zoom in/out.

7. Scrolling up and down scrolls your view up and down. Scrolling up and down while
holding the Shift key scrolls your view left and right.

3.3 Fine-Tuning the Layout

Once you have completed your initial layout to your satisfaction, you are ready to fine-
tune it and make it ready for routing.

3.3.1 A Bit of Theory

• There are certain components on a board that are more important than others. For
example, if this board had a microcontroller on it, it would likely have a crystal os-
cillator. This crystal oscillator or clock resonates at a certain frequency and helps
provide the clocking the microcontroller needs to perform all of its tasks. Without
it, the entire circuit would malfunction. Because of this, special care needs to be
taken to make sure that clocks are placed (and routed) first so that they get prior-
ity. When you are designing a layout with a clock, place the clock and its supporting
components (usually two capacitors) close to the IC, as shown in the ”Best Practices
for Oscillator Layout” document from Atmel (http://ww1.microchip.com/downloads/
en/DeviceDoc/Atmel-8128-Best-Practices-for-the-PCB-Layout-of-Oscillators Application
Note AVR186.pdf).

• Another important component is anything that is analog. Analog signals are very
sensitive and components that are receiving analog signals should be placed far away
from digital signals and components that have significant switching that could in-
terfere with the analog signals. This doesn’t apply to this board, but it is good to
know.

• Components connected to differential pairs and other timing-sensitive signals are also
important. With differential pairs and timing-sensitive signals, you need to make
sure the traces are close to the same length or else one signal will get there slightly
before the others, causing the data to become garbage. To minimize this possibil-
ity, plan to make the traces approximately the same length (and preferably a short
length) by placing their corresponding components near each other.

• Perhaps one of the most important component types to lay out carefully is bypass
or decoupling capacitors. These capacitors connect between power and ground and
help keep voltage in the circuit steady. When you have a lot of switching in the IC,
voltage is bound to drop sometimes, but when this happens, the bypass capacitor
is there acting as a sort of reservoir that will push the system to the right level to
keep things steady. The only problem here is that nothing is ideal. In reality, there
is parasitic inductance in PCB traces that can cancel out some of the benefit of these
capacitors. To minimize the parasitic inductance, all you have to do is place the by-
pass capacitors as close as possible to their corresponding IC power and ground pins.
See the example layout at the beginning of this document for an example.
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3.3.2 Some More Tips

In general, whenever you are making a board, you want it to be something that you are
proud of. Making the layout clean and as symmetric as possible helps you put your best
foot forward (especially if you are going to be showing off your board to potential employ-
ers). Below are some tips to help fine-tune your layout.

• A useful thing to do when fine-tuning your layout is to align components so that
they aren’t placed haphazardly. There are a few ways to do this. You can either
double click a component and change its X/Y location in its properties (as shown
in Figure 17) so it is at the same X or Y position as the component you are aligning
with. Or, the easier option is to use the align tool. Simply select the components you
would like to align, right click one of them, and select Align then whichever type of
alignment you would like. In the example shown in Figure 18, we want the compo-
nents to be at the same vertical height, so we can select Align Vertical Centers.
If you want them to be at the same horizontal position, you can select Align Hor-
izontal Centers. Once you select your alignment type, click the component you
would like the alignment to be referenced to, then the other components should fall
into place automatically.

Figure 17: Screenshot of X/Y location settings in Properties panel

Figure 18: Example of using the Align Vertical Centers alignment type

• Another type of alignment that is helpful is distributing components vertically or
horizontally. Especially when you have many of the same component that you would
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like to have in a nice row or column, you can select them, right click on one of the
components, then select Align and whichever alignment type you would like. In Fig-
ure 19, we are distributing the components horizontally, which will space them out
evenly horizontally. Sometimes this doesn’t work as expected though because com-
ponents can have different origins which makes it tricky to figure out how to align
them. Ctrl+Z is your friend if anything goes wrong. No worries, just try again!

Figure 19: Example of using the Distribute Horizontally alignment type

• Another useful trick is to use the selection filter. Let’s say you only want to change
the size of the text (because maybe it is distracting and large, which it often is by
default). Instead of having to go around selecting every piece of text, you can simply
use the selection filter to select only text. Go into the bottom right corner of your
Altium screen and select Panels then Properties. At the top, you should see some-
thing like in Figure 20, which has every object type in blue showing that they could
all be selected. Select the All-On button in the Selection Filter to turn all of the ob-
jects grey (meaning that none of them can be selected on the board). Click on your
desired objects (in this case, Texts) and they should turn blue again. This means
you can select them on the board. Use Ctrl+A to easily select all of the text now.
Figure 21 shows how to set the Selection Filter for texts only. With all of the text
selected, you can even change the size of all of the text at once, as shown in Figure
22. I like to set my text size to a text height of 36 mil and a stroke width of 6
mil. This works for JLCPCB, which is the company we usually order boards from.

Figure 20: Screenshot of default selection filter
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Figure 21: Screenshot of selection filter set for texts only

Figure 22: Screenshot showing text adjustment in properties

16



• AN IMPORTANT NOTE ABOUT THE SELECTION FILTER: Make
sure you go back and make it so that all the objects are blue in the se-
lection filter again. Selecting the ”Custom” button at the top of the se-
lection filter should do this. If you forget to set it back to letting you se-
lect all objects, you may find that you suddenly can’t move components,
traces, etc. When in doubt, check the selection filter!
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3.4 Tasks

In this section, you are going to create a PCB layout for your project. Using the tech-
niques discussed above, complete the following steps:

1. Import changes from your schematic to your PCB.

2. When all your components are imported, create an initial layout (remember this is
just a rough draft! The components don’t have to be perfectly aligned just yet). It
should look something like this:

Figure 23: Initial layout example for CAN Transceiver board

3. Once you are happy with your initial layout, fine-tune it so that components are
better aligned for routing (and for aesthetics). A decent fine-tuned board layout is
shown in Figure 24.

Figure 24: Example of a decent fine-tuned PCB layout ready for routing
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4 Routing

Once you are done with the PCB layout, you are ready to route all of your traces! Note
that it is still totally okay to readjust your layout as you go to make routing easier (I do
it all the time because often you’ll place things in an area that makes sense but once you
go to route it, you realize there’s no space!). Be patient, be kind to yourself, and think of
PCB layout and routing as a sort of puzzle. Honestly, one of my biggest pieces of advice
if you ever get stuck and feel like there’s no way to route something is to take a step back
and ask yourself, ”Why is this component in this position?” See if you can figure out new
ways the component could be placed so that you can route more efficiently. Think outside
of the box. I like to think of it like entering your apartment on move-in day. Most of the
time, the furniture is not exactly where you’d like for it to be. Maybe the desk is facing
the wrong way or the bed isn’t at the height you like. You have to take a look at the room
and reimagine how the furniture could be arranged so that it is functional and aestheti-
cally pleasing. This is essentially exactly what you are doing when designing a PCB.

4.1 Setting Rules

Before we begin routing, it is important to make sure that you don’t get too far without
setting some rules for your design. JLCPCB, a company we can order our PCBs from, has
certain requirements for boards you submit. If your boards don’t fit their requirements,
their machines can’t make it. We won’t go over all the nitty-gritty details of their rules in
this document (more details can be found on their website, or on the website of any fab
house you choose to send boards to). For this practice project, you will only need to set a
few rules to get started. To get to the rules, you need to go to Design→Rules as shown
in Figure 25. Note that usually, design rules should be set before starting the PCB, but
we are doing them now because I didn’t want you to worry about them when you were
learning the basics of creating a layout.

Figure 25: Screenshot of steps to get to the rules menu

The following are three rules you will want to update.

1. The default trace width often does not give you the full range of trace widths that
you will want. When you are in the rules menu, go to Routing→Width as shown
in Figure 26 and set the minimum trace width to 5 mil and the maximum trace
width to 20 mil for each layer.
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Figure 26: Screenshot of trace width rule settings

2. The default polygon connect style is with thermal reliefs, which look like little tabs
that attach to the pads when there is a polygon connected. In general, it is nice to
have thermal reliefs when you have a very large board with a ground plane because
when you solder, the ground plane will take heat away from your soldering iron and
make it impossible to melt the solder if you don’t have thermal reliefs. However, for
small boards like this one, it’s not a big deal (and I think it helps to make a more
reliable connection to the pad for current to pass through, but whether or not you
use thermal reliefs is up to the requirements of your design). To change the poly-
gon connect style, go into the rules menu then go to Plane→Polygon Connect
Style→PolygonConnect (or make a new PolygonConnect rule if there isn’t one
called PolygonConnect already). Using the Connect Style dropdown, select Direct
Connect. Figure 27 shows how to set the polygon connect style to direct connect.

3. Soon we will be adding polygon pours to your PCB. It is best practice to make sure
that the polygons are not directly against the edge of the boards, where they risk
damage. I like to have mine at least 30 mil away from each edge. To set this in the
rules, go into the rules menu then scroll down on the left side of the menu to Board
Outline Clearance and make a new rule (by clicking New Rule at the bottom),
as shown in Figure 28. Double click the new rule to enter its settings. As shown in
Figure 29, set the polygon outline edge clearance to 30 while leaving everything else
at its default.

Make sure that you hit Apply and OK before closing out of the rules menu.
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Figure 27: Screenshot of polygon connect rule settings

Figure 28: Screenshot of the creation of a new Board Outline Clearance rule
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Figure 29: Screenshot of the board outline clearance rule settings

4.2 Routing Differential Traces

Finally we are ready to start routing! To begin, let’s start with our trickiest and most im-
portant traces: the differential pair! To route a differential pair, all you have to do is go to
the upper toolbar and right click the interactive routing tool to show other options. Then
select the interactive differential pair routing tool, as shown in Figure 30.

Figure 30: Screenshot of toolbar showing interactive differential pair routing tool

Once you have selected the right tool, go to any pad that is connected to the differential
pair, and click the center of the pad. Begin moving your cursor over to where you would
like to connect to another pad. Because this is a differential pair, the second trace should
be automatically routing for you and should hopefully be approximately the same length
(remember that length matching as closely as possible is important for differential pairs).
Click on the center of the pad you would like to end on. Figure 31 shows you how to be-
gin a differential pair trace. When routing differential pairs, try your best to make them
symmetrical so that they are approximately the same length. Figure 32 is an example of
what NOT to do. The problem is that the traces are very wiggly and are likely not length-
matched as well as they would be if they were straight for more of the distance.
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Figure 31: Screenshot showing the beginnings of routing a differential pair

Figure 32: Screenshot showing what NOT to do when routing a differential pair
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4.3 How to Route a Single Trace

After you have routed your differential traces, you can go ahead and route your regular
old traces everywhere else (except for power and ground nets). Make sure you still do
more important traces first (if you have clock traces, analog traces, etc.). To route a sin-
gle trace, you go up to the same tool as before for the interactive differential pair routing,
except you click the button for regular interactive routing, as shown in Figure 33. As an
aside, you’ll probably hear people talk about using an ”auto-router” sometimes to do the
routing for them. I am not going to teach you to use the auto-router because at the end of
the day, it is a computer and you are a human. You know better than it does where your
important traces need to be. Trust your own routing!

Figure 33: Screenshot showing the interactive routing tool

Just like the differential routing, to start a trace, simply click the center of a pad and then
move your cursor to where you would like the end of the trace to go. Note that you can
always place a trace and then drag it around to adjust its shape later. Figure 34 shows
what it looks like to begin a trace that is not differential.

Figure 34: Screenshot of what it looks like to begin a regular trace

You may be wondering why I keep saying that you should click the centers of pads when
you are doing your routing. It is best practice to have your traces connect to the centers
of pads, so it is a good habit to get into. Another important best practice is to make sure
your traces have only straight pieces or straight pieces connected with 45 degree angles.
You never want to have a 90 degree angle in your trace if you can help it. When a signal
is propagating through the trace, it has a much harder time when you have a 90 degree
angle that makes it suddenly change direction as opposed to changing direction a bit more
smoothly with a series of 45 degree angles.

4.4 Polygons

Once you have routed all traces (except for power and ground), you are ready to make
your polygons. What is a polygon, you ask? A polygon (or polygon pour or copper pour)
is basically a large region of copper that connects multiple pads on the board at once. It
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can be used on pads that are nearby and on the same net other than power and ground,
but power and ground polygons are probably used most often. All you have to do to make
a polygon is go up to the top toolbar and select the polygon tool, as shown in Figure 35.

Figure 35: Screenshot showing polygon tool

Once you select the polygon tool, you can begin drawing your polygon around the pads
you want to be covered. Click each vertex to place the corner. You can choose to make it
a rectangle across the area that contains the pads (in which case copper won’t be poured
around other nets inside that don’t match your target net) or you can make a more ”ab-
stract” shape that only covers the pads you want. It is up to you, but if you choose to
be a bit more abstract, try to make the edges at least look nice. I find that the polygon
tool often likes to make my polygon corners look really weird (like in Figure 36), so once
you are done making the shape, feel free to go back and drag those corners into the place
you’d actually like.

Figure 36: Screenshot of problematic polygon corner

Once you have drawn your polygon, double click it to open up its properties tab on the
right panel. There are a few important settings to make sure you set up. First, you want
to set the polygon’s net, as shown in Figure 37. For example, if you are making a polygon
for 5V pads, you will want the net to be 5V. Also verify that the polygon is on the layer
you want. For this project, everything will be on the top layer, but in future projects you
may have bottom layer polygons, in which case you would simply select bottom layer from
the layer dropdown.
Next, if you scroll down in the polygon settings a bit, you will see something that looks
like the image in Figure 38.
You should see four check boxes and a dropdown. The Remove Islands check box basically
says, ”If there is a little area of copper that is less than what is specified, I will just not
pour copper there.” This is fine to leave checked, but sometimes on really small pours you
need to uncheck it so that the polygon actually shows up. The Remove Necks check box
basically says, ”If there is a little copper peninsula that is less than what is specified, I will
just not pour copper there.” Again, this is usually fine to leave checked, but if your pour
is really small, you may want to uncheck it just to make sure the polygon actually shows
up. Check the box below that says ”Remove Dead Copper.” This is useful because it does
sort of what the other boxes do and keeps you from pouring copper that doesn’t really do
anything. Finally, the last box says ”Optimal Void Rotation.” I really don’t know what
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Figure 37: Screenshot showing where to adjust the polygon net and layer

Figure 38: Screenshot of more polygon settings
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that one does, so I just always leave it checked. In the dropdown, make sure you select
Pour Over All Same Net Objects. This should be sufficient for most of your polygon
needs.

Once you are finished in the settings, click Repour at the top of the polygon settings, or
right click the polygon and select Polygon Actions→Repour All as shown in Figure
39. The polygon should then cover the space that you specified.

Figure 39: Screenshot showing how to repour polygon

4.5 Helpful Shortcuts and Tips

• While you are routing, if you press the Tab key on your keyboard, you pause the
routing and open up the trace settings. From there, you can adjust the trace width
(in the bottom right under ”Width”) if you so choose, and simply press the pause
button in the center of the screen to resume routing with your new trace width. This
process is shown in Figure 40.

Figure 40: Screenshot showing how to adjust trace width while routing
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• Feel free to get creative with your routing! Sometimes it is possible to even route un-
der components, as shown in Figure 41. As you can see, we are still using our best
practices of ending the traces in the centers of the pads and avoiding 90 degree an-
gles, we just found additional routing space under the IC. Note that you can’t do
this with all ICs because sometimes they have pads beneath them, but if not, you
can certainly use this technique. You can also route beneath resistors and capacitors
if there is space. However, NEVER route beneath a crystal oscillator unless you are
on a different layer (we’ll see this later).

Figure 41: Screenshot showing some clever routing beneath an IC

• If you are ever trying to adjust traces but a polygon you poured is getting in the
way, don’t delete the polygon, just shelve it! To shelve a polygon (putting it away
for later), simply right click, select Polygon Actions→Shelve Selected, as shown
in Figure 42. This removes your polygon and holds it in the polygon manager until
you are ready to restore it.

Figure 42: Screenshot showing how to shelve a polygon

To get the polygon back when you’re ready, you can either go to Tools→Polygon
Pours→Polygon Manager or I would recommend simply going to Tools→Polygon
Pours→Restore Shelved Polygons, as shown in Figure 43. This will put your
polygons back. Just remember to repour them! Figure 44 shows how to access the
Polygon Manager if you choose the harder method.
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Figure 43: Screenshot showing how to restore polygon

Figure 44: Screenshot showing how to access the polygon manager (if desired)

• You may notice that when you are placing polygons, it is important to have match-
ing pads close to each other. This is an important layout consideration. For exam-
ple, if you want to connect all the 5V pads to one polygon, you will want them to
all be in relatively the same area. This is especially important to do with power and
ground pads on two-layer boards like the one in this project.

4.6 Tasks

In this section, you are going to route your PCB. Using the techniques discussed above,
complete the following steps. NOTE: PLEASE USE 15 MIL TRACE WIDTH FOR ALL
TRACES ON THIS BOARD. This is not a set standard, but will work for this board. You
may need to go into the rules and adjust the minimum trace width settings.

1. Update the trace width, polygon connect style, and board outline clearance rules as
discussed in the above section.

2. Route the differential traces first. Remember that we route differential traces, clock
traces, and other sensitive and time-dependent traces first because they are most
important!
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3. Route all other traces besides 5V and GND. Remember to try to get them to meet
the components in the center of the pads and without snaking around at right an-
gles!

4. Create a 5V polygon pour to cover the 5V pin of the IC, the 5V pad of the bypass
capacitor, and the 5V pad of the power header. You may need to go into the rules
and adjust the polygon connect style to direct connect (which is desired for this
project).

5. Create a GND polygon pour across the rest of the board. Make sure that you have
set the board outline clearance in your rules so that the polygon will end 30 mils
from the edges of the board.
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5 Silkscreen

Finally, you’re done with your layout and routing! You’re almost done! All you need to do
now is adjust your silkscreen and add some finishing touches! What is silkscreen? Silkscreen
(on the Top Overlay layer) appears as yellow text in 2D layout mode and white text on
the actual board. It’s the little letters and shapes that help you label things on the board.

5.1 Adding Useful Silkscreen

Whenever you are making a board, think about the end user. Are you the only one using
this board? Probably not. You’re an expert on how this board works, but another user
may not be, so make sure that your silkscreen makes it clear how to use the board. Exam-
ples include labeling the power connector with a ”5V” and ”G” to show which pin is for
power and which is for ground. You can also add a label naming the board (maybe call
this one something like ”CAN Board”) so that other users don’t have to struggle to figure
out what the device is. The first thing I would suggest doing is cleaning up the silkscreen
you already have for each component. You can select multiple texts and align or evenly
distribute them (using the alignment tool from earlier), and you can rotate them to make
them fit better on the board. NOTE: Be consistent in your silkscreen placement!
It is okay to have some text horizontal and some vertical, but be consistent in what direc-
tion they face. Figure 45 shows an example of what good silkscreen orientation looks like.
Figure 46 shows an example of messy silkscreen you should NOT have.

Figure 45: Screenshot of nice and consistent silkscreen orientations

There is one case where having silkscreen in multiple different orientations may be help-
ful. If you know which way the user will be looking at the board while plugging things in,
you will want to have the text on the connectors facing in such a way that the text will be
right-side up when it is being read. See the sample 3D model of the board at the begin-
ning of this document for an example.

Once you have adjusted the silkscreen from the components (also, make sure that it isn’t
overlapping any pads or going off the edges of the boards, because then you won’t be able
to see it on your final product!), you can add the additional silkscreen we talked about
earlier (the labels that will help the end user know what’s going on, such as 5V and GND
labels on power connectors and a board title naming what the board is). To add new text,
go up to the upper toolbar and select the text tool, as shown in Figure 47.
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Figure 46: Screenshot of messy silkscreen orientations that you should AVOID

Figure 47: Screenshot showing the location of the text tool

Once you have selected the text tool, click anywhere on or around the board to place your
text. You will notice that by default, the word ”String” will appear in red. This is NOT
what you want to leave it as! Double click the text to bring up the text properties in the
right panel, as shown in Figure 48. In the field labeled ”Text,” replace the default text
with the text you actually want. In the layer dropdown, make sure you choose the yel-
low Top Overlay layer. This step is EXTREMELY important because it makes sure
that the text is actually a part of the silkscreen. If you leave the text in its default red
form, that means that it will be on the top layer, and you will essentially be writing with
copper traces! To change the text size, simply adjust the values in the text height and
stroke width fields. I prefer to have my text with a Text Height of 36 mil and a Stroke
Width of 6 mil because that fits the standards of JLCPCB.

32



Figure 48: Screenshot showing the text settings

5.2 Tasks

In this section, you are going to add to the silkscreen on your PCB. Using the techniques
discussed above, complete the following steps:

1. Add silkscreen labels for ’TX’ and ’RX’ on the left connector.

2. Add silkscreen labels for ’G’ (or ’GND’) and ’5V’ on the bottom connector.

3. Add silkscreen labels for ’H’ (or ’CANH’) and ’L’ (or ’CANL’) on the right connector
that goes to the differential pair.

4. Add a board title of some sort (e.g. ’CAN Board’) somewhere on the board.

5. Clean the silkscreen as you see fit (align it, make sure they are facing in logical direc-
tions, etc.).
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6 Additional Details

At this point, you’re basically done! There are just a few finishing touches that you can
add to make your board even better. While there are lots of options here, we will only go
over two of them for now. Later, we will discuss more options such as via stitching. Addi-
tionally, usually you will end a board design by running the DRC (design rule check), but
that is not in the scope of this workshop or document. The purpose of this document is
just to teach you the skills you need to make a PCB layout in Altium.

6.1 Adding Test Points

While you can often probe pins on the board while you are testing the physical board it-
self, sometimes it is useful to have little test pads/points that you can place your probe
on. To make a simple test point, all you need to do is go up to the upper toolbar, right
click the via tool to see more options, and select the pad tool. This process is shown in
Figure 49.

Figure 49: Screenshot showing how to access the pad tool from the upper toolbar

Once you have selected the pad tool, click the location on the board where you would
like to place the pad. You can attach pads to traces with smaller branching traces, or you
can do what I would recommend and place it on a polygon somewhere. For example, you
could create a ground test point by placing the pad on a ground pour. Double click on
the test pad you have place to bring up the pad settings. In Figure 50, we see the first
few pad settings and how to select the pad layer. Make sure that the layer shown on the
Layer dropdown matches the layer you would like the pad to live on. Don’t leave it on
multilayer. Next, in the Net field, shown in Figure 51, set it to the name of the net you
are adding the pad to. For example, if you are putting a test point on a ground polygon,
your net will be GND. The rest of the settings shown in Figures 50 and 51 can be left as
their defaults.
If you scroll down a little farther in the pad settings, you will see where you can adjust the
size, as shown in Figure 52. The X/Y sets the diameter. If you would like a circular pad,
set both to the same value. Leave all other settings shown in Figure 52 as their defaults.
When you are done adjusting the pad, be sure to repour all polygons.
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Figure 50: Screenshot showing pad layer settings

Figure 51: Settings showing how to set pad net
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Figure 52: Screenshot showing how to adjust pad size settings

6.2 Adding Mounting Holes

Often, you will want to add mounting holes to your boards. You can use them to attach
standoffs that help your board stand steady when you place it down on a lab bench, or
you can use them for screws to attach to something like a robot. There are many standard
sizes for mounting holes, but in this practice project, we will be using M2 size holes, which
have an 86.6 mil hole size. Adding a mounting hole isn’t any harder than adding a pad.
To add a mounting hole, click the pad tool again, then place your pad where you want a
mounting hole (usually in one of the corners of the board). Double click the pad to open
its settings. You can set the pad’s location to a specific spot by changing the X/Y location
in its properties, as shown at the bottom of Figure 53. Note that this is NOT the same as
the X/Y size of the pad, which is shown lower in the settings. I usually like to have my
mounting holes 100 mil from the edges. So if I had a board that was 600 mil x 500 mil,
the center of my upper right mounting hole would be at 500 mil horizontal and 400 mil
vertical.

Once your mounting hole is in the location you want, make sure that the layer is set to
Multilayer. We didn’t want this before with the test points because we wanted those
pads to be on the top layer for us to probe. However, for mounting holes, we want them
to go through all the layers, so leave the layer setting on multilayer. Also, make sure that
your net for the mounting hole is set to No Net. This is sufficient for our purposes. Fi-
nally, scroll down in the settings until you reach the section about pad/mounting hole
size, as shown in Figure 54. What really matters here is the hole size. Set the X/Y size to
something small, like 10 mil in each direction, so that the hole is much larger than the rest
of the pad (we don’t want to see an actual pad). In the Hole Size field, type in the hole
size you would like for your mounting hole. For M2, the value is 86.6 mil. You should now
have a nice mounting hole! You can take a look at the sample 3D layout at the beginning
of this document for an example of what mounting holes should look like on a board.
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Figure 53: Screenshot showing how to access pad location settings

Figure 54: Screenshot showing how to adjust mounting hole size in the pad settings

6.3 Tasks

In this section, you are going to practice adding test points and mounting holes to your
board. Using the techniques discussed above, complete the following steps:

1. Add a test point to GND somewhere on the board. Make the pad 50 mil in diameter
and make sure it is labeled.

2. Add four M2 mounting holes (86.6 mil hole size), one to each corner of the board.
Try to make them about 100 mil from each edge in the corner (e.g. the upper right
hole will be 100 mil below the top and 100 mil left of the side, so it will be at the
coordinates 840, 510).
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7 Bonus Material: Multilayer PCB Techniques

Now that you have two-layer PCB design down, I want to teach you some techniques that
you can apply to multilayer PCB design!

7.1 The Layer Stack

When making a one- or two-layer board, both layers are signal (routing) layers, meaning
you can route traces on the top or bottom of the board. With a multilayer board, we add
additional copper layers into the board so that you have more room to route (not just on
the top and bottom) and/or so you can connect to power and ground more effectively.
There are many different layer configurations that are used for different purposes, and
boards can have anywhere from 1 layer to dozens of layers and beyond. Adding more lay-
ers greatly increases the cost though, so for most hobby applications, I recommend sticking
with either 2-layer or 4-layer PCBs. Otherwise things would get way too expensive.

7.2 Adjusting the Stackup

The stackup that we will be using is (from top to bottom): Signal, Ground, Power, Signal.
This means that you will be able to route on the top and bottom layers and then connect
to the second layer for ground and the third layer for power. This is the stackup that has
been used in all 4-layer boards I have made before, but it is not the only option. How do
we tell Altium this is the stackup we want? We need to go into the Layer Stack Manager!
Go to the Layer Stack Manager by going to Design→Layer Stack Manager as shown
in Figure 55.

Figure 55: Screenshot showing how to access the Layer Stack Manager

Once the Layer Stack Manager opens, you should see the default 2-layer stackup (2-layer
as in 2 copper layers–solder mask, prepreg, etc. doesn’t count), as shown in Figure 56.

We need to add two new layers. We can do this in one step because Altium will mirror
the layers for us by default. Right click the first copper layer where it says ”Top Layer”
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Figure 56: Default Layer Stack

Figure 57: Screenshot showing how to add an additional layer (or layers) to the layer stack

and select Insert Layer Below→Signal, as shown in Figure 57. This creates new signal
layers. When this is complete, you should see something like what is shown in Figure 58.
Now, rename Layer 1 ”GND” and Layer 2 ”Power” (click the box that says the layer name
and then type in what you want). Your final stackup should match Figure 59.
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Figure 58: Layer stack updated to have four layers

Figure 59: Final stackup for our multilayer board

You may notice that there are a ton of extra layers and values that we haven’t touched.
(Also note that the copper layers are the only ones we count when describing how many
layers a PCB is). The defaults are fine in this case, so we don’t have to change anything
else. The green layers represent the top and bottom overlay and solder mask. The solder
mask is the material (that is often green) that goes on the outside of the board to repel
solder (so the solder goes only on the pads). Top/Bottom Overlay is the layer name for
silkscreen layers on the top and/or bottom of the board. In between the copper layers are
non-conducting materials such as FR-4 (a common PCB material). You often don’t have
to change the values of the dielectric or thickness for these layers because the places that
can fabricate the boards have their own stock of the materials, so you basically have to go
with whatever they have.

7.3 Using Multiple Layers

Alright, now that we have set up the layer stack (make sure you save the stackup when
you’re done adjusting it!), what do we do with it? Basically the same thing as always, but
with just a few adjustments!
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7.3.1 Top Layer

The top layer will still be where you can do a significant portion of your routing, and will
often be where most of your components are. You can change layers in the component
properties (double click on a component then go to the Layer field in the properties win-
dow that pops up) to put your component on the bottom side of the board if you want.
While this is totally valid and common in PCB design as a whole, I recommend not adding
components to the bottom side of the board for projects you are soldering by hand or re-
flow oven because it will make it significantly more difficult to solder in house (unless it’s
like one or two easy things on the bottom). Typically we would like to try to use a reflow
oven to solder tiny surface mount components to the board, but if the board has compo-
nents on both sides, one side will have to be soldered by hand so the reflow oven doesn’t
desolder one side while trying to solder the other.

7.3.2 Bottom Layer

Like the top layer, the bottom layer is a great place to route traces (and place components
if you have to). Feeling trapped on the top layer? Bring the trace to the bottom layer to
get around any ”traffic” then head back up to the top layer to complete the trace! To
switch layers on the board, you will need to place something called a via. A via is basi-
cally just a little plated hole through the board that acts as a tunnel for the trace. We
only use through hole vias (that connect from top to bottom and have little conductive
pads to connect to internal layers as needed) on our boards here, but it is also possible to
have blind vias that connect from the top or bottom to an internal layer or buried vias
that connect internal layers (this is just not necessary for our application and JLCPCB,
the company that I usually use to make my boards, can’t do blind or buried vias). I’ll talk
about vias in more detail later in this document. Once you place the via, go to the bot-
tom of the screen and select the layer you would like (Top, Bottom, etc.), as shown in Fig-
ure 60. This will switch you over to the new layer so you can route and make polygons as
usual. You’ll probably notice that your traces will be a different color. This is totally nor-
mal and just lets you see what is a part of a different layer. If you start getting distracted
by all the colors on the board across all the layers, you can use the shortcut Shift+S to
have Altium focus on one layer at a time. Hitting Shift+S two more times will return you
to the original layer view.

Figure 60: Available layers shown at the bottom of the Altium window. Selecting a differ-
ent layer takes you to that layer.

7.3.3 Ground Layer

The ground layer in our stackup is directly below the top layer and will basically be a
full layer of copper. I recommend just putting a GND polygon across the entire ground
layer. If this gets too distracting toward the beginning of your routing (because you’ll have
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to keep repouring), you can either add the ground polygon at the end (all the GND vias
should connect to it automatically), or you can shelve it until you’re ready to add it back
in. While you’re routing, anything that is connected to ground will connect to this ground
layer through a via somewhere. I would recommend not connecting anything to ground
through a trace if you can because it will look better if you use polygons. What you can
do is create a ground pour (polygon) on the top of the board, on the bottom of the board,
and on the ground layer. Then you can add something called via stitching (basically just
an array of vias) to connect all these ground pours to each other. We’ll talk about via
stitching in a later section of this document. If you end up not adding a ground pour to
the top and bottom of the board, you don’t need via stitching. Instead, you can just con-
nect GND pins using traces to vias connecting to the GND layer. Note that it depends on
your design requirements whether or not you should use a ground pour on top and bottom
and add via stitching. Sometimes it serves to reduce electromagnetic interference or noise,
but other times it could add harmful parasitics. Another note: remember our clock? I said
you should never route traces beneath a crystal oscillator, but it is okay to do so if you
have a GND plane in between them. So if you have a crystal oscillator on the top layer, a
GND layer below it, and traces on the bottom layer, that is okay. The GND layer provides
the necessary shielding.

7.3.4 Power Layer

The power layer is below the GND layer and above the bottom layer in our stackup. The
power layer is a lot like the ground layer in that you will just be adding large polygons
and connecting vias to it from other layers. However, the power layer will likely have more
than one polygon (whereas the ground layer only has one ground polygon). Based on your
voltage requirements, you can place power polygons in convenient places on the power
layer. Take a look at Figure 61, the power layer of a board I have worked on, for an ex-
ample. The polygon in the bottom left is 5V, the polygon in the middle is 3V3, and the
polygon spanning the left and right sides is 6V. Let’s take the 5V polygon as an exam-
ple. I knew the CAN transceiver was in the bottom left corner and that it needed 5V, so
I placed the 5V polygon below it and made sure the screw terminal that was bringing in
the 5V would also be right over the 5V polygon. Placing your power polygons wisely al-
lows you to make things a lot easier while you are connecting your components to power.
One thing I’ll note that is important is that you need to make sure you leave a little bit of
space between your power polygons. You don’t want any shorts!

7.4 Using Vias

7.4.1 Adding Vias

As I’ve mentioned before, vias are little holes in the board that allow you to connect to
different layers. To add a via, first go to the top toolbar and select the via tool, as shown
in Figure 62.

Next, place the via on the board. Normally this will be while you’re routing, but you could
also place one on a polygon if you want. For example, you could be routing on the top
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Figure 61: Example of a power layer on a different board with polygons for different volt-
age levels. The polygon in the bottom left is 5V, the polygon in the middle is 3V3, and
the polygon spanning the left and right sides is 6V.

Figure 62: Via tool on the top toolbar

layer when you reach an obstruction (another top layer trace, a large component, etc.).
To get around this, you can stop the trace, place a via, go to the bottom layer, route on
the bottom layer until you can come back up to the top, place another via, then finish the
route on the top layer. When you place the via, it will often be nowhere near the size you
want, and sometimes it will even connect to the wrong net. You can double click the via
to open up its properties, as shown in Figures 63 and 64. Figure 63 shows the first set of
via settings. All you have to change is the Net field. Make sure you set it to the net you
are routing (or the GND/PWR net you want to connect to). Figure 64 shows the second
set of via settings. There are tons of different sizes of vias you can have, but for this ex-
ample, please use vias with a diameter of 24 mil and a hole size of 12 mil. This also aligns
with JLCPCB’s capabilities. Under the Solder Mask Expansion section, set it to manual,
then take a look at the boxes next to the word ”Tented.” If a via is tented, it means that
it gets covered up by solder mask. It makes it a lot more aesthetically pleasing, so I rec-
ommend you use tenting on the top and bottom wherever you can (so check the tenting
boxes). One example of when you would not want to use via tenting is when you have
a tight layout and want to add test points (maybe around an IC). There often won’t be a
good amount of space for test pads, but non-tented vias (at least non-tented on the top)
can act as test points as long as you know what net it is connected to.
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Figure 63: First set of via settings

Figure 64: Second set of via settings

7.4.2 Adding Via Stitching

On boards with very high frequency and high noise risks (often these are RF boards), it
is sometimes a good idea to add via stitching (again consider the design requirements
first). You can add a ground pour on the top and bottom layers and use via stitching
to connect them together and to the GND layer. This is great for reducing electromag-
netic interference (EMI) and other noise concerns, but is often overkill for most non-RF
boards. It’s a good thing to know though, so it’s good to practice. Make sure that be-
fore you attempt to add via stitching, you shelve the power layer polygons. If you don’t do
this, the via stitching doesn’t like to work for whatever reason. To add via stitching (after
you have all your ground pours on the top, bottom, and GND layers), go to Tools→Via
Stitching/Shielding→Add Stitching to Net. A new settings window will pop up as
shown in Figure 65 that allows you to change the via stitching properties. You can leave
almost everything at its default and play with the spacing later as needed, but what is
most important is the hole size, diameter, net, and tenting. Make sure the hole size is 12
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mil and the diameter is 24 mil (or really just match these sizes with the dimensions of the
rest of your vias). Make sure you set the net to GND so the vias connect to each GND
pour. Finally, force complete tenting on top and bottom (you don’t want so many non-
tented vias–it would be an eyesore!). Make sure you repour all your polygons (including
the restoring and repouring the power polygons) when you’re done! If you want to remove
the via stitching, you can simply go to Tools→Via Stitching/Shielding→Remove
Via Stitching Group then click one of the stitching vias to remove them all.

Figure 65: Via stitching settings
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8 Conclusion

Congratulations! At this point, you should now have a PCB for your CAN transceiver
project as well as some skills you can apply if you want to make two-layer or multilayer
PCBs! You should pat yourself on the back, because Altium can be tricky, but you really
have come incredibly far. Thank you for attending my workshop, and if you ever have any
questions about Altium, don’t hesitate to reach out at emarshall33@gatech.edu!
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