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General 
This document contains all information for 
installation, putting into operation, operation, 
and maintenance or trouble-shooting of the 
system delivered. This document is intended 
for persons with basic knowledge of 
installation and operation of software-
controlled machines. General knowledge of 
operational safety as well as basic knowledge 
of using PCs running Microsoft Windows® are 
required. 

Availability 
A complete and legible copy of this document 
must be available at the operation station. Any 
person who is authorised to operate the 
system must have read and understood this 
document. The facility owner is required to 
ensure that all safety measures listed in this 
document are observed. 

Notations 

Various text attributes, notations, and 
structures are used to facilitate reading and 
understanding the document. The text 
attributes (highlighting) inside this document 
are defined as follows: 

Attribute Function 

Bold Important information 

Italics Brand name 

Bold italics LPKF brand name 

[…] Button 

\...\ Input/display field 

<…> Check box 

{…} Radio button 

>…>…> Menu trail 

/…/ Reference to a number in the 
figure 

Figures 
Figures (photos or drawings) are displayed in 
a frame. Each figure has a numbered figure 
title, e. g. “Fig. 1: Overview”. Numbers in the 
figure mark certain components or actions. 
Arrows in the figure show the direction of an 
action. 

Tables 
Data, facts, and important contexts are 
arranged in tables. Each table has a 
numbered table title, e. g. “Table 1: Scope of 
delivery”. Every table has a highlighted 
header row containing the column headings. 
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Procedures 
In this document, procedures or workflows are 
compiled to step-by-step operation sequen-
ces. An individual operation sequence 
consists of at least three components: Title, 
step, and result 

Component Description 

■ title Description of the objective of 
the procedure marked by a 
preceding “■” 

1. step Consecutively numbered 
sequence of an procedure 

➨ intermediate 
result 

Intermediate result of an 
operation step. The procedure 
continues. 

♦ result Result of the procedure 
marked by a preceding “♦” 

Symbols and signal words 
The following symbols are used to mark 
important information: 

Symbol Description 

 

Safety note 
WARNING – Hazard for persons 
CAUTION – Damage to the 
system 

 

Note 
A note is an information on the 
optimum usage of a feature. 

 

Tip 
A tip contains additional 
information. 

© Copyright 

® Registered Trademark 

Registered Trademarks and Brand names 
The LPKF Logo and the LPKF product names 
are registered trademarks of LPKF Laser & 
Electronics AG. 
Microsoft and Windows are brand names or 
registered trademarks of Microsoft 
Corporation in the USA and/or other 
countries. 
All other trademarks belong to the respective 
owner. 

Standards 
The following standards and guidelines were 
observed when creating this document: 
 

Standard Description 

DIN 5008 
2011-04 

Rules for writing and 
layouting 

VDI 4500 Bl.1,2  
11-2006 

Technical documentation - 
Definitions and legal basics 

DIN EN 82079-1 
2011-04 

Preparation of instructions 
for use. Structuring, content 
and presentation. General 
principles and detailed 
requirements 

DIN EN ISO 
12100  
2011-03 

Safety of machinery - 
General principles for design 
- Risk assessment and risk 
reduction 

DIN EN 60204-1 
2007-06 

Safety of machinery - 
Electrical equipment of 
machines - Part 1: General 
requirements 
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1 Function 
The system software LPKF CircuitPro PM is a powerful application that 
combines two important components of PCB production: Editing of design data 
and machine control. The circuit board plotters made by LPKF are controlled 
with this application running on Windows® computers. 
LPKF CircuitPro PM imports your CAD data, aperture and tool lists and guides 
you step by step through the production of your PCB. Design data will be split 
up into the separate work steps and prepared for the production process. The 
integrated wizards will guide you through the whole PCB production process. 
They will inform you whenever you have to take action (e.g. manual tool change 
or turning over the material for producing a double-sided PCB). 
Use the “Design Rule Check” for checking the width and the spacing of the 
conductor tracks. Violations of the rules will be shown in the message view and 
graphically in the CAM View. Thus, you can make corrections before starting 
the production process. 
The current milling status and position are shown in the machining view, so that 
you can always keep an eye on the production process and progress. 
LPKF CircuitPro PM allows you to create templates for solder resist masks and 
legend printing. Additionally the software supports the automatic tool exchange 
with tool adjustment (depending on the machine type). 
The basic operation of the Windows® graphical user interface is not part of this 
manual. If you are not familiar with using Windows®, please refer to the 
Windows® user manual and online help. 
 

Fig. 1: LPKF 
CircuitPro PM  
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2 Safety notes 
The following chapter describes the most important safety notes while working 
with the software CircuitPro PM and the circuit board plotter. 
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2.1 General safety notes 

 

 
Note 

The usage of the software CircuitPro PM without the circuit 
board plotter has a low risk potential. 

 

 
DANGER 

Follow the safety notes! 

If you do not follow the safety notes injuries or accidents may 
occur.  
Read the manuals of the circuit board plotter and accordingly 
the control software carefully and follow the safety notes.  

 

 
DANGER 

Pay attention to a secure data transfer! 

A malfunction or interruption of data transmission between 
the PC and the circuit board plotter can cause uncontrolled 
machine reactions.  

Check the connection and replace defective or damaged 
cables immediately.  

 

 
DANGER 

Secure the machine against accidental switching on!  

Personal injuries may occur during manual tool exchange or 
maintenance if the machine is accidentally switched on. 
Always secure the machine against unauthorized use and 
accidental switching on.  

 
CAUTION 

Follow the safety regulations!  

The non-observance of the operational and regulatory health 
and safety regulations can cause serious personal injuries.  

Make sure that each operator knows the operational and 
regulatory health and safety regulations.  

 

 
DANGER 

Handling only by trained personnel!  

Improper operation of the machine can cause serious 
personal injuries. 

Instruct each user in handling the machine. 

 
Pos: 4.1 /ED_Technische_Dokumentation/2_Bedi enungsanleitung/Software/CircuitPro 2.1/Kapitel 3_Installati on/01_Installati on_Einl eitung @ 6\mod_1383663406447_2058.docx @ 127146 @ 1 @ 1 
 



 
Installation CircuitPro PM 2.3  

 
 

14 V1.1 – 11.2016 © 2016 LPKF AG 

3 

3 Installation 
This chapter describes how to install the CircuitPro PM program. 
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3.1 System requirements 

The following system requirements must be met for installing CircuitPro PM 
successfully: 

Minimum system requirements for working with CircuitPro PM 

 
Table 1: Minimum 
system 
requirements 

Component Minimum system requirements 

CPU 2 GHz 

RAM 2 GB 

Hard disk memory 2 GB 

Graphics board with 128 MB dedicated memory (non-
shared memory) 
LPKF advises against using the following 
graphics boards as these cause 
problems: 

 Intel 82945G 

Screen resolution 1024 x 768 pixels 

USB port 2 x USB 2.0  

 Supported operating systems Windows XP (32bit) 
Windows 7 (32bit/64bit) 
Windows 8 (64bit) 
Windows 8.1 (64bit) 

 

Recommended system configuration for working with CircuitPro PM 

 
Table 2: 
Recommended 
system 
configuration 

Component Recommended system configuration 

CPU Dual core 2.6 GHz 

RAM 8 GB 

Hard disk memory 2 GB 

Graphics board with 1 GB dedicated memory (non-
shared memory) 
LPKF advises against using the following 
graphics boards as these cause 
problems: 

 Intel 82945G 

Screen resolution 1680 x 1050 pixels 

USB port 2 x USB 2.0  

 Operating system Windows 7 (64bit) 
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Note 

If you are using the Microsoft® Windows 8 operating system, 
please install the Microsoft® .NET Framework 3.5 contained on 
your Windows® 8 DVD before installing CircuitPro PM 2.1. 
The Microsoft® .NET Framework 3.5 cannot be installed 
automatically in Microsoft® Windows 8 due to changes in the 
operating system. 
For further information on installing the Microsoft®.NET 
Framework 3.5 please refer to 
http://support.microsoft.com/kb/2785188/en-us 

  

 

 Required setting in the Windows Power options 3.1.1

The USB power-saving function must be disabled to ensure stable operation of 
CircuitPro PM. The following figure shows the disabled power option as an 
example in Windows 7: 

Fig. 2: Required 
setting in Power 
optins  
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3.2 Installing and starting the software 
 

 
ATTENTION 

Improper installation causes machine damage! 

An incorrect or incomplete installation of the software can 
cause damage to the machine.  

LPKF assumes no liability for damage to the machine caused 
by improper software installation.  

 

 
Note 

Make sure that the machine is not connected to the computer.  
The USB cable must not be connected! 

 

 Installing CircuitPro PM 
1. Switch on the PC. 
2. Open the CD ROM drive and insert the CD ROM “CircuitPro PM” into the 

drive. 

➨ The CD ROM is read. The LPKF setup wizard starts automatically and the 
installation and update information is displayed in your browser's window: 

Fig. 3: Installation 
and update 
information 

 

 
3. Close the browser window displaying the installation and update 

information. 
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Fig. 4: LPKF 
setup wizard 

 

 
4. Click on [Next] to start the installation procedure. 
 

 
Note 

Navigating in the installation program is done by clicking on 
[Back] and [Next]. Click on [Back] to go to the previous 
installation step. Click on [Next] to go to the next installation 
step. The installation is aborted by clicking on [Cancel]. 

 
Fig. 5: License 
agreement 

 

 
5. Read the terms of the license agreement and select {I Agree}. 
6. Click on [Next]. 



 
Installation CircuitPro PM 2.3  

 
 

18 V1.1 – 11.2016 © 2016 LPKF AG 

3 

➨ In the following step, you can choose the folder where CircuitPro PM is to 
be installed: 

Fig. 6: Choosing 
the installation 
folder 

 

 

 
Hinweis 

When using Windows 8, the installation stores the program 
data by default in: 
C:\Program Files (x86)\LPKF Laser & 

Electronics\LPKF CircuitPro PM 2.3\. 
When using Windows 7, the installation stores the program 
data by default in: 
C:\Program Files (x86)\LPKF Laser & 

Electronics\LPKF CircuitPro PM 2.3\. 
When using Windows XP, the installation stores the program 
data by default in: 
C:\Programme\LPKF Laser & Electronics\LPKF 

CircuitPro PM 2.3\. 
Click on [Browse] to install the program data in a folder of 
your choice. 

 

 
Note 

Click on [Back] to review the settings of the previous screens. 
Click on [Cancel] to cancel the installation. 
 

 
7. Click on [Next]. 
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➨ The dialog to confirm the installation is displayed: 
Fig. 7: Confirm 
installation 

 

 
8. Click on [Next]. 

➨ The installation of CircuitPro PM is started: 
Fig. 8: 
Installation of 
CircuitPro PM 2.3 
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➨ The following warning message is displayed during the installation: 
Fig. 9: User 
Account Control 

 

9. Click on [Yes]. 
 

➨ The program is being installed on the PC. Progress of the installation is 
displayed. During the Installation the following warning message is 
displayed: 

Fig. 10: Warning 
message 

 

10. Acknowledge the warning message by clicking on [OK]. 

➨ The following dialog is displayed during the installation: 
Fig. 11: Driver 
installation 

 

11. Click on [Install]. 
 

 
Note 

LPKF recommends to install the camera driver even if the 
camera is not installed.  

➨ The camera driver is installed. 
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➨ When the installation is complete, the following dialog is displayed: 
Fig. 12: 
Installation 
complete 

 

 
12. Click on [Close] to exit the installation program. 
 The CircuitPro PM program has been installed. 

 

 
Note 

A link to the CircuitPro PM program has been created on your 
desktop: 
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 Starting CircuitPro PM 
1. Switch on the machine. 
2. Boot the PC. 

➨ The PC boots and starts the operating system. 
3. Start CircuitPro PM. 

➨ The following splash screen is displayed: 
Fig. 13: 
CircuitPro PM 
splash screen 

 

 

 
Note 

If you already had installed a previous version of CircuitPro on 
your computer, you can decide at this point whether to use your 
previous configuration files. This means that settings that are 
stored in the following folder are also applied to currently 
installed version CircuitPro PM Version 2.3: 
In Windows XP: 
C:\Programme\LPKF Laser & Electronics\LPKF CircuitPro 

1.X\config  

In Windows 7: 
C:\Program Files (x86)\LPKF Laser & Electronics\LPKF 

CircuitPro 1.X\config. 

These settings apply – among others – to the language setting 
and the machine configuration. 

 
4. In the list “Version”, click on the CircuitPro version whose configuration 

settings you want to use and subsequently click on [OK]. 
Or 
4. Click on [Default] if you want to use the default settings of 

CircuitPro PM 2.3. 
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➨ The following dialog is displayed: 

Fig. 14: New 
document 

 

 
5. Select a template file. 
 The CircuitPro PM program is started and the user interface is displayed. 

 

 
Tip 

Language settings 
CircuitPro PM is installed in English by default. If you want to 
change the language setting of CircuitPro PM, perform the 
following steps: 
1. Click on Extras > Options. 
2. Click on the row “Language” and change the value to the 
desired language. 
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3.3 Machine setup 

After CircuitPro PM has been installed on your PC, it has to be configured once 
for the machine and the accompanying equipment. The equipment configuration 
wizard helps you setting up the machine. 
 

 Setting up the machine 
1. Start CircuitPro PM. 

➨ The equipment configuration wizard starts automatically. 
Fig. 15: Start-up 
screen 
“Equipment 
configuration 
wizard” 

 

 

 
Note 

You can also start the equipment configuration wizard 
manually. Click in the menu bar of CircuitPro PM on 
Wizards>Equipment configuration wizard… 

 

 
Note 

ProtoMat X60/H100 
The machine-specific files (*.ini oder *.xml) have to be available at 
the first startup or after replacing the PC.  
Ini file: Has been delivered together with the machine and is stored 
on the data medium of the machine. Or you can copy the ini file of 
an existing BoardMaster installation. 
Xml file: Machine settings exported from CircuitPro PM. 

 
2. Perform all the steps of the equipment configuration wizard and follow the 

corresponding instructions. 

➨ The CAM view is displayed. 
 The machine has been set up. The accompanying available equipment for 

producing PCB prototypes has been configured as well. 

 
Pos: 5.1.1 /ED_Technische_Dokumentation/2_Bedi enungsanleitung/Software/CircuitPro 2.1/Kapitel 4_Aufbau der  Bedi enober fläche/1_Allgemei n/01_Ei nlei tung_Aufbau_der _Bedienoberfläche  @ 5\mod_1381399325984_2058.docx @ 120918 @ 1 @ 1 
 



 
CircuitPro PM 2.3 Structure of the user interface 

   

© 2016 LPKF AG  V1.1 – 11.2016 25 

4 

4 Structure of the user interface 
The following pages describe in detail the structure of the CircuitPro PM user 
interface. 
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4.1 User interface 

The CircuitPro PM user interface is divided into several information and display 
panes that can be displayed or hidden as necessary. The user interface is 
structured as follows: 
 

Fig. 16: CircuitPro user interface 
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Table 3: User 
interface 

 

No. 
 

Pane Name 

/1/  Menu bar 

/2/  “Standard” toolbar 

/3/  “Modify” toolbar 

/4/  “Prototyping” toolbar 

/5/  “Layouts” toolbar 

/6/  “Insert” toolbar 

/7/ Layers The “Layers” pane contains a table listing the 
individual layers of the circuit board to be processed. 

/8/ Navigation The “Navigation” pane displays an overview of the 
project with a zoom rectangle.  

/9/ CAM view Editing pane displaying a 2D representation of the 
project. 

/10/ Status bar The status bar displays the coordinates of the current 
cursor position and of the anchor point. 
Measurement results are displayed in the “Length” 
field. 
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4.2 Views 

In the following, the different views in CircuitPro PM are described in detail. 
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 CAM View 4.2.1

The CAM View allows you to regard the object to be processed two-dimensional 
and the corresponding layers. 
Move your cursor to menu View > CAM 2D… or click “CAM” on the toolbar 
“Layout” to open the following window: 

Fig. 17: CAM 
View 

 
 
In this view you are able to regard both sides of the PCB. According to the 
colors in the pane "Layers" each object on the board is highlighted. 
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 Toolbar CAM view 4.2.2

The toolbar “CAM view” provides following icons:  
Fig. 18: Toolbar 
CAM view 

 

 
The following table provides a brief description of the toolbar’s icons: 

Table 4: Toolbar 
CAM view 

 

No. Function description 

/1/ Polygonal Selection: Click on this icon to select objects by drawing 
polygons. The context menu offers extended functions if this icon is enabled. 

/2/ Selection: This arrow must be enabled to select or create objects in the CAM 
view. 

/3/ Fit all: Click on this icon to fit the whole layout into the CAM view. 

 /4/ Zoom area: Click on this icon and select an area that will be zoomed in 
afterwards.  

 /5/ Zoom: Click on this icon and move your mouse to zoom in/out the layout.  

 /6/ Pan: Click on this icon to move your whole layout to a desired position. 

 /7/ Global Pan: The currently zoomed area will be zoomed out by clicking on this 
icon. If you click on an area in the layout again, this area will be zoomed in. 

 /8/ Set toolpath selection mode: Selects toolpaths within the created polygon. 
Three different modes are available: object, curve and element. 
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Context menu Polygonal selection 

 Displaying the context menu Polygonal selection 
1 Click on the icon [Polygonal selection]. 

➨ The polygonal selection is activated. 
2 Right-click into the CAM view. 
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➨ The following context menu is displayed: 

Fig. 19: Context 
menu “Polygonal 
selection” 

 

 /1/ Remove last point /2/ Select 
 /3/ Cancel  

 
 The context menu Polygonal selection is displayed. 

 
The following table contains a brief description of the context menu's functions: 

Table 5: Context 
menu “Polygonal 
selection” 

 

No. Description 

/1/ Remove last point: Removes the point added last to the polygon. 

/2/ Select: Selects the objects within the polygon. 

 /3/ Cancel: Cancels the creation of the polygon. 
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 Machining view ProtoMat X60 4.2.3

The machining view enables you to regard your process data. 
Click on View > Machining 2D or click on “Machining view” in the toolbar 
“Layout” to open this view: 

Fig. 20: 
Machining view 
X60 

 

 /1/ Processing area /3/ Object to be processed 
 /2/ Axis of reflection /4/ Current head position 

 
When you start the production of a board, the movement of the milling head, 
displayed as crosshairs, is shown in the machining view. 
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 Machining view ProtoMat H100 4.2.4

The machining view enables you to regard your process data. 
Click on View > Machining 2D or click on “Machining view” in the toolbar 
“Layout” to open this view: 

Fig. 21: 
Machining view 
H100 

 

 /1/ Processing area /3/ Object to be processed 
 /2/ Axis of reflection /4/ Current head position 
 /3/ Tool holder  

 
When you start the production of a board, the movement of the milling head, 
displayed as crosshairs, is shown in the machining view. 
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 Machining view E33/E34/E44  4.2.5

The machining view enables you to regard your process data. 
Click on View > Machining 2D or click on “Machining view” in the toolbar 
“Layout” to open this view: 

Fig. 22: 
Machining view 
E33 

 

 /1/ Processing area /3/ Object to be processed 
 /2/ Axis of reflection /4/ Current head position 

 
When you start the production of a board, the movement of the milling head, 
displayed as crosshairs, is shown in the machining view. 
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 Machining view S43 4.2.6

The machining view enables you to regard your process data. 
Click on View > Machining 2D or click on “Machining view” in the toolbar 
“Layout” to open this view:  

Fig. 23: 
Machining view 
S43 

 

 /1/ Processing area /3/ Obejct to be processed 
 /2/ Axis of reflection /4/ Current head position 

 
When you start the production of a board, the movement of the milling head, 
displayed as crosshairs, is shown in the machining view. 
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 Machining view S63/S103  4.2.7

The machining view enables you to regard your process data. 
Click on View > Machining 2D or click on “Machining view” in the toolbar 
“Layout” to open this view:  

Fig. 24: 
Machining view 
S63/S103 

 

/1/ Current head position 
/2/ Tool holder 
/3/ Processing area 

/4/ Axis of reflection 
/5/ Object to be processed 

 

  

 
The tool magazine of the circuit board plotter can pick up to 15 different tools. 
According to the colors of the tool’s distance rings of the LPKF tools, the circles 
in area /2/ are displayed in the same color. 
When you start the production of a board, the movement of the milling head, 
displayed as crosshairs, is shown in the machining view. 
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 Machining view ProtoMat D104  4.2.8

The machining view enables you to regard your process data. 
Click on View > Machining 2D to open this view or click on “Machining view” in 
the toolbar “Layout”. 

Fig. 25: 
Machining view  
D104 

 

 /1/ Processing area /4/ Object to be processed 
 /2/ Tool holder /5/ Axis of reflection 
 /3/ Current head position  

 
The tool magazine of the circuit board plotter can pick up to 15 different tools. 
According to the colors of the tool’s distance rings of the LPKF tools, the circles 
in area /2/ are displayed in the same color. 
When you start the production of a board, the movement of the milling head, 
displayed as crosshairs, is shown in the machining view. 
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 Toolbar Machining view 4.2.9

The toolbar “Machining view” provides following icons: 
Fig. 26: Toolbar 
“Machining view” 

 
 

 
The following table provides a brief description of the toolbar’s icons: 

Table 6: Toolbar 
“Machining 
view” 

 

No. Function description 

/1/ Polygonal Selection: Click on this icon to select objects by drawing 
polygons. The context menu offers extended functions if this icon is enabled. 

/2/ Select: This arrow must be enabled to select or create objects in the machine 
view. 

/3/ Fit All only for Job Data: Only the job data is displayed. Other elements of 
the machining view are hidden. 

 /4/ Fit All for both Job Data and Machine Area: Scales and fits in the layout so 
that the elements of the machining view stay visible. 

 /5/ Zoom area: Click on this icon and select an area that will be zoomed in 
afterwards.  

 /6/ Zoom: Click on this icon and move your mouse to zoom in/out the layout.  

 /7/ Pan: Click on this icon to move your whole layout to a desired position. 

 /8/ Global Pan: The currently zoomed area will be zoomed out by clicking on this 
icon. If you click on a area in the layout again, this area will be zoomed in. 

 /9/ Set toolpath selection mode: Selects toolpaths within the created polygon. 
Three different modes are available: object, curve and element. 
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Context menu Polygonal selection 

 Displaying the context menu Polygonal selection 
1 Click on the icon [Polygonal selection]. 

➨ The polygonal selection is activated. 
2 Right-click into the CAM view. 

  

4 5 6 7 8 1 2 9 3 



 
CircuitPro PM 2.3 Structure of the user interface 

   

© 2016 LPKF AG  V1.1 – 11.2016 37 

4 

➨ The following context menu is displayed: 

Fig. 27: Context 
menu “Polygonal 
selection” 

 

 /1/ Remove last point /2/ Select 
 /3/ Cancel  

 
 The context menu Polygonal selection is displayed. 

 
The following table contains a brief description of the context menu's functions: 

Table 7: Context 
menu “Polygonal 
selection” 

 

No. Description 

/1/ Remove last point: Removes the point added last to the polygon. 

/2/ Select: Selects the objects within the polygon. 

 /3/ Cancel: Cancels the creation of the polygon. 
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 3D View 4.2.10

The 3D View allows you to regard the object to be processed three-
dimensional.  
Click on View > 3D View to open the following window: 

Fig. 28: 3D View 

 

 
Once you have imported a three-dimensional object, it will be shown in this 
view.  
 

 
Note 

Two-dimensional objects can also be shown in this 3D view. 
Therefore you have to highlight the corresponding toolpaths  in 
the pane “Toolpath“ and select “Display in 3D” in the context 
menu.  
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 Toolbar 3D view 4.2.11

The toolbar “3D view” provides following icons: 
Fig. 29: Toolbar 
“3D view” 

 
 
 

 
The following table provides a brief description of the toolbar’s icons: 

Table 8: Toolbar 
“3D view” 

 

No. Function description 

/1/ Selection: This arrow must be enabled to select or create objects in the 3D 
view. 

/2/ Fit all: Click on this icon to fit the whole layout into the 3D view. 

 /3/ Zoom area: Click on this icon and select an area that will be zoomed in 
afterwards. 

 /4/ Zoom: Click on this icon and move your mouse to zoom in/out the layout. 

 /5/ Pan: Click on this icon to move your whole layout to a desired position. 

 /6/ Global Pan: The currently zoomed area will be zoomed out by clicking on this 
icon. If you click on a area in the layout again, this area will be zoomed in. 

 /7/ Front view: Displays the front of the object. 

 /8/ Top View: Displays the top side of the object. 

 /9/ Left View: Displays the left side of the object. 

 /10/ Rear View: Displays the rear side of the object. 

 /11/ Right View: Displays the right side of the object. 

 /12/ Bottom View: Displays the bottom side of the object. 

 /13/ Axonometric View: Standard view that displays the object in a 30° angle. 

 /14/ Rotate: Click on this icon to rotate your object in any direction by using your 
mouse. 

 /15/ Reset View: Resets the current view of your object. 
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4.3 Toolbars 

CircuitPro PM’s toolbars offer you a quick access to functions that are used 
most often. 

Fig. 30: 
Toolbars 

 
 
The following toolbars exist in CircuitPro PM: 

• Standard 
• Insert 
• Modify 
• Layouts  
• Prototyping 

 

 
Note 

You are able to hide/display the toolbars. You can find this 
option under menu Tools > Customize… Go to tab “Toolbars” 
and enable/disable the corresponding checkboxes. 

 
You can arrange the toolbars anywhere on the surface of CircuitPro PM. 

 Changing the toolbar’s position 
1. Move the cursor to the top of the toolbar which is marked with several 

points.  

➨ The cursor takes the shape of a cross. 
2. Hold the left mouse button.  
3. Move the toolbar to the desired location on the user interface.  
 

 
Note 

You can arrange the toolbar on the left, bottom, right or top of 
the user interface.  

 
4. Release the left mouse button.  
 The toolbar is now fixed at the desired location of the user interface. 
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 Toolbar Standard 4.3.1

The toolbar “Standard” provides following icons:  
Fig. 31: Toolbar 
“Standard” 

 

 
The following table provides a brief description of the toolbar’s icons: 

Table 9: Function 
description 
“Standard“ 

 

No. Icon Function description 

/1/ New… Creates a new document in CircuitPro PM. Either you 
are able to create a document based on a standard 
template or you browse your hard disk for own 
templates.  

/2/ Open… Opens an existing CircuitPro PM document. 

/3/ Save Saves the currently edited document with all changes 
under the same name and location. 

/4/ Cut Cuts a selected area in the document. 

/5/ Copy Copies a selected area in the document. 

/6/ Paste Pastes the previously cut or copied region. 

/7/ Print Preview Opens a print preview of the current document. 

/8/ Print Opens the print dialogue. Make your settings for 
printing here. 

/9/ Undo Undo the last action in the document. 

/10/ Redo Redo the previously undone action. 

/11/ Delete Deletes the previously selected objects on the layer. 
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 Toolbar Insert 4.3.2

The toolbar “Insert” provides following icons: 
Fig. 32: 
Toolbar 
“Insert”  

 

 
The following table provides a brief description of the toolbar’s icons: 

Table 10: 
Function 
description 
“Insert” 

 

No. Icon Function description 

/1/ Create open path Creates an open path in the CAM View.  

/2/ Create closed path Creates a closed path in the CAM View. 

/3/ Create polygon Creates a polygon in the CAM View. 

/4/ Create rectangle Creates a rectangle in the CAM View 

/5/ Create circle Creates a circle in the CAM View. 

/6/ Create circle path Creates a circle path in the CAM View. 

/7/ Create flash Creates a flash in the CAM View. 

/8/ Create text object Creates a text in the Cam View. 

/9/ Fiducial Creates fiducials in the CAM View. 

/10/ Rubout area Creates a rubout area. 

/11/ Create polygon with cutouts Creates a polygon with cutouts in the CAM 
View. 

/12/ Create copper pouring Creates copper pouring. 

/13/ Switch line mode to 90° Enable the line mode, if you want to draw a 
horizontal line.  

/14/ Switch line mode to 45° Activate the line mode if you want to draw 
a straight line with a slope of 45°. 
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 Toolbar Modify 4.3.3

The toolbar “Modify” provides following icons:  
Fig. 33: Toolbar 
„Modify“ 

 

 
The following table provides a brief description of the toolbar’s icons: 

Table 11: Toolbar 
“Modify” 

 

No. Icon Function description 

/1/ Close open path Closes an open path. 

/2/ Combine open paths Combines several open paths into a single 
open path. 

/3/ Convert closed path to 
polygon 

Converts the selected object to a polygon.  

/4/ Convert polygon to path Converts the selected object to a closed 
path. 

/5/ Draw to flash Converts a drawn object to a flash. 

/6/ Combine objects to flash Connects objects to a flash. 

/7/ Compare objects to flash Converts objects on the same layer that 
have the same form and size as the selected 
flash object into flash objects. 

/8/ Transformation Translates, rotates, scales and inverts 
objects and toolpaths. 

/9/ Rotate objects 90° counter-
clockwise around the 
anchor point 

Rotates the selected object 90° counter-
clockwise around the anchor point. 

/10/ Rotate objects 180° around 
the anchor point 

Rotates the selected object 180° around the 
anchor point. 

/11/ Rotate objects 270° 
counterclockwise around 
the anchor point 

Rotates the selected object 270° counter-
clockwise around the anchor point. 

/12/ Mirror objects along x axis Mirrors the object at the anchor point along 
the x axis. 

/13/ Mirror objects along y axis Mirrors the object at the anchor point along 
the y axis. 

/14/ Step and repeat The selected objects are duplicated with a 
defined distance, vector and count. 

/15/ Move selected objects Moves the selected object. 

/16/ Move a point or segment Moves a point or a segment. 

/17/ Cut a point or segment Cuts a point or a segment. 

/18/ Delete a point or segment Deletes a point or a segment. 

/19/ Create or move an arc Creates or moves an arc. 

/20/ Add a point or segment Adds a point or a segment. 
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 Toolbar Prototyping 4.3.4

The toolbar “Prototyping” provides following icons: 
Fig. 34: Toolbar 
“Prototyping”  

 

 
 
The following table provides a brief description of the toolbar’s icons: 

Table 12: 
Function 
description 
“Prototyping” 

 

No. Icon Function description 

/1/ Process planning wizard Starts the process planning wizard. 

/2/ Import Imports all files of the formats CAM, Excellon, 
Gerber, GerberX, LMD, HPGL, DXF and Sieb 
& Meyer. 

/3/ Rubout area Inserts a rubout area in the CAM view. 

/4/ Fiducial Inserts fiducials in the CAM view. 

/5/ Technology Dialog Generates insulation and contour routing 
toolpaths. 

/6/ Tool magazine Opens the dialog to edit the contents of the 
tool magazine.  

 /7/ Board Production Wizard Starts the Board Production Wizard. 

 /8/ Tool library Opens the tool library. 
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 Toolbar Layout  4.3.5

The toolbar “Layout“ provides following buttons: 
Fig. 35: Toolbar 
“Layout”  

 

 
The following table provides a brief description of the toolbar’s buttons: 

Table 13: 
Toolbar 
“Layout” 

 

No. Icon Function description 

/1/ CAM Distinction between the views CAM and 
Compact CAM. 
CAM: Displays all active views and panes. 
Compact CAM: Hides all views and panes 
except the CAM view and the panes 
“Navigation” and “Layers”. 

/2/ Machining Hides all views and panes except the 
machining view and the pane “Processing”. 
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4.4 Panes 

CircuitPro PM allows arranging several individual panes on your screen. These 
are: 
 
• Layers 
• Geometry 
• Toolpath 
• Processing 
• Properties 
• Tool info 
• Navigation 
• Camera 
• Messages 
• Fault Monitor 
 

 Arranging the panes 
1. First, open the desired pane in the menu “View”. 

➨ The pane is displayed at the left bottom of the main window of 
CircuitPro PM. 

2. Double-click on the title bar of the pane. 

➨ The pane is now detached.  
 You are able to maximize/minimize the pane and to arrange it as desired. 

 

 Fixing the pane  
1. Click and hold the detached pane with the left mouse button. 
2. Move the pane. 

➨ In the main window of CircuitPro PM, icons appear at the top, bottom, right 
and left side. 

3. Move the pane onto the icon at the desired window edge. 
 

 
Note 

Be sure to place the cursor exactly on the icon before you 
release the left mouse button. 

 
4. Release the left mouse button. 
 The pane is now fixed at the desired position. 
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 Layers 4.4.1

The pane “Layers” lists the required layers for your project. Depending on the 
template that you select at the beginning of your project, the number and type of 
the layers diversify.  
Click on View > Layers to open the pane “Layers”: 

Fig. 36: Pane 
“Layers” 

 

 
The following table provides a brief description of the pane’s columns: 

Table 14: 
Columns in the 
pane “Layers”  

 

Column Description 

 Name Shows the name of the layer. 
The numbers shown in the brackets next to the layer 
name shows the number of the contained objects. 

 Visible Shows/hides the corresponding layer in CAM View.  

 Selectable Enable this function to make the layer selectable in 
CAM View. 

 Colors In this column each layer is assigned to a colour. The 
layers’ colours shown in the CAM View match these 
colours in the column.  

 Mode This list enables you to determine in which display 
mode the layer shall be shown.  

Tech Determine the layer’s processing goal in this column. 
I.e. for example, if you select the value "Solder 
Paste", you determine that this layer will be processed 
with solder paste later on. 

Inverse Mills the inside of the objects on the source layer. 
Example: In a letter or a number the inner area is 
milled. 

Phase Determines the phase in which the layer will be 
processed.  

 
[Z] Sorting function: sorts the layers by the display priority 

in Z direction.  
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 Geometry 4.4.2

The pane “Geometry” lists all apertures, which were imported from the Gerber 
and Excellon files. CircuitPro PM names the aperture list after the file name by 
default.  
Click on View > Geometry to open the pane “Geometry”. 

Fig. 37: Pane 
“Geometry” 

 
 

Pos: 5.4.4 /ED_Technische_Dokumentation/2_Bedi enungsanleitung/Software/CircuitPro 2.1/Kapitel 4_Aufbau der  Bedi enober fläche/4_U nterfenst er/04_U nterfens ter _Wer kzeug bahn @ 5\mod_1381764050387_2058.docx @ 123290 @ 3 @ 1  

 Toolpath  4.4.3

The pane “Toolpath” shows the board’s individual production phases. 
Click on View > Toolpath to open the pane “Toolpath”. 

Fig. 38: Pane 
“Toolpath” 

 

 
The phases are named after the production steps. After clicking on the arrow 
symbol to the left of a phase, the tools used for the phase are shown. 
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 Processing  4.4.4

 

 
Note 

Please note that several functions in sections “Select a Head” 
and “Head actions” are not available when using the ProtoMat 
S43/E33. 
Also note that in section “Select a Head” a laser head is 
available when using the ProtoMat D104. 

 
In the "Processing" pane you can control the processing head of the machine 
and determine its height. 
Click on View > Processing to open the pane “Processing”: 

Fig. 39: Pane 
“Processing” 

 

 
Table 15: 
Processing  

 

No. Button Description 

X/Y - positioning 

/1/ 

 

Distance entry to move the machine 
head in X and Y direction. 
Enter the distance in the combo box 
and click on the arrow buttons. Each 
click moves the machine head at the 
specified distance in the preferred 
direction. 

/1/ 

 

Move head to the basic position: Click 
on this button to move the machine 
head to the basic position. 

/1/ 

 

Move head to the pause position: Click 
on this button to move the machine 
head to the pause position. 

/1/ 

 

Move head to the zero position: Click on 
this button to move the machine head to 
the zero position.  

/1/ 

 

Enables moving the head to the position 
selected by mouse click in the 
machining view.  

1 

2 

6 5 

4 3 
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Table 15: 
Processing  

 

No. Button Description 

Z - positioning 

/2/ 
 

Distance entry to move the machine 
head in Z direction. 
Enter the distance in the combo box 
and click on the arrow buttons. Each 
click moves the machine head at the 
specified distance in the preferred 
direction. 

Select a head 

/3/ 

 

Select the milling head as the active 
head. 

/3/ 

 

Select the camera head as the active 
head. 

/3/ 

 

Select the dispenser head as the active 
head. 

/3/ 

 

Select the laser head as the active 
head. 

Head actions 

/4/ 

 

Moves the machine head upwards or 
downwards. 

/4/ 

 

Switches the spindle on/off. 

/4/ 

 

Clean dispenser. 
The button is only visible when the 
dispenser has been selected as the 
active machine head. 

/4/ 

 

Switches the suction on/off. 

/4/ 

 

Executes the auto focus. 

/4/ 

 

Decreases the brightness of the 
camera. 

/4/ 

 

Increases the brightness of the camera. 
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Processing 

/5/ 

 

 

Starts processing. 
Please note the phase that is selected 
in the field below. 

/5/ 

 

 

Starts processing from the selected 
phase in the field below.  
All subsequent phases are processed 
one after another. 

/5/ 

 

Stops processing 

Tool information 

/6/ Displays the tool information for the tool that is currently located in the clamp. 
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 Properties 4.4.5

The pane “Properties” includes detailed information about the project. 
Click on View > Properties to open the pane “Properties”: 

Fig. 40: Pane 
“Properties” 

 

 
In this pane you find information about the tools, too. If you click on an aperture 
in the pane “Geometry”, you will get information about it, such as shape and 
diameter. 
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 Tool Info  4.4.6

The “Tool Info” pane displays the parameters of the tool located in the clamp. 
Click on display > Tool Info to open the “Tool Info” pane. 

Fig. 41: Pane 
“Tool info” 

 

 
The tool information displayed here is identical to the information provided in the 
tool library. 
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 Navigation 4.4.7

The pane “Navigation” is shown as soon as you have activated the CAM View 
or have clicked on View > Navigation: 

Fig. 42: Pane 
“Navigation”  

 

 
 /1/ Magnifying glass icons 

/2/ Reset zoom 
/3/ Zoom bar 

 
You see the object to be processed in small format in this pane. If you click on a 
certain position using the mouse, you can zoom in on this position by means of 
the zoom function. 
The following functions are available: 
• Minimise/enlarge the area selected with the mouse by using the +/- 

magnifying glass icons /1/. 
• Minimise/enlarge the area selected with the mouse by using the 

zoom bar /3/. 
• Reset the zoom or adapt the layout to the CAM view by clicking on 

button /2/. 
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 Camera (only if a camera is connected) 4.4.8

The pane “Camera” enables you to regard the object to be processed through 
the camera. 
Click on View > Camera to open the pane “Camera”. 

Fig. 43: Pane 
“Camera” 

 

 

 
Note 

Please note that a camera image is only displayed when a 
camera is actually available. This must be installed and 
connected via USB properly. 
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 Messages 4.4.9

Click on View > Messages to open the pane “Messages”. This pane contains 
information about: 

Fig. 44: Pane 
“Messages” 

 
 

Table 16: 
Messages  

 

Type Description 

Errors Errors are critical bugs. Click [Errors] in order to 
correct the errors. If the error recovery is not 
successful please call the LPKF Support. 

Warnings Warnings are input errors caused by the user. 
For example this may be information about 
cancelled or not properly executed actions. 

Messages Messages are statistical information of the 
program. This may be feedback from 
CircuitPro PM on certain actions performed, 
such as: “create new document”. 

 

Service Messages Service messages are displayed when the 
machine maintenance is due. Please contact the 
LPKF support. 

 

Raise selection Highlights the corresponding action in the CAM 
view. 
Example: You draw a rectangle. In the 
“Messages” pane appears a corresponding 
message (e.g. Rectangle Drawn_5 was 
created). Now if you click on the button “Raise 
selection” and hereafter on the message about 
the drawn rectangle, this rectangle is highlighted 
in the CAM view.  
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 Fault Monitor 4.4.10

The machine errors which have occurred are listed in the “Fault Monitor” pane. 
This machine error must be rectified so that production can be continued. 
Click on View > Fault Monitor to open the “Fault Monitor” pane: 

Fig. 45: 
Pane 
“Fault 
Monitor
” 

 

 
The icons used signify the following:  

Table 17: Error 
monitoring 

Icon Description 

 

Displays the first error message. 

 

Displays the previous error message. 

 

Displays the next error message. 

 
 

Displays the last error message. 

 
 

Acknowledges the error message currently marked. 

 
 

Acknowledges all error messages. 

 
 

Deletes the error message currently marked. 

 
 

Deletes all error messages. 
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5 How to work with CircuitPro PM 
The following chapter describes the usage of CircuitPro PM in detail.  
Each menu and submenu of CircuitPro PM is listed accordingly. 

Fig. 46: Menu 
bar 
CircuitPro PM  

 
CircuitPro PM’s menu bar contains following menu items: 

 
• File 
• Edit 
• Insert 
• Toolpath 
• Modify 
• View 
• Select 
• Wizards 
• Machining 
• Camera (only if a camera is mounted) 
• Extras 
• Help 
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5.1 Menu File 

The “File” menu contains the standard file operations of CircuitPro PM. 
Click on the “File” menu item to open the submenu: 

Fig. 47: Menu 
“File” 

 
 
The following table contains short descriptions of the functions of the individual 
menu items: 

Table 18: “File” 
menu functions 

 

Menu item Description 

New… Creates a new document in CircuitPro PM. You can 
either select one of the standard templates for your 
new document or browse your disk drive for your 
own templates. 

Open… Opens a CircuitPro PM document. 

Recent files Contains a list of the five CircuitPro PM documents 
that have been opened/edited most recently. 

Save Saves the document currently edited with all 
changes made under the same file name and 
location. 

Save As… Saves the document currently edited with all 
changes made under the specified file name and 
location. 

Save As 
Template… 

Saves the current document as a template (file 
extension .cbf). Thus, it is displayed in the select 
template dialog. 

Import… Imports the following file formats: CAM, Excellon, 
Gerber, GerberX, LMD, HPGL, DXF, and Sieb & 
Meyer. 

Import 3D shape… Imports all 3D shapes in the STEP and IGES file 
formats. 

Import toolpath… Imports the toolpath data of an existing 
CircuitPro PM document. 
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Table 18: “File” 
menu functions 

 

Menu item Description 

Recent files 
imported 

Contains a list of the five documents that have been 
imported most recently. 

Recent files 3D Contains a list of the CircuitPro PM 3D documents 
that have been opened/edited most recently. 

Export… Exports the toolpaths of the current document into 
an LMD file. 

Print Preview… Opens the print preview of the current document. 

Print… Opens the print dialog. Choose your settings for 
printing and start the print operation subsequently. 

Export to image… Exports the visual presentation or selected parts 
into an image file of the formats Bitmap, JPEG, or 
Windows Enhanced Metafile. 

 Exit Closes CircuitPro PM. 
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 New 5.1.1

The menu item “New” lets you create a new document based on a template. 

 Creating a new document in CircuitPro PM 
1. Click on File > New. 
2. Select the tab “Templates”. 

➨ The dialog of the templates available in CircuitPro PM is displayed: 

Fig. 48: New 
document 

 
 
3. Select a template. 
 A new document is created based on the selected template. 

 
Tip 

If you want to define a template as default template, select the 
desired template and mark the check box “Set as default”. The 
corresponding template is underlined in the list of templates. 

 

 
Tip 

If you want to use none of the templates you can also start the 
project planning wizard. The wizard guides you through the 
steps to define your design. 
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 Loading a custom template 
1. Click on File > New. 
2. Select the tab “Templates”. 

➨ The dialog of the templates available in CircuitPro PM is displayed: 
   

Fig. 49: New 
document 

 

 /1/ List of custom templates created 
previously 

/2/ [Load custom template…] 
opens the file dialog “Open” 

   

 
3. Click on a custom template /1/. 
 A custom template is opened. 

Or 
3. Click on [Load custom template…]. 

  

1 

2 

2 
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➨ The following dialog is displayed: 

Fig. 50: File 
dialog “Open” 

 

 
4. Select the appropriate CBF file on your drive. 
5. Click on [Open]. 
 A custom template is opened. 
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 Open 5.1.2

Use the menu item “Open” to open an existing CircuitPro PM document. 

  Opening an existing document in CircuitPro PM 
1. Click on File > Open. 

➨  The following dialog is displayed: 

Fig. 51: Open 

 
 
2. Select the desired CBF document on your drive. 
3. Click on [Open]. 
  The selected document is opened. 
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 Recent files 5.1.3

This menu item shows the five files that have been opened/edited in CircuitPro 
PM most recently.  
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 Save 5.1.4

Saves the document currently edited with all changes made under the same file 
name and in the same folder.  
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 Save As 5.1.5

Use the menu item “Save As” to save the file currently edited under a new 
name or in a different folder. 

 Saving a document (under a new name/in a different folder) 
1. Click on File>Save As. 

➨ The following dialog is displayed: 

Fig. 52: Save As 

 
 
2. Enter a file name. 
3. Select the folder for saving the file. 
4. Select the file type. 

  

 
Note 

CircuitPro PM (2.x) is downward compatible and can read and 
write files of older CircuitPro versions (1.x).  
However, CircuitPro (1.x) cannot read files of CircuitPro PM 
versions (2.x). 

  

5. Click on [Save]. 
 The document is saved. 
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 Save As Template 5.1.6

Use the menu item “Save As Template” to save the current document as a 
custom template in CircuitPro. 

 Saving a document as a template 
1. Click on File > Save As Template… 

➨ The following dialog is displayed: 

Fig. 53: Save As 
Template 

 
 
2. Select the folder for saving the file. 
3. Enter a file name for the template. 
4. Select the file type. 
5. Click on [Save]. 

  

 
Note 

CircuitPro PM (2.x) is downward compatible and can read and 
write files of older CircuitPro versions (1.x).  
However, CircuitPro (1.x) cannot read files of CircuitPro PM 
versions (2.x). 

  

 The document is saved as a template. 
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If you subsequently create a new document via the menu item File > New, the 
dialog for selecting a template displays a section “My templates”: 
 

Fig. 54: My 
templates 
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 Import 5.1.7

The “Import“ menu item lets you import CAD files of the following formats: 
    

Table 19: Formats Format Description Extension 

 CAM native data format of LPKF CircuitCAM *.CAM 

 Excellon data format used for drilling and milling on printed circuit 
boards 

.*DRL / 

.*DRD 

 Gerber data format used for printed circuit board image data *.GBR 

 GerberX 
GerberX2 

extended data format used for printed circuit board 
image data 

*.GBX 

 JOB files Data format for BoardMaster JOB files. *.JOB 

 LMD LPKF Mill Drill data format used for data transfer 
between LPKF software products 

*.LMD 

 HPGL data format used for drawings, formerly used to drive 
pen plotters 

*.PLT 

 DXF data format used for drawings from AutoCAD *.DXF 

 Sieb & 
Meyer 

data format used for drilling and milling on printed circuit 
boards 

*.DRL /  
*.SM? 

 ODB++ data format used for printed circuit board image, drill 
data, netlists and component data 

*.ZIP 
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 Importing CAD files 
1. Click on File > Import… 

➨ The import dialog is displayed: 

Fig. 55: 
File > 
Import 

 
 
2. Select the desired file(s) on your drive. 
3. Click on [Open]. 

➨ The following contents are displayed corresponding to your imported file 
(Gerber in this case): 

Fig. 56: Import  

 /1/ List of the imported data 
/2/ View tabs 

/3/ Data/settings tabs 

 

 
 /1/ List of the imported data 

/2/ Main tabs 
/3/ Sub-tabs 

1 
 

2 
 3 
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4. Check the loaded data and modify if necessary. 
5. Click on [OK]. 

 The CAD files have been imported. 
 
Section /1/ lists the files you imported. In this list, you define the layers in 
CircuitPro PM where each file's data are assigned to. 
 
Section /2/ contains the tabs that display detailed information on the imported 
data. These are structured as follows: 
• 2D view 
• Apertures/Tools 
• Text View 
• Message View 
 
Depending on the active tab, section /3/ displays the following sub-tabs: 
• General 
• Options 
• Attributes (only if the “Apertures/Tools” tab is active) 
 

 
Note 

You can change the import settings for the individual file types 
via menu item Extras > Options Import / Export. 

 
The following pages show the contents of the tabs using Gerber files as 
examples. If you import other file formats, the contents of the tabs may differ. 
 

2D View tab 

The “2D View” tab displays the design and the dimensions of the imported file: 
Fig. 57: 2D View 
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Apertures/Tools tab 

The “Apertures/Tools” tab lists the apertures and tools required for the project. 
Fig. 58: 
Apertures/Tools 

 
 

The columns of this tab show the following: 
Table 20: 
Apertures and 
tools 

Column Description 

Image Shows the shape of the individual aperture. 

Name Shows the name of the individual aperture. 

Mode Shows whether the aperture is imported as a drawn  or 
flashed  object. 

Rotation Shows the angle by which the aperture is rotated 
(meaningless in case of a circle shape). 

A-D These columns contain the parameters defining the size and 
shape of the aperture. Depending on the aperture shape, not 
all parameter columns are used. 
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Text View tab 

The “Text View” tab displays the ASCII text of the imported file. 
Fig. 59: Text View 

 
 

Message View tab 

The “Message View” tab contains system messages of CircuitPro PM about the 
operations performed during the file import: 

Fig. 60: Message 
View 
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Data/Settings tab General 

In the “General” tab, you can define the dimensions of the imported files: 
Fig. 61: General 

 
 
The following settings are possible: 

Table 21: General Setting Description 

Size Displays the overall size of the imported design. 

Unit Displays the unit of measurement 

Values Defines whether absolute or relative values are used. 

Decimal Defines whether leading or trailing zeroes are to be 
omitted. 

Digits m.n Defines the number of digits. 
m = digits before the decimal point 
n = digits after the decimal point 

 
  



 
CircuitPro PM 2.3 How to work with CircuitPro PM 

   

© 2016 LPKF AG  V1.1 – 11.2016 71 

5 

Data/Settings tab Options 

The “Options” tab lets you select various options: 
Fig. 62: Options 

 
 
The following options can be activated: 

Table 22: Options Setting Description 

Use layer name Use the layer name defined in the Gerber file. 

Use layer polarity Activate/deactivate analysis of layer polarity during 
Gerber import. 

Rotate Square Activate/deactivate automatic rotation of square 
objects during Gerber import. 

Step and Repeat to 
flash 

Activate/deactivate combining object collections to 
flash objects for “Step & Repeat” commands (in the 
file) when importing Gerber files. 

Rotate AM Octagon Always align octagon edges to axes. 

Set 360 interpolation as 
default 

Activates the 360° interpolation for circles as 
default, irrespective of corresponding commands in 
the file. 

 
Apply to all Gerber files Applies the settings of this tab to all imported 

Gerber files 
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Data/Settings tab Attributes 

The “Attributes” tab displays and lets you modify the properties of the apertures 
and tools: 

Fig. 63: Attributes 

 
 
The attributes define the following: 

Table 23: 
Attributes 

Attribute Description 

Type Defines the type of the aperture. 

Rotation Defines the rotation angle of the aperture. 

A-D These fields contain the parameters defining the 
size and shape of the aperture. Depending on the 
aperture shape, not all parameter fields are used. 
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 Import 3D shape  5.1.8

Use the menu item “Import 3D shape” if you want to import a file containing 3D 
shapes into CircuitPro PM. 
The following file types containing 3D shapes can be imported: 
• STEP files (*.stp, *.step) 
• IGES files (*.igs, *.iges) 
• BRep files (*.brep) 

 Importing a 3D shape 
1. Click on File > Import 3D shape... 

➨ The following dialog is displayed: 

Fig. 64: Import 3D 
shape 

 
 
2. Select the desired document (STEP or IGES) on your drive. 
3. Click on [Open]. 
 The 3D shape is imported. 
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 Import toolpath  5.1.9

Use the menu item “Import toolpath” to import toolpaths from other CircuitPro 
PM files (.cbf). 

  Importing toolpaths 
1. Click on File > Import toolpath… 

➨  The following dialog is displayed: 

Fig. 65: Import 
toolpath 

 
 
2. Select the desired document on your drive. 
3. Click on [Open]. 

➨  The toolpaths of the document are imported and displayed in the “toolpath” 
pane: 

Fig. 66: 
“Toolpath” pane 
with imported 
toolpaths 

 
 

 The toolpaths have been imported. 
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 Recent files imported 5.1.10

This menu item shows the five files that have been imported into CircuitPro PM 
most recently. 
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 Recent files 3D 5.1.11

This menu item shows the five 3D files that have been opened/edited in 
CircuitPro PM most recently.  
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 Export 5.1.12

Use the function “Export” to export toolpaths in CircuitPro PM to LMD files. 

 Export toolpaths to LMD file 
1. Click on File > Export… 

➨  The following dialog is displayed. 

Fig. 67: Export 

 

2. Enter a file name in section “Parameters”.  
3. Scroll down the list „Source objects“ until you see the phases of the current 

CircuitPro PM project.  
  

 
Note 

In CircuitPro PM the toolpaths are assigned to the corresponding 
phases. You can check the assignments in the pane “Toolpath”.  

  
4. Tick the checkbox of these phases whose toolpaths you want to export.  
5. Click on [Save]. 

➨ The toolpaths are exported in a LMD file. This file is saved in the folder of 
your current CircuitPro PM project.  

  

 
Tip 

Highlighting and exporting individual toolpaths  
In the CAM/Machining view you are able to highlight the 
toolpaths to export or you click on the individual toolpaths in the 
pane “Toolpath”. 
In the “Export” dialog, select “<Current selection>” in the list 
“Source objects”. 
Click on [Save], to export the toolpaths.  

  
 The toolpaths have been exported.  
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 Print preview 5.1.13

Before printing a document in CircuitPro PM, you can use the print preview to 
get an overview of the pages to be printed. 
 

  Starting the print preview 
1. Click on File > Print Preview… 

➨  The following window is displayed: 

Fig. 68: Print 
preview 

 
 
The print preview has the following menu items: 

Fig. 69: Menu 
items in Print 
preview  

 
 

 
Table 24: Menu 
items in Print 
preview 

No. Icon Description 

/1/ Print Starts the printing process. 

/2/ Settings Opens the printer setup dialog. 

/3/ Lens Zooms in or out of the page(s) to be printed. 

View 

/4/ 2D/3D Offers the choice between the objects in 2D view and 
in 3D view. 

 Mode 

/5/ One Page Displays only one page at a time of the document to 
be printed. 

/5/ Two pages Displays two pages at a time of the document to be 
printed. 
 

1 2 3 4 5 6 7 8 
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Table 24: Menu 
items in Print 
preview 

No. Icon Description 

/5/ Three pages Displays three pages at a time of the document to be 
printed. 

/5/ Four pages Displays four pages at a time of the document to be 
printed. 

/5/ Six pages Displays six pages at a time of the document to be 
printed. 

Print area 

/6/ All visible Restricts the print area to all visible objects.  

 /6/ View Restricts the print area to the current view. 

 /6/ Full layout Fits the print area to the full layout. 

 /6/ Selection Restricts the print area to the current selection.  

  

 /7/ Page number Displays the current page number. 

 /8/ Close Closes the print preview. 

    

 
2. Click on the print button /1/ in order to print the document. 
Or  
2. Click on [Close] in order to close the print preview window. 
 
  The print preview window is closed. 
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 Print 5.1.14

Use the menu item File > Print… if you want to print a document/artwork film in 
CircuitPro PM. 
Use the different tabs to set your desired properties for a good printing result. 

 Printing a document/artwork film 
1. Click on File > Print… 

➨ The print dialog is displayed. 
2. Take your desired settings in the individual tabs as explained below: 

General tab 

Fig. 70: Print > 
General 

 
 /1/ Printer selection 

/2/ Page Range 
/3/ Collate 

/4/ View 
/5/ Print Area 
 

 
  

1 
 

2 
 3 

 
4 
 

5 
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Table 25: Print > 
General 

 

Section Description 

Printer selection Select the printer for the print job in this section. 

Page Range Select the pages that are to be printed. If the radio 
button “Selection” is activated only the current 
selection in the view are printed. 

Number of copies 
and collate 

Enter the number of copies to be printed. If more 
than one copy is selected, the “Collate” check box is 
available. This setting is for printing all pages of one 
copy before printing the next copy. 

 View Select the view that is to be printed. 

 
Print Area Print area defines whether the current view, the 

whole design, the selection, or everything is to be 
printed. 

 Button Description 

Properties Opens the printer dialog to set the properties of the 
connected printer. 

Preview Creates a preview of the print job. 

 Print Starts the printing process 

 Cancel Closes the dialog. 

 Apply Stores the settings. 

 

 
Tip 

Printing an artwork film 
To print an artwork film (for a later usage in LPKF 
ProMask/ProLegend), enter the following settings in your printer 
properties: 
1. Click on [Properties…]. 
2. Enter the following settings in the upcoming dialog: 

 Print quality: high 

 Color: gray shades 

 Paper quality: fine/film 

 The document size must be equal to actual size. I.e. the 
option “reduce/enlarge the page” must be disabled. 
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Page Setup tab 

Fig. 71: Print > Page 
Setup 

 
 /1/ Preview 

/2/ Paper 
/3/ Orientation 
/4/ Margins 
 

Table 26: Print > 
Page Setup 

 

Section Description 

Preview Displays an example sheet of the current settings. 

Paper Select the paper size and the paper source of the 
printer. 

Orientation Select the orientation of the pages: Portrait or 
Landscape. 

 Margins Enter the page margins. 

 
  

1 
 

2 
 

3 
 

4 
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Settings tab 

Fig. 72: Print > 
Settings 

 
 /1/ Printing options 

/2/ Scaling 
/3/ Page count 
 

 
Table 27: Print > 
Settings 

 

Section Description 

Printing options You can select the following options: 
• Enable colors: Activate this option for color 
printing. 
• Auto rotate: Adjusts the page orientation to the 
orientation setting in the printer setup. 
• Include file name in print output: Prints the file 
name of the project on every page. 
• Inverse: This function creates an inverted view of 
the milling area. I.e., the surface that is milled when 
producing the circuit board (e.g. rubout area) 
remains blank and the remaining copper areas are 
printed. 
• Mirror Y: Mirrors the object to be printed on the Y 
axis. 

Scaling You can choose between three options for scaling: 
• Best fit according paper size: Select this option 
to have the print output scaled automatically to the 
paper size. 
• 1:1: If this option is selected, the print output has 
the actual size of the printed object. No scaling 
takes place. In case of large designs, these may be 
printed across several pages. In case of small 
designs, it can happen that details are printed so 
small that they become illegible. 
 
• Manual scaling: Enter a scaling value to scale the 
print output. If you enter e.g. “4” the output is 
enlarged by four. 
If the scaling factor would result in a print output of 
more than 100 pages the scaling is aborted. 

1 
 

2 
 

3 
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Table 27: Print > 
Settings 

 

Section Description 

Page count One page: If the output is enlarged (e.g. requires 3 
pages) only the center part is printed on a single 
page. The remaining parts are cropped. 
 
Page count according to scaling: The output is 
printed exactly (if e.g. 3 pages are required) as 
displayed in the preview. The output is not cropped 
or limited. 
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Printer Calibration tab 

Fig. 73: Print > 
Printer Calibration 

 
 

Table 28: Print > 
Printer Calibration 

 

Section Description 

Parameters Enter the parameters for printing a calibration 
rectangle: 
Rectangle size: Enter the size (X and Y values) of 
the calibration rectangle. 
 Start a test print by clicking on [Print calibration 
rectangle]. 
Printed size: Enter the actual size of the printed 
calibration rectangle. 
 Use a ruler to measure the rectangle in the print 
output. 
Correction factor: This is computed automatically 
from the difference between the rectangle size and 
the actual printed size. You can also modify the 
factor manually. 
 Activate the check box <Use Calibration> to 
apply the correction factor. 

 Button Description 

Print calibration 
rectangle 

Prints a rectangle that can be adjusted to the 
desired rectangle size by entering the actual size in 
the parameters section. 

 
3. Click on [Print] in order to print the document. 
  The document is printed. 
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 Export to image 5.1.15

CircuitPro PM offers to export designs into image files. The following file formats 
are available: 
• Bitmap (*.bmp) 
• JPEG (*.JPG, *:JEPG) 
• Metafile (*.emf)  
• Portable Network Graphics (*.png)  
 

 Exporting a design to an image 
1. Click on File > Export to image… 

➨ The following dialog is displayed: 

Fig. 74: Export to 
image 

 
 
2. Select the file format for the image (bitmap, JPEG, metafile or Portable 

Network Graphics). 
3. In the parameters field, select whether 2D graphics or 3D graphics are to be 

exported. 
You can also select which area of the design are to be exported into the 
image file. 
 

Fig. 75: 
Parameters 
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Table 29: 
Parameters 

 

Selection Description 

All visible Exports all visible objects of the 2D/3D view 

View Exports the current CAM view. 

Full layout Exports the whole design in 2D and 3D view 

 Selection Exports only the objects selected in 2D/3D view. 

 
4. Select the folder for saving the image. 
5. Click on [Save]. 
 
 The design is exported and stored into an image file. 
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 Exit 5.1.16

The menu item “Exit” closes the CircuitPro PM program. Just click on 
File > Exit. 
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5.2 Menu Edit 
 

The “Edit” menu contains the functions for editing objects in CircuitPro PM. 
Click on the menu item “Edit” to open the sub-menu: 

Fig. 76: Menu 
“Edit” 

 
 
The following table contains short descriptions of the functions of the individual 
menu items: 

Table 30: “Edit” 
menu items 

 

Menu item Description 

Undo Undoes the last operation in the document.. 

Redo Restores the operation previously undone. 

Cut Cuts the selected object(s) from the document and 
stores it (them) in the clipboard. 

Copy Copies the selected object(s) to the clipboard. 

Paste Inserts the object(s) previously cut/copied at the 
selected position/on the selected layer. 

Material 
properties… 

Defines the properties (such as type and size) of the 
material used for 2.5D operations. 

Material 
placement… 

Defines the height and the position of the material 
used (2.5D objects) 

Material 
Settings… 

Opens the dialog “Material settings" where you can 
enter the parameters of the base material used. 

Tool magazine… Opens the dialog “Tool magazine” dialog. Enter the 
various tools that are/will be in the machine's tool 
magazine in this dialog. 

Tool Library… Opens a dialog showing all available tools. 

Aperture list 
library… 

Opens a dialog showing all apertures of the current 
document. 

Design Rule 
Check… 

Opens a dialog for the setting options and starting the 
design rule check. 
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Table 30: “Edit” 
menu items 

 

Menu item Description 

Measure Activate this menu item to measure the distance 
between two points in the 2D/3D/Machining view. The 
values are shown in the status bar of CircuitPro PM. 
Press the ESC key on your keyboard to deactivate 
this function. 

Distance… Opens the “Distance” dialog. The dialog shows the 
exact distance between two objects. 

Set anchor 
point… 

Opens a dialog where you can define the coordinates 
of the anchor point. 

Set zero point… Moves the zero point to the current anchor point. 

Move anchor to 
center point… 

Moves the anchor point to the center point of a 
selected object.  

Move layer to 
zero… 

Aligns the objects of the selected layer to the zero 
point. 

 
Match up layers… Opens a dialog allowing to align the objects of two 

layers along a vertical line. 

 
Match up 
objects… 

Opens a dialog allowing to move a source object onto 
a target object. 

 Delete… Deletes the selected object(s) of the layer. 
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 Undo 5.2.1

Use this function to undo the last operation. By default, you can undo up to 10 
operations.  
If you want to increase the number of undo operations change the setting in 
menu Extras > Options > General > Undo/Redo level (see page 354). 
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 Redo 5.2.2

Use this function to restore the operation undone last. By default, you can 
restore up to 10 undone operations. 
If you want to increase the number of redo operations change the setting in 
menu Extras > Options > General > Undo/Redo level (see page 354). 
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 Cut 5.2.3

Use this function to cut the selected object(s) and store it (them) in the 
clipboard. 
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 Copy 5.2.4

Use this function to copy the selected object(s) and store it (them) in the 
clipboard. 
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 Insert 5.2.5

Use this function to paste objects previously cut or copied from the clipboard to 
the current mouse position. 
 

 
Note 

If you insert the copied object on the same layer the 
new object will be placed on the original object. In 
this case activate the button on the left. Now click 

and move the copied object to the desired position. 
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 Material properties 5.2.6

In the dialog “Material properties”, the properties of the 3D object to be 
processed can be determined. 

 Determining material properties 
1. Click on process > Material properties. 

➨ The following dialog is shown: 

Fig. 77: Material 
properties 

 

 
2. Select the material type in the field \Type:\. 
3. Enter the length of the material (in mm) in the field \Length:\. 
4. Enter the material width (in mm) in the field \Width:\. 
5. Enter the height of the material in the field \Height:\. 
 

 
Tip 

If you use the same material frequently, you can also set the 
specified values as default properties and save them. Activate 
the checkbox “Save as default properties”. 

 
6. Click on [OK] to adopt the values. 
 The material properties have been determined. 
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 Material placement  5.2.7

You can place the material in the maching view by using this dialog. You define 
the corners of the material as well as the surface height.  

 Placing the material 
1. Click on Edit > Material placement… 

➨ The following dialog is displayed: 

Fig. 78: Material 
placement 

 

 /1/ Material properties 
/2/ Location 

/3/ Surface level  
/4/ Machine properties 

 
The individual section contain the following information/functions: 

Table 31: Material 
placement 

Section Description 

Material properties In this section, the material properties of the material to be 
processed are displayed. You previously entered these 
properties in the dialog “Material properties”. 

Machine 
properties 

In this section, the current material side to be processed, is 
displayed. 

Location In this section, the material corners are set. Please take the 
exact instructions from the following pages. 

Surface level In this section, please set the surface height. Please take the 
exact instructions from the following pages. 

 
2. Modify the settings as required. 
3. Click on [OK] to save the values. 

➨ The dialog is closed. 
 The material has been placed. 

 
  

1 

2 

3 

4 
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 Set material corners 
1. Move the camera head to the left, lower corner of your base material: 

a) Click in the “Processing” pane. 
b) Use the arrow buttons in the section "X/Y positioning" to move the 

camera head. 

Fig. 79: Pane 
“Processing” 

 

 

 
Note 

The camera head is activated automatically. This can be 
recognised in the “Processing” pane by the green frame around 
the camera icon: 

 
 

 
Tip 

You can also click on the corner of your material in the 
machining view. The camera moves automatically to this 
position. Perform fine adjustment by using the X/Y buttons in the 
“Processing” pane. 

 
2. Perform autofocus for improved material alignment: 

a) To do this, click on the button "Autofocus" in the “Processing” pane: 

Fig. 80: 
Autofocus 

 

 
3. Position the camera head so that the corner of your material is exactly at 

the crosshairs: 
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Fig. 81: Crosshair 
of the camera 

 

 

 
Tip 

If you use the dark/reflective base materials (for example, POM), 
the display of the camera image can be too dark for the material 
to be recognised. 
In this case, turn the camera aperture to improve the incidence 
of light/lightness of the camera image. 

 
4. In the dialog “Material placement”, click on the following icon:   

 

➨ The value for the lower, left material corner was saved. 

➨ The following message is displayed: 

Fig. 82: Message 
for second 
position 

 

 
5. Confirm the message by clicking on “Yes”. 

➨ The camera automatically moves in the opposite corner of the material. 
6. Align the crosshairs with the material corner by using the X/Y buttons. 
7. Click on the symbol for the upper, right-hand corner:   

 

➨ The value was saved. 
 The material corners have been set. 
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 Setting the material height 
In the next step, the Z height of the material must be determined. 

➨ The following message is displayed after you have set the material corners: 

Fig. 83: Move to 
measuring 
position 

 

 
1. Confirm the message by clicking on “Yes”. 
2. Click on [Autofocus]. 

3. Now click on the button to set the material height:  
 The material height has been set. 
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 Material Settings 5.2.8

Use this dialog to define the material properties of the object to be processed. 
Fig. 84: Material 
settings 

 
 /1/ Application 

/2/ Properties 
/3/ Location 

 
  

1 

2 

3 
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Section /1/ defines whether the material is used as a printed circuit board or as 
a front panel/engraving. 
The properties of the material are defined in section /2/. This comprises: 
• Material type (glass-reinforced epoxy laminate (FR4) or aluminium) 
• Thickness of the copper layer in µm 
• Material thickness in mm 
• Thickness of the underlay in mm (none if vacuum table is mounted) 
 
Section /3/ defines the location and size of the material area. In case of front 
panels/engravings, the Z height has to be determined by lowering the tool to the 
surface of the material. The following properties can also be defined: 
• Material width in mm 
• Material length in mm 
 
 When the material area is defined, the resulting surface height and the 
coordinates of the material's corners are displayed. 

 Defining the material area 
1. Click on the upper right corner of the working area in the machining view of 

the project. 

➨ The milling head moves to this position. The X and Y coordinates of this 
position are displayed in the “Material settings” dialog. 

Fig. 85: Material 
settings > 
coordinates 

 
 

 
Note 

If you have selected “Front panel/Engraving” in the 
“Application” section, you have to enter the Z coordinate at the 
material's corners. 
 Move the milling head downwards by changing the Z value 
until the tool touches the material. Follow the further 
instructions from step 2 onwards. 
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2. Click on the icon representing the right rear corner, see /2/ in the following 
figure: 

Fig. 86: Material 
settings > 
Location 

 
 
 
 

 /1/ Left front corner  /2/ Right rear corner 

 

➨  The coordinates of the material area are stored.  
3. Click on the lower left corner of the working area in the machining view of 

the project. 

➨  The milling head moves to this position. The X and Y coordinates of this 
position are displayed in the “Material settings” dialog. 

4. Click on the icon representing the left front corner /1/. 
 

 
Tip 

After defining front left corner of the material area, you can also 
define the size of the material area by setting the “Material width” 
and “Material length”. 

1. Follow the steps 3 and 4 of “Defining the material area” 
2. Enter the values for \Material length\ and \Material width\ 

in millimetres. 
 The material area is adjusted automatically. 

 
 The material area is defined. 

die 

  

2 1 
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 Tool magazine ProtoMat D104 5.2.9

The tool magazine dialog lets you 
• view a list of the tools required for the current project, 
• view the tools currently present in the machine, 
• load the tool magazine, 
• view/put back the tool currently present in the clamp, 
• pick up a tool with the clamp, 
• check the milling width (Universal Cutter and Micro Cutter) or the milling 

depth (End Mill) of a tool, 
• view the current state of the tool life spent, and 
• replace an old tool with a new one. 

 

 
Note 

The “Tool magazine” dialog offers these options only for 
machines with automated tool change. This comprises the 
ProtoMat S63, the ProtoMat S103, and the ProtoMat D104. 

 
To open the dialog, select the milling head as active head and click on 
Edit > Tool magazine… or click on the following icon of the toolbar to open the 
dialog as an alternative: 
 

Fig. 87: Tool 
magazine icon 
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The following dialog is displayed: 
Fig. 88: Tool 
magazine 
S63/S103/D104 

 
 

 /1/ Required tools 
/2/ Button “Check milling width…” 

/3/ Button “Discard tool” 
/4/ Tools in the machine 

 
It is necessary to load the tool magazine for processing a project. In section /1/, 
CircuitPro PM displays the tools that are required for processing the project. 
The required tools have to be inserted into the tool magazine manually. You can 
either 
• insert the tools into the tool holders and then assign them to the tool holders 

accordingly in section /4/ or 
• assign tools to the tool holders in the “Tool magazine” dialog and then insert 

the tools into the tool Holders according to the list. 
  

  

2 3 4 1 



 
How to work with CircuitPro PM CircuitPro PM 2.3  

 
 

98 V1.1 – 11.2016 © 2016 LPKF AG 

5 

 Loading the tool magazine  
1. Click on the drop-down list of the first tool holder: 
 

Fig. 89: Drop-
down list of the 
tool holder 

 
 

➨ A list of all tools that you can use with the machine is displayed. 
2. Select the required tool (in this case: Universal Cutter 0.2 mm, as in 

adjacent list): 
Fig. 90: 
Assigning a tool 

 

➨ The tool is marked with a green check mark in the list of the required tools. 
Also, a green check mark is displayed next to the corresponding drop-down 
list and the tool life spent is displayed on the right. 
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3. Repeat above steps for all tools that are required for your project with the 
other tool holders. 

Fig. 91: Tool 
magazine loaded 

 
 
 The tool magazine is loaded. 

 

 Picking up a tool with the clamp 
1. Click on the following button next to the drop-down list: 

Fig. 92: Picking 
up a tool 

 
 

➨ The following message is displayed while the clamp picks up the tool: 

Fig. 93: Message 
picking up tool 

 
 

➨ The symbol on the tool's button changes: 

Fig. 94: Tool 
currently in 
clamp 

 
 
 Now, the tool is in the clamp. 
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 Putting the tool back to its magazine position 
1. Click on the following button next to the drop-down list: 

Fig. 95: Putting 
down a tool 

 
 

➨ The following message is displayed while the clamp puts down the tool: 

Fig. 96: Message 
tool release 

 
 

➨ The symbol on the tool's button changes: 

Fig. 97: Tool not 
in clamp 

 
 
 The tool is back at its corresponding magazine position.  
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 Checking the milling width (Universal Cutter) 
A tool has to be in the clamp to enable checking the milling width 
(Universal Cutter) or the milling depth (End Mill) of a tool. 
A short line is milled that is subsequently measured with the camera or the 
caliper. 
 
1. Pick up the tool with the clamp (see procedure “Picking up a tool with the 

clamp”). 

➨ The tool is now in the clamp. 
2. Activate the check box of the tool currently in the clamp: 
 

Fig. 98: Check 
box activated 

 
 

➨ The button “Check milling width…” is active. 
 

 
Note 

If a tool the milling width of which cannot be checked (e.g. 
Spiral Drill etc.) is in the clamp the button is not activated. 

 
3. Click on [Check milling width…]. 
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➨ The following message is displayed: 

Fig. 99: Defining 
a machine area 

 
 
4. Click on a position outside the area to be used for the project (but inside the 

processing area) to mill a line (see figure above). 
 

 
Note 

Please make sure that the milled line is inside the working area 
of the camera so that the camera can measure the line. 

 

➨ The milling head moves to the corresponding position in the processing 
area.  

5. Click on [OK]. 
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➨ The dust extraction of the machine is switched on, the milling head moves 
to the zero position and the spindle motor is warmed up: 

Fig. 100: Warm-
up of spindle 
motor 

 
 

 
Note 

The warm-up may already have taken place before, if the 
machine has already processed material after switching it on. 

 

➨ The line to be milled is displayed in the machining view and the line is 
milled: 

Fig. 101: 
Machining view 
with milled line 
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After the line has been milled the camera moves to the corresponding position. 
The “Camera” pane displays the line just milled: 
 

Fig. 102: 
“Camera” pane 

 
 

➨  The dialog with the measurement results is displayed: 

Fig. 103: 
Measurement 
results 

 

 

If there is a difference between the desired milling width and the measured 
width CircuitPro PM automatically proposes a correction value. 
 

 
Note 

You can manually enter a correction value if you do not want to 
apply the value proposed by CircuitPro PM. 

 
6. Increase or decrease the value of the proposed correction by using the two 

arrow buttons. 
7. To apply the proposed correction only for the current tool, click on [Store 

correction]. 

➨ The correction value for the current tool has been applied. The dialog is 
closed. 
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or  
8. To apply the proposed correction for all tools of the same tool type, click on 

[Save for all tools]. 

➨ The correction value for all tools of the same tool type has been applied. 
The dialog is closed. 

 
  

 
Note 

In CircuitPro PM it is possible to apply the correction value for all 
tools of the same tool type. If you check the milling width with an 
Universal Cutter and if you click on the button [Save for all tools], 
the correction value is applied for all Universal Cutters. 

  

 
  

 
Note 

If you do not want to apply any correction click on [Cancel]. 
 

  

 
  

 
Note 

Please note that the tool has to be put back into the holder and 
picked up again in order to have the corrected settings be 
applied. 

  

 
 The milling width has been checked. 
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 Checking the milling width (Micro Cutter) 
A tool has to be in the clamp to enable checking the milling width of that tool. 
First, a short line is milled that is subsequently measured with the microscope. 
 
1. Pick up the tool with the clamp (see procedure “Picking up a tool with the 

clamp”). 

➨ The tool is in the clamp. 
2. Activate the check box of the tool currently in the clamp: 

Fig. 104: Check 
box activated 

 
 

➨ The button “Check milling width…” is active. 
 

 
Note 

If a tool the milling width of which cannot be checked (e.g. 
Spiral Drill etc.) is in the clamp the button is not activated. 

 
3. Click on [Check milling width]. 
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➨ The following message is displayed: 

Fig. 105: 
Definition of 
machine area 

 
 
4. Click on a position outside the area to be used for the project (but inside the 

processing area) to mill a line (see figure above). 

➨ The milling head moves to the corresponding position in the processing 
area.  

5. Click on [OK]. 
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➨ The dust extraction of the machine is switched on, the milling head moves 
to the zero position and the spindle motor is warmed up: 

 
Fig. 106: Warm-
up of spindle 
motor  

 
 

 
Note 

The warm-up may already have taken place before, if the 
machine has already processed material after switching it on. 

 

➨ The line to be milled is displayed in the machining view and the line is 
milled: 

Fig. 107: 
Machining view 
with milled line 
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➨ The dialog with the results is displayed: 

Fig. 108: Results  

 
 

 
Hinweis 

If the option Adjust width manual for micro cutter is set to 
False, the milling width is measured with the camera and 
measurement with the microscope is omitted. The option Adjust 
width manual for micro cutter can be found in Extras > 
Options under the item “Machine”. 

 
6. Measure the milling width by using a microscope. 
 

 
Note 

To determine the correct milling width, put on the 
microscope at the lower, inner edges of the copper: 

 

 
7. Enter the measured value into the field \ Measured width \. 

 
Note 

If there is a difference between the desired milling width and the 
measured width CircuitPro PM automatically proposes a 
correction value. 

 

 
Note 

You can manually enter a correction value if you do not want to 
apply the value proposed by CircuitPro PM. 

 
8. Increase or decrease the value of the proposed correction by using the two 

arrow buttons. 
9. To mill the line with the entered proposed correction, click on [Repeat]. 
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➨ The new line is milled onto the base material with a slight offset and the 
dialog with the results is displayed: 

Fig. 109: Results  

 
 
10. Measure the milling width by using a microscope. 
11. Enter the measured value into the field \ Measured width \. 
12. Repeat steps 6 - 12 until the desired milling width is reached. 
or 
9. Click on [Store correction] to apply the proposed value. 

➨ The correction value for the current tool has been applied. The dialog is 
closed. 

 
Note 

If you do not want to apply any correction click on [Cancel]. 

 
 The milling width has been checked. 
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 Discarding a tool  
If the tool life of a tool is spent, the tool should be discarded to ensure optimum 
milling results. 
 

 
Note 

Please note that all information on the tool to be discarded will 
be deleted. 

 
1. Activate the check box of the tool to be discarded. 

➨ The button “Discard tool” is activated. 

Fig. 110: Replace 
tool 

 
 
2. Click on [Discard tool]. 

➨ The following message is displayed: 

Fig. 111: Tool 
replacement 

 
 
3. Confirm by clicking on [Yes]. 
 

 
Note 

If the tool to be discarded is currently in the clamp, the tool is 
put back into its corresponding magazine position. 

 

➨  A message is displayed which prompts you to discard the tool. 
4. Replace the old tool in the machine with a new one. 
  The old tool is discarded. 
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 Tool magazine ProtoMat S43/E33/E34/E44/X60 5.2.10
(manual tool change)  

The “Tool magazine” dialog moves the milling head to the zero position to allow 
a manual tool change. 
Click on Edit > Tool magazine… or the following icon of the toolbar to open the 
dialog: 
 

Fig. 112: Tool 
magazine icon 

 
 
The following dialog is displayed. 

Fig. 113: Tool 
magazine dialog 
for E33 and S43 

 
 /1/ Tool selection list /2/ Tool in clamp 

 

 Performing a manual tool change 
1. Select the tool that you want to mount into the clamp from the tool selection 

list /1/. 
 

 
Note 

This example uses the tool “Universal Cutter 0,2 mm”. 
 
 

 
2. Click on [Continue]. 

➨ The following message is displayed: 

Fig. 114: Tool 
change 

 
 
3. Mount the tool. 
4. Click on [OK]. 
 The manual tool change is finished. 

1 2 
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 Measuring the milling width 

 
Note 

Please note, that you can only measure the milling width of a 
conical tool. 

 
1. Click on [Milling Width]. 

➨ The following dialog is displayed: 

Fig. 115: Measure 
Milling Width 

 
 
2. Click on the position in the Machining view where you want to mill the line. 
3. Enter the length of the line to be milled. 
4. Select an option: 

• Horizontal milling line 
• Vertical milling line 

5. Click on [Mill a Line]. 

➨ The line is milled at the selected position. 
6. Measure the milling width by using a microscope. 
 

 
Note 

To determine the correct milling width, put on the microscope 
at the lower, inner edges of the copper: 

 

 
7. Click on [Accept Width], if the milling width is okay. 
If not 
7. Adjust the tool manually and mill a line again until the result of the milling 

width is okay. 
 The milling width is measured. 
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 Tool magazine ProtoMat S63/S103/H100  5.2.11

The tool magazine dialog lets you 
• view a list of the tools required for the current project, 
• view the tools currently present in the machine, 
• load the tool magazine, 
• view/put back the tool currently present in the clamp, 
• pick up a tool with the clamp, 
• check the milling width of a tool (only for Universal Cutter and Micro Cutter), 
• view the current state of the tool life spent and 
• replace an old tool with a new one. 

 

 
Note 

The “Tool magazine” dialog offers these options only for 
machines with automated tool change. This comprises the 
ProtoMat S63 and the ProtoMat S103. 

 
Click on Edit > Tool magazine… or the following icon of the toolbar to open the 
dialog: 

Fig. 116: Tool 
magazine icon 

 
 
The following Dialog is displayed: 

Fig. 117: Tool 
magazine 

 
 

 /1/ Required tools 
/2/ Button “Check milling width…” 

/3/ Button “Discard tool” 
/4/ Tools in the machine 

 
It is necessary to load the tool magazine for processing a project. In section /1/, 
CircuitPro PM displays the tools that are required for processing the project. 

2 3 4 1 
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The required tools have to be inserted into the tool magazine manually. You can 
either 
• insert the tools into the tool holders and then assign them to the tool holders 

accordingly in section /4/ or 
• assign tools to the tool holders in the “Tool magazine” dialog and then insert 

the tools into the tool Holders according to the list. 
  

 Loading the tool magazine  
1. Click on the drop-down list of the first tool holder: 

Fig. 118: Drop-
down list of the 
tool holder 

 
 

➨ A list of all tools that you can use with the machine is displayed. 
2. Select the required tool (in this case: Universal Cutter 0.2 mm, as in 

adjacent list): 
Fig. 119: 
Assigning a tool 
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➨ The tool is marked with a green check mark in the list of the required tools. 
Also, a green check mark is displayed next to the corresponding drop-down 
list and the tool life spent is displayed on the right. 

3. Repeat above steps for all tools that are required for your project with the 
other tool holders. 

Fig. 120: Tool 
magazine loaded 

 
 
 The tool magazine is loaded. 

 

 Picking up a tool with the clamp 
1. Click on the following button next to the drop-down list: 

Fig. 121: Picking 
up a tool 

 
 

➨ The following message is displayed while the clamp picks up the tool: 

Fig. 122: Message 
picking up tool 

 
 

➨ The symbol on the tool's button changes: 

Fig. 123: Tool 
currently in 
clamp 

 
 
 The tool is now in the clamp. 
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 Putting the tool back to its magazine position 
1. Click on the following button next to the drop-down list: 

Fig. 124: Putting 
down a tool 

 
 

➨ The following message is displayed while the clamp puts down the tool: 

Fig. 125: Message 
tool release 

 
 

➨ The symbol on the tool's button changes: 

Fig. 126: Tool not 
in clamp 

 
 
 The tool is back at its corresponding magazine position.  

 
  



 
How to work with CircuitPro PM CircuitPro PM 2.3  

 
 

118 V1.1 – 11.2016 © 2016 LPKF AG 

5 

 Checking the milling width (Universal Cutter) 
A tool has to be in the clamp to enable checking the milling width. 
A short line is milled that is subsequently measured with the camera. 
 
1. Pick up the tool with the clamp (see procedure “Picking up a tool with the 

clamp”). 

➨ The tool is now in the clamp. 
2. Activate the check box of the tool currently in the clamp: 

Fig. 127: Check 
box activated 

 
 

➨ The button “Check milling width…” is active. 
 

 
Note 

If a tool the milling width of which cannot be checked (e.g. 
Spiral Drill etc.) is in the clamp the button is not activated. 

 
3. Click on [Check milling width…]. 

  



 
CircuitPro PM 2.3 How to work with CircuitPro PM 

   

© 2016 LPKF AG  V1.1 – 11.2016 119 

5 

➨ The following message is displayed: 

Fig. 128: Defining 
a machine area 

 
 
4. Click on a position outside the area to be used for the project (but inside the 

processing area) to mill a line (see figure above). 
 

 
Note 

Please make sure that the milled line is inside the working area 
of the camera so that the camera can measure the line. 

 

➨ The milling head moves to the corresponding position in the processing 
area.  

5. Click on [OK]. 
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➨ The dust extraction of the machine is switched on, the milling head moves 
to the zero position and the spindle motor is warmed up: 

 

Fig. 129: Warm-
up of spindle 
motor 

 
 

 
Note 

The warm-up may already have taken place before, if the 
machine has already processed material after switching it on. 

 

➨ The line to be milled is displayed in the machining view and the line is 
milled: 

Fig. 130: 
Machining view 
with milled line 
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After the line has been milled the camera moves to the corresponding position. 
The “Camera” pane displays the line just milled: 
 

Fig. 131: 
“Camera” pane 

 
 

➨  The dialog with the measurement results is displayed: 

Fig. 132: 
Measurement 
results 

 

 

If there is a difference between the desired milling width and the measured 
width CircuitPro PM automatically proposes a correction value. 
6. Click on [Store correction] to apply the proposed value. 
 
You can manually enter a correction value if you do not want to apply the value 
proposed by CircuitPro PM. 
7. Increase or decrease the value of the proposed correction by using the two 

arrow buttons. 
8. Click on [Store Correction]. 
 
If you do not want to apply any correction click on [Cancel]. 

➨ The dialog is closed. 
 The milling width of the tool currently in the clamp was checked. 
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Note 

Please note that the tool has to be put back into the holder and 
picked up again in order to have the corrected settings be 
applied. 

 

 Checking the milling width (Micro Cutter) 
A tool has to be in the clamp to enable checking the milling width of that tool.  
First, a short line is milled that is subsequently measured with the microscope. 
 
1. Pick up the tool with the clamp (see procedure “Picking up a tool with the 

clamp”). 

➨ The tool is in the clamp. 
2. Activate the check box of the tool currently in the clamp: 
 

Fig. 133: Check 
box activated 

 
 

➨ The button “Check milling width…” is active. 
 

 
Note 

If a tool the milling width of which cannot be checked (e.g. 
Spiral Drill etc.) is in the clamp the button is not activated. 

 
3. Click on [Check milling width]. 
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➨ The following message is displayed: 

Fig. 134: 
Definition of 
machine area 

 
 
4. Click on a position outside the area to be used for the project (but inside the 

processing area) to mill a line (see figure above). 

➨ The milling head moves to the corresponding position in the processing 
area.  

5. Click on [OK]. 
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➨ The dust extraction of the machine is switched on, the milling head moves 
to the zero position and the spindle motor is warmed up: 

 
Fig. 135: Warm-
up of spindle 
motor  

 
 

 
Note 

The warm-up may already have taken place before, if the 
machine has already processed material after switching it on. 

 

➨ The line to be milled is displayed in the machining view and the line is 
milled: 

 
Fig. 136: 
Machining view 
with milled line 
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➨ The dialog with the results is displayed: 

Fig. 137: Results  

 
 

 
Hinweis 

If the option Adjust width manual for micro cutter is set to 
False, the milling width is measured with the camera and 
measurement with the microscope is omitted. The option Adjust 
width manual for micro cutter can be found in Extras > 
Options under the item “Machine”. 

 
6. Measure the milling width by using a microscope. 
 

 
Note 

To determine the correct milling width, put on the 
microscope at the lower, inner edges of the copper: 

 

 
7. Enter the measured value into the field \ Measured width \. 

 
Note 

If there is a difference between the desired milling width and the 
measured width CircuitPro PM automatically proposes a 
correction value. 

 

 
Note 

You can manually enter a correction value if you do not want to 
apply the value proposed by CircuitPro PM. 

 
8. Increase or decrease the value of the proposed correction by using the two 

arrow buttons. 
9. To mill the line with the entered proposed correction, click on [Repeat]. 
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➨ The new line is milled onto the base material with a slight offset and the 
dialog with the results is displayed: 

Fig. 138: Results  

 
 
10. Measure the milling width by using a microscope. 
11. Enter the measured value into the field \ Measured width \. 
12. Repeat steps 6 - 12 until the desired milling width is reached. 
or 
9. Click on [Store correction] to apply the proposed value. 

➨ The correction value for the current tool has been applied. The dialog is 
closed. 

Note 

If you do not want to apply any correction click on [Cancel]. 

 
 The milling width has been checked. 
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 Discarding a tool  
If the tool life of a tool is spent, the tool should be discarded to ensure optimum 
milling results. 
 

 
Note 

Please note that all information on the tool to be discarded will 
be deleted. 

 
1. Activate the check box of the tool to be discarded. 

➨ The button “Discard tool” is activated. 

Fig. 139: Replace 
tool 

 
 
2. Click on [Discard tool]. 

➨ The following message is displayed: 

Fig. 140: Tool 
replacement 

 
 
3. Confirm by clicking on [Yes]. 
 

 
Note 

If the tool to be discarded is currently in the clamp, the tool is 
put back into its corresponding magazine position. 

 
4. Replace the old tool in the machine with a new one. 
  The old tool is discarded. 
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 Tool library 5.2.12

The tool library contains the tools that you selected when setting up the 
machine (equipment configuration wizard). 
The dialog allows the following operations: 
• Adding new tools 
• Deleting existing tools 
• Defining filters for displaying the categories, tool types, and materials 
• Adding new materials or delete existing ones 

Fig. 141: Tool 
library 

 
 /1/ Display of available tools /2/ Detailed information on the 

selected tool 

 
  

1 
 

2 
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 Displaying tool information 
1. First select the type of your machine in the drop-down list \Machine type\. 

➨ The tools which are assigned to your machine type are displayed in the 
section “Available tools”.  

2. In section /1/, click on the tool whose detailed information you would like to 
view. 

➨ In section /2/, now the relevant detailed information on the selected tool is 
shown with an image: 

 
Fig. 142: Detailed 
information 

 
 

  

Fig. 143: Detailed 
information on 
the laser 

 

  

 
The materials which can be processed are listed under each tool.  
3. Click on the arrow symbol next to the respective tool: 
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➨ The materials are listed and the following information is displayed in 
section /2/: 

 
Fig. 144: Material 
display 

 

 /1/ Material display /2/ Detailed information on the materials 

• Feed Speed 
• Rotation Speed 
• Maximum Tool Life 
• Maximum penetration depth [mm] 
• Z penetration offset [mm] 
 

Fig. 145: Material-
anzeige Laser 

 

 /1/ Material display /2/ Detailed information on the 
materials 

   

• Feed Speed [mm/s] 
• Maximum penetration depth [mm] 
• Z penetration step [mm] 
• Diameter [mm] 
• Laser power [W] 
• Laser on delay [ms] 
• Laser off delay [ms] 
• Runs 
 The detailed information has been displayed. 

  

1 

2 

1 

2 
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 Removing an existing tool from the list 
1. In section /1/, click on the tool that you want to remove from the list. 
2. Click on [Remove tool]. 
 The tool is removed from the list. 

 

 Adding a new tool 
1. Click on [Add tool…]. 

➨ The following dialog is displayed: 

Fig. 146: Add tool 

 
 

 Adding LPKF tools 
1. Click on “Add LPKF tools…”. 

➨ The following dialog is displayed: 

Fig. 147: Add 
LPKF tool 
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2. Select a tool from the list. 

➨ The associated materials are displayed in the list.  
3. Click on [Close]. 
 The tool has been added. 

 

 Adding custom tools 
1. Click on “Add custom tools...”. 

➨ The following dialog is displayed: 

Fig. 148: Add 
custom tool 

 

 
2. Select a tool type. 
3. Enter a tool name. 
4. If necessary, enter a tool description. 
5. Set the tool diameter. 
6. Select a base tool from the current list of available tools. 
7. Click on the materials for which the tool is to be used. 

➨ The “Add tool” button is active. 
8. Click on [Add tool]. 

➨ The new tool appears in the tool list. 
9. Click on [Close]. 

➨ The dialog is closed.  
 The custom tool has been added. 
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 Adding dispense tools 
1. Click on “Add dispense tools...”. 

➨ The following dialog is displayed: 

Fig. 149: Add 
dispense tools 

 

 
2. Enter a tool name. 
3. If necessary, enter a tool description. 
4. Set the tool diameter. 
5. Select a base tool from the current list of available tools. 
6. Click on the materials for which the tool is to be used. 

➨ The “Add tool” button is active. 
7. Click on [Add tool]. 

➨ The new dispense tool appears in the tool list. 
8. Click on [Close]. 

➨ The dialog is closed.  
 The dispense tool has been added. 
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 Editing materials 
The dialog “Edit Materials” allows you to add new materials (optionally using 
tool parameters of other materials) or remove existing ones. 
1. Click on [Edit materials…]. 

➨ The following dialog is displayed: 

Fig. 150: Edit 
materials 

 
 
In this dialog, the following options are available: 
• Adding materials 
• Adding materials with the tool parameters of materials already available 
• Removing materials that are added individually. 
 

 Adding materials 
1. Enter a name for the new material. 
2. Click on [Add material]. 

➨ The material is displayed in the list “Available materials”. 
3. Click on [Close]. 

➨ The dialog is closed. 
 The new material has been added. 

 
  



 
CircuitPro PM 2.3 How to work with CircuitPro PM 

   

© 2016 LPKF AG  V1.1 – 11.2016 135 

5 

 Add materials with the tool parameters of materials already available 
If you want to add a new material that has the same tool parameters as a 
material already available, please follow these steps: 
1. Enter the name for the new material. 
2. Mark the checkbox <Copy all tool parameters from:> 
3. Now select the material whose properties you would like to copy from the 

drop-down list. 
4. Click on [Add material]. 

➨ The new material, with the copied tool parameters, is added to the list of 
available materials. 

5. Click on [Close]. 

➨ The dialog is closed. 
 The new material, with the tool parameters for materials already available, 

has been added. 

 

 Removing materials that are added individually 
1. In the list of the available materials, please click on the material that has 

been added individually. 
  

 
Note 

Only materials that have been added individually can be 
removed. Default materials of the LPKF tools cannot be 
removed. 

  

 
2. Click on [Delete]. 

➨ The selected material is removed. 
3. Click on [Close]. 

➨ The dialog is closed. 
 The material that has been added individually has been removed. 

 
 Material editing is complete. 
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 Defining filters 
You can define one filter each for the tool types and materials. The filter is used 
to display only information significant for you. 
The tabs “Tool type” and “Material” contain your customised entries. 
1. Click on [Define filter…]. 

➨ The following dialog is displayed: 

Fig. 151: Define 
filter 

 
 
2. Click on the tool type/material that the filter shall apply to. 
 

 
Note 

Each tab offers the option to select the standard filter for the 
tool type or the material. These standard filters are defined by 
the system and cannot be modified. 

 
3. Click on [OK]. 

➨ The changes were adopted and the dialog is closed. 
 The filters are defined. 

 
Pos: 6.3.15 /ED _Technische_D okumentati on/2_Bedienungsanl eitung/Software/CircuitPr o 2.1/Kapitel 5_So ar beiten Sie mi t CircuitPro PM /3_Menü Bearbeiten/12_Bl endenlistenbi bliothek @ 5\mod_1380612161192_2058.docx @ 120328 @ 3 @ 1 
 

  



 
CircuitPro PM 2.3 How to work with CircuitPro PM 

   

© 2016 LPKF AG  V1.1 – 11.2016 137 

5 

 Aperture list library 5.2.13

A dialog to manage the apertures of the current project and the apertures and 
aperture lists in the aperture list library can be started by clicking on 
Edit > Aperture list library. 
 

 
Note 

Please note that CircuitPro PM automatically loads the *.cbf file 
“ApertureListsLibrary.cbf” when the aperture library is opened 
for the first time. CircuitPro PM displays a corresponding 
message. 
When using Windows XP, the file “ApertureListsLibrary.cbf” is 
stored in folder C:\Documents and Settings\User 
name\Local Settings\Application Data\LPKF 

Laser&Electronics\LPKF CircuitPro PM 2.3. 
When using Windows 7, the file “ApertureListsLibrary.cbf” is 
stored in folder C:\Users\User name\AppData\Local\LPKF 
Laser&Electronics\LPKF CircuitPro PM 2.3. 
When using Windows 8, the file “ApertureListsLibrary.cbf” is 
stored in folder C:\Users\User name\AppData\Local\LPKF 
Laser&Electronics\LPKF CircuitPro PM 2.3. 

 
Fig. 152: Aperture 
list library 

 

 
 /1/ File name 

/2/ Aperture lists 
/3/ Detail section: contains the individual apertures 
of the selected aperture list. 

/4/ Copy 
/5/ Remove a single 
aperture 
/6/ Remove aperture list 

 
  

1 

2 

3 

6 

4 
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The following operations are available in the “Aperture list library” dialog: 
• Copying aperture lists from the current project into the aperture list library 

(thus making them available in other projects). 
• Copying aperture lists available in the aperture list library into the current 

project. 
• Removing apertures from the library. 
 
By default, the aperture library is stored as a *.cbf file. 
 
You can also load custom *.cbf files in the dialog to edit the contained aperture 
libraries. 
 

 
Note 

Unless you open a new file in the “Aperture list” dialog, 
CircuitPro PM automatically loads the aperture library that was 
used last when opening the dialog. 

 

 Copying an aperture list from the current project to the aperture list library 
1. Select the aperture list to be copied in /2/. 
2. Click on [Copy]. 

➨ The following dialog is displayed: 

Fig. 153: Copy 
aperture list to 
library 

 

 
 
3. Enter a name for the aperture list to be created. 
4. Click on [OK]. 
 The aperture list is copied to the aperture list library. 
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 Copying an aperture list from the aperture list library to the current project 
1. Select the aperture list to be copied in /2/. 
2. Click on [Copy]. 

➨ The following dialog is displayed: 

Fig. 154: Copy 
aperture list to 
document 

 

 
 
3. Enter a name for the aperture list to be created. 
4. Click on [OK]. 
 The aperture list is copied to the current project. 

 

 Removing an aperture list from the library 
 

 
Note 

Please note that only aperture lists that are not used in the 
current *.cbf document can be removed from the aperture list 
library. 

 
1. Click on the aperture list in /2/ that you want to remove. 
2. Click on [Remove aperture list]. 
 The aperture list is removed from the library. 

 

 Removing an aperture from the aperture list 
 

 
Note 

Please note that only apertures that are in a library's aperture 
list can be removed. 

 
1. Click on the aperture in /3/ that you want to remove. 
2. Click on [Remove]. 
 The aperture is removed from the aperture list. 
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 Design Rule Check 5.2.14

The design rule check helps you to check whether the design meets defined 
and recommended standards for producing circuit boards. 

Fig. 155: Design 
rule check 

 
 
You can check the following: 
• Spacing between objects that are on different layers. 
• Spacing between objects on the same layer. 
This function enables you to check before isolation whether the object spacing 
matches the size of the tool used, thus ensuring flawless isolation. 
 

 
Note 

In order to check the object spacing, check the size of the tool 
you want to use for isolation first. You can find this information 
in the menu item “Technology dialog”. 
For more information on the menu item “Technology dialog” 
see the corresponding chapter. 
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 Checking the spacing between two layers 
1. Click on the first layer in the drop-down list “Source objects”. 
2. Click on the second layer in the drop-down list “Additional source objects”. 

Fig. 156: 
Checking the 
spacing between 
2 layers 

 
 
3. Select a result layer. 
 

 
Note 

It is recommended to create a new result layer. 

 
4. Enter the minimum spacing to check in millimetres. 
5. Click on [Run]. 

➨ The design rule check is started. A new result layer “DRC_Errors” is created 
in the “Layers” pane: 

Fig. 157: Result 
layer 

 
 

Fig. 158: 
Violations count 

 
 

➨ The number next to the layer name “DRC_Errors” shows how often the 
design rules were violated 

  The design rule check is finished. 
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 Checking the spacing within a layer 
1. In the drop-down list “Source objects”, select the first layer whose object 

spacing you want to check. 
2. Select a result layer. 

Fig. 159: 
Checking the 
spacing within a 
layer 

 
 

 
Note 

It is recommended to create a new result layer. 

 
3. Enter the minimum spacing to check in mm. 
4. Click on [Run]. 

➨  The design rule check is started. A new result layer is created in the 
“Layers” pane: 

Fig. 160: Result 
layer 

 
 

➨ The number next to the layer name “DRC_Errors” shows how often the 
design rules were violated. 

 The design rule check is finished. 
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Fig. 161: 
Violations count 
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 Measure 5.2.15

Use this function to measure the distance between two points. 
 

 Measuring the distance between two points 
1. Click on Edit > Measure. 
2. In the graphical view (CAM view/3Dview/Machining view), click on the 

starting point from which to measure. 
3. Move the mouse to the second point in order to measure the distance. 

➨ The mouse cursor draws a line. 
4. Read the length of the line from the status bar of CircuitPro PM. 

Fig. 162: Measure 

 
 
 The distance between the two points is measured. 
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 Distance 5.2.16

Use the “Distance” dialog to measure the distance between two objects that are 
on the same layer. 
 

 Measuring the distance between two objects 
1. Click on Edit > Distance… 

➨ The following dialog is displayed: 

Fig. 163: Distance 

 
 
2. Select an object in the drop-down list “First object”. 
3. Select the second object in the drop-down list “Second object”. 
 

 
Tip 

You can also click on the desired objects in the CAM view. 
1. Click on the radio button of “First object” in the dialog. 
2. Click on the desired object in the CAM view. 
 The name of the selected object is transferred to the “First 
object” field. 
3. Repeat steps one and two for the “Second object” field. 

 

➨ The distance between the two objects is measured. Two distances are 
displayed: 

 
• Between center of objects: This value is the distance between the center 

points of the objects. 
• Minimum: This value is the shortest distance between the two objects. 
 

 
Tip 

If you do not know the name of an object, you can find it in the 
“Properties” pane. 
Select the object and click on the item “General” in the 
“Properties” pane. The name property of the selected object is 
displayed. 

 
 The distance between the two objects was measured.  
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 Set anchor point  5.2.17

An anchor point is a reference point in the drawn object. In the CAM view, the 
anchor point is marked by a magenta-colored asterisk (see following figure). 

Fig. 164: Anchor 
point in CAM 
view 

 
 
Using the anchor point function, you can determine the object reference points. 
Click onto a reference point of the object and read the coordinates in the status 
bar of CircuitPro PM (Anchor point X and Y). 
 

Fig. 165: Anchor 
point in object 

 
 /1/ Object reference point /2/ Anchor point 

You can change the position of the anchor point by entering new X and Y 
values and thus setting a new starting point for a drawn object. 
 

1 

2 
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 Setting an anchor point 
1. Click on Edit > Set anchor point... 

➨ The following dialog is displayed: 

Fig. 166: Set 
anchor point 

 
 
2. Enter the “X value” of the anchor point. 
3. Enter the “Y value” of the anchor point. 
4. Click on [Apply]. 

➨ The values of the anchor point are displayed in the status bar of CircuitPro 
PM. 

 The anchor point is set. 
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 Set Zero Point 5.2.18

The zero point is a reference point used for measured and computed values. 
You can shift the zero point in the CAM view. This moves the zero point to the 
current anchor point. Thus, you can start new measurements /computations 
from this new zero point. 

Fig. 167: Set zero 
point on current 
anchor point 

 
 /1/ Cursor position=zero point 

/2/ X and Y value of the cursor 
position 
 

/3/ X and Y value of the anchor 
point 
/4/ Position of the anchor point 

  Setting the zero point 
1. Click on Edit > Set zero point... 
  The zero point is moved to the current anchor point. 
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 Move anchor to center point  5.2.19

Using the function "Move anchor to center point", you can set the current 
anchor point to the central point of the object marked. 

 Setting the anchor to the central point 
1. Mark the center point of the object to which you would like to move the 

anchor point. 

➨ The object is marked: 
Fig. 168: Mark 
object 

 

 /1/ Current anchor point  
   

2. Click on Edit > Move anchor to center point… 

➨ The anchor point is moved to the center point of the object: 
Fig. 169: Mark 
object 

 

 /1/ Moved anchor point  
   

 The anchor point was moved to the center point. 

1 
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 Move layer to zero 5.2.20

Use “Move layer to zero” to move flash objects of a layer to the zero point of the 
layer: 

Fig. 170: Move 
layer to zero 

 
 /1/ Cursor position=zero point /2/ Object to be moved 

 

 Moving a flash object to the layer's zero point 
1. Select the flash object /2/ that you want to move to the layer's zero point /1/. 

➨ The object is highlighted in grey. 
2. Click on Edit > Move layer to zero. 

  

1 
2 
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➨ The flash object is moved to the layer's zero point: 

Fig. 171: Flash 
object moved to 
the layer's zero 
point 

 
 
 The flash object was successfully moved to the layer's zero point. 
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 Match up layers 5.2.21

Use the function ”Match up layers” to align flashed objects that are on different 
layers. 

 
Note 

Use “Draw to flash” in the “Edit” menu to convert objects into 
flash objects. For a detailed procedure see the corresponding 
chapter. 

 
The selected object is moved to the center of the object that is on the reference 
layer. The center points of the two objects are aligned. 
 

 
Note 

Please note that the whole layer is moved together with the 
object to be aligned. Thus, all object of the layer are assigned 
new coordinates. 

 
The following figure shows two flash objects. They are on the layers “TopLayer” 
and “BottomLayer” and are to be aligned: 

Fig. 172: Flash 
objects 

 
 /1/ Flash object on TopLayer /2/ Flash object on BottomLayer 

 
The center point of the flash object on TopLayer (see /1/) has the coordinates 
X=7 and Y=7. 
The center point of the flash object on BottomLayer (see /2/) has the 
coordinates X=15 and Y=2. 
 

  

1 

2 
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  Matching up layers 
1. Click on Edit > Match up layers… 

➨  The following dialog is displayed: 

Fig. 173: Match 
up layers 

 
 /1/ Radio button for the layer to be 

aligned 
/2/ Radio button for the reference layer 

 
2. Activate the radio button /1/ for selecting the layer to be aligned. 
3. In the CAM view, click on the object whose center point is to be aligned to 

the reference layer. 
Fig. 174: 
Selecting the 
layer to be 
aligned 

 
 /1/ Coordinates of the selected object and name of the layer 

 

➨  The object is highlighted in grey. The coordinates of the object and the 
name of its layer are displayed in the dialog. 

4. Activate the radio button /2/ (see figure above) for the reference layer. 
5. Click on the object whose center point is to be used as the reference for the 

object to be aligned. 
 

1 

2 

1 
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Fig. 175: 
Selecting the 
reference layer 

 
 /1/ Coordinates of the selected object and name of the layer 

➨  The object is highlighted in grey. The coordinates of the object and the 
name of its layer are displayed in the dialog. 

6. Click on [Apply]. 

➨  The layer to be aligned is aligned to the reference layer: 

Fig. 176: Layer 
aligned 

 
 

  

1 
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The center points of both objects have the coordinates X=15 and Y=2. You can 
find these values in the status bar of CircuitPro PM and also in the “Properties” 
pane of each object: 

Fig. 177: 
Properties 

 
 
  The layers have been aligned successfully. 
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 Match up objects 5.2.22

Use the function ”Match up objects” to align any geometrical object (circle, 
rectangle, circle path, polygon etc.). The objects to be aligned do not have to be 
on the same layer. 
This function places the object to be aligned on the center of the reference 
object. 
The following figure shows a circle and a rectangle. They are on the layers 
“SolderMaskTop” and “BottomLayer” and are to be aligned: 

Fig. 178: Drawn 
objects 
 

 
 /1/ Circle object on layer 

“SolderMaskTop” 
/2/ Rectangle object on BottomLayer 

 

 Aligning objects 
1. Click on Edit > Match up objects… 

➨ The following dialog is displayed: 

Fig. 179: Match 
up objects 

 
 /1/ Radio button for the object to be 

aligned 
/2/ Radio button for the reference object 

 
2. Activate the radio button /1/ for selecting the object to be aligned. 
3. In the CAM view, click on the object that is to be aligned: 

1 

2 

1 
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Fig. 180: 
Selecting object 
to align 

 
 /1/ Coordinates and name of the selected object 

➨ The object is highlighted in grey. The coordinates and the name of the 
object are displayed in the dialog. 

4. Activate the radio button /2/. 
5. Click on the object that is to serve as the reference object. The object to be 

moved will be centered on this object: 
  

1 
1 
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Fig. 181: 
Selecting 
reference object 

 
 /1/ Coordinates and name of the selected object 

➨ The reference object is highlighted in grey. The coordinates and the name 
of the object are displayed in the dialog. 

6. Click on [Apply]. 

➨ The object to be aligned is moved onto the center of the reference object. 

Fig. 182: Object 
aligned 

 
 
 The operation “Match up objects” is finished successfully. 
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 Delete 5.2.23

Use this function to delete the currently selected objects. 

 Deleting selected objects in the CAM view 
 

 
Note 

Please ensure that the selection mode (arrow icon /1/) is 
activated (see following figure). 

 
1. In the CAM view, click on the object to be deleted: 

Fig. 183: 
Selecting an 
object for 
deletion 

 
 /1/ Selection mode icon /2/ Selected object 

 

➨ The object is highlighted in grey. 
2. Click on Edit > Delete. 
 The selected object is deleted. 
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5.3 Menu Insert 

The “Insert” menu contains several objects that can be created in the CAM 
view. 
Click on the “Insert” menu item to open the submenu: 

Fig. 184: Menu 
“Insert” 

 
 
The following table contains short descriptions of the functions of the individual 
menu items: 

Table 32: “Insert” 
menu functions 

 

Menu item Description 

Open path… Creates an open path in the CAM view. 

Closed path… Creates a closed path in the CAM view. 

Polygon… Creates a polygon in the CAM view. 

Rectangle… Creates a rectangle in the CAM view. 

Circle… Creates a circle in the CAM view. 

Circle path… Creates a circle path in the CAM view. 

Flash… Creates a flash object in the CAM view. 
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Table 32: “Insert” 
menu functions 

 

Menu item Description 

Text… Creates a text object in the CAM view. 

Polygon with cutouts… Creates a polygon with cutouts in the CAM 
view. 

Copper pouring… Creates an insulated copper area around 
conductive tracks. 

Rubout area Creates an area where all unnecessary copper 
is removed. 

Fiducial Creates fiducials in the CAM view. 

Topography Creates grid points for recognizing the board 
topography. 

 
Drill hole… Inserts drill holes in the CAM view. 

 
Milling curve… Inserts a toolpath in the CAM view. 

 
Pos: 6.4.2 /ED_Technische_Dokumentation/2_Bedi enungsanleitung/Software/CircuitPro 2.1/Kapitel 5_So arbeiten Sie mit CircuitPr o PM/4_M enü Einfüg en/02_Offener_Lini enzug @ 6\mod_1383659994398_2058.docx @ 126424 @ 3 @ 1 
 

 Open path 5.3.1

The menu item “Open Path” lets you create any open path consisting of line 
segments and arcs. You can combine line segments and arcs thus forming the 
open path: 

Fig. 185: Open 
path examples 

 
 
There are different ways to create an open path: 
• Entering the X and Y values of the segment in the dialog window. 
• Moving the mouse pointer to the desired position in the CAM view thus 
drawing the segment/arc. Please ensure that the selection mode (arrow icon) is 
activated (see following figure): 
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Fig. 186: 
Selection mode 
(arrow icon) 
activated 

 
 

 
Note 

You have to be in the CAM view of CircuitPro to be able to 
insert or modify geometrical forms (open paths, polygons, etc.) 
of the design! 

 

 Creating an open path with segments 
1. Click on Insert > Open path. 

➨ The following dialog is displayed: 

Fig. 187: Open 
path 

 
 
2. In the drop-down list, select the layer where you want to create the open 

path. 
3. Select either absolute or a relative start point by clicking on the 

corresponding radio button. 
 

 
Note 

The absolute start point  is computed using the X and Y 
coordinates starting from the zero point . 
If you want to create more than one open path you can make all 
paths start from the same starting point using the “Absolute” 
start point option. 
The relative start point  is variable. Once you have created a 
segment, the relative start point moves automatically to the end 
of this segment to serve as start point for the next segment to be 
created. 

 

 
Note 

Please note that the magenta-colored asterisk in the view 
always denotes the anchor point , not the zero point ! 

 
4. Enter the X and Y value of the start point in millimeters. 
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5. Enter the X and Y values of the segment. 
6. Select the desired “curve width”: 

Fig. 188: Creating 
a segment 

 

  
Aperture: 
• If your document contains an aperture list you can select an aperture for 

creating the open path. 
• If no aperture list is stored in your document, a line without defined width is 

created. 
Numeric: 
• The “Numeric” option lets you define the line width in millimeters. 
7. Click on [Set]. 

➨ The segment is created. 

 
Note 

Function of the “Apply” and “Set” buttons: 
Once you have created  a segment you can finish your entries 
using either [Apply] or [Set]. 
If you use [Set] you can still remove the segment by clicking on 
[Remove last]. You can add as many segments as you like. 
If you use [Apply] for creating the segment, it cannot be 
removed afterwards. You also cannot add any more segments. 

 

8. Repeat the above steps if you want to create another segment. 
9. Click on [Apply] to create the open path. 
Or 
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10. Press the right mouse button as an alternative. 

➨ The context menu is displayed: 

Fig. 189: Creating 
a second 
segment 

 

  
10. Click on “End” to finish creating the open path. 

➨ The open path is created. 
11. Click on [Close] in the dialog. 

➨ The dialog is closed. 
 The open path with segments is created. 

 

 
Tip 

Procedure without entering X and Y values: 
You can also create segments in CircuitPro without entering 
coordinates. You can just use the mouse pointer. 
1. Press the left mouse button at the desired start point of the 
segment in the CAM view. 
2. Move the mouse pointer to the desired position in the CAM 
view. 
3. Press the left mouse button. 
 The segment is created. 
• A left-click corresponds to clicking the [Set] button in the dialog. 
• Pressing the right mouse button opens the context menu and 
you can finish creating the path by clicking on “End”. This 
corresponds to clicking on [Apply] in the dialog. 
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Tip 

If you want to abort creating the path press the ESC key. 

 Creating an open path with arcs and segments  
You can combine as many line segments and arcs as you like when creating an 
open path. This example describes how to create an arc that combined with a 
line segment forms an open path. 
1. Perform the steps 1 to 7 of “Creating an open path with segments”. 

➨ A line segment is created. 
2. Activate the radio button “Make arc” 
Or 
2. Press the right mouse button and select “Arc” in the context menu. 

Fig. 190: 
Selecting “Arc” in 
context menu 

 

 
3. Select whether the direction of the arc should be “Clockwise” or “Counter-

clockwise”. 
4. Enter the radius of the arc. 
5. Enter the opening angle of the arc. 
 

 
Tip 

Creating arcs with the mouse pointer 
1. Activate the “Arc” option in the dialog or in the context menu. 
2. In the CAM view, click on the desired end point of the arc. 
3. Drag the mouse to the left or to the right until the arc has the 
desired size. 

 
6. Click on [Apply]. 
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➨ An arc is created: 

Fig. 191: Creating 
an arc 

 

 
7. Click on [Close] in the dialog. 

➨ The dialog is closed. 
 The open path with an arc and a segment is created. 
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 Closed path 5.3.2

The menu item “Closed Path” lets you create any closed path consisting of line 
segments and arcs. You can combine as many line segments and arcs as you 
like. Creating a closed path requires at least two segments or two arcs or one 
segment plus one arc. These form the closed path in the end. 

Fig. 192: 
Examples closed 
paths with 
segments and 
arcs 

 
 
There are different ways to create a closed path: 
• Entering the X and Y values of the segment in the dialog window. 
• Moving the mouse pointer to the desired position in the CAM view thus 

drawing the segment/arc. Please ensure that the selection mode (arrow 
icon) is activated (see following figure): 

Fig. 193: 
Selection mode 
(arrow icon) 
activated 

 
 

 
Note 

You have to be in the CAM view of CircuitPro PM to be able to 
insert or modify geometrical forms (open paths, polygons, etc.) 
of the design! 
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 Creating a closed path with segments 
1. Click on Insert > Closed path. 

➨ The following dialog is displayed: 

Fig. 194: Closed 
path 

 
 
2. In the drop-down list, select the layer where you want to create the closed 

path. 
3. Select either absolute or a relative start point by clicking on the 

corresponding radio button. 
 

 
Note 

The absolute start point is computed using the X and Y 
coordinates starting from the zero point . 
If you want to create more than one closed path you can make 
all paths start from the same starting point using the “Absolute” 
start point option. 
The relative start point is variable. Once you have created a 
segment, the relative start point moves automatically to the end 
of this segment to serve as start point for the next segment to be 
created. 

 

 
Note 

Please note that the magenta-colored asterisk in the view 
always denotes the anchor point, not the zero point .! 

 
4. Enter the X and Y value of the start point in millimeters. 
5. Enter the X and Y values of the segment. 
6. Select the desired “curve width”: 
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Fig. 195: Creating 
a segment 

 

 
Aperture: 
• If your document contains an aperture list you can select an aperture for 

creating the open path. 
• If no aperture list is stored in your document, a line without defined width is 

created. 
Numeric: 
• The “Numeric” option lets you define the line width in millimeters. 
7. Click on [Set]. 

➨ The segment is created. 

 
Note 

Function of the “Apply” and “Set” buttons: 
Once you have created  a segment you can finish your entries 
using either [Apply] or [Set]. 
If you use [Set] you can still remove the segment by clicking on 
[Remove last]. You can add as many segments as you like. 
If you use [Apply] for creating the segment, it cannot be 
removed afterwards. You also cannot add any more segments 

 
8. Repeat the steps above to create at least one more segment for creating 

the closed path: 
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Fig. 196: Creating 
a second 
segment 

 

 
9. Click on [Apply] to combine the segments created to a closed path. 
Or 
10. Press the right mouse button as an alternative. 

➨ The context menu is displayed: 

Fig. 197: Opening 
the context menu 

 

 
10. Click on “Close” in the context menu. 
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➨ The path is closed: 

Fig. 198: Opening 
the context menu 

 

 

11. Click on [Close] in the dialog. 

➨ The dialog is closed. 
 The closed path with segments is created. 

 

 
Tip 

Procedure without entering X and Y values: 
You can also create segments in CircuitPro PM without 
entering coordinates. You can just use the mouse pointer. 
1. Press the left mouse button at the start point of the segment. 
2. Move the mouse pointer to the desired position in the CAM 
view. 
3. Press the left mouse button. 
 The segment is created. 
• A left-click corresponds to clicking the [Set] button in the dialog. 
• Pressing the right mouse button opens the context menu and 
you can finish creating the path by clicking on “End”. This 
corresponds to clicking on [Apply] in the dialog. 

 

 
Tip 

If you want to abort creating the path press the ESC key. 
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 Creating a closed path with arcs and line segments 
You can combine as many line segments and arcs as you like when creating a 
closed path. This example describes how to create an arc that combined with a 
line segment forms a closed path. 
1. Perform the steps 1 to 7 of “Creating a closed path with segments”. 

➨ A line segment is created. 
2. Activate the radio button “Make arc” in the dialog. 
Or 
2. Press the right mouse button and select “Arc” in the context menu. 

Fig. 199: 
Selecting “Arc” in 
context menu 

 

 
3. Select whether the direction of the arc should be “Clockwise” or “Counter-

clockwise”. 
4. Enter the radius of the arc. 
5. Enter the opening angle of the arc. 
 

 
Tip 

Creating arcs with the mouse pointer 
1. Activate the “Arc” option in the dialog or in the context menu. 
2. In the CAM view, click on the desired end point of the arc. 
3. Drag the mouse to the left or to the right until the arc has the 
desired size. 

 
6. Click on [Set]. 
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➨ An arc is created: 

Fig. 200: Creating 
an arc 

 

 
7. Click on “Apply” in the dialog or “Close” in the context menu. 

➨ The path is closed: 

Fig. 201: Closing 
an open path 
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8. Click on [Close] in the dialog. 

➨ The dialog is closed. 
 The closed path with an arc and a segment is created. 
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 Polygon 5.3.3

The menu item “Polygon” lets you create any polygon area using line segments 
and arcs. Creating a polygon requires at least two segments or two arcs or one 
segment plus one arc. These are connected in a final step forming the polygon 
surface area. 

Fig. 202: Polygon 

 
 
There are different ways to create a polygon: 
• Entering the X and Y values of the segments in the dialog. 
• Moving the mouse pointer to the desired position in the CAM view thus 

drawing a segment/arc. Please ensure that the selection mode (arrow icon) 
is activated (see following figure): 

Fig. 203: 
Selection mode 
(arrow icon) 
activated 

 

 

 
Note 

You have to be in the CAM view of CircuitPro PM to be able to 
insert or modify geometrical forms (open paths, polygons, etc.) 
of the design! 
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 Creating a polygon with line segments 
1. Click on Insert > Polygon. 

➨ The following dialog is displayed: 

Fig. 204: Polygon 

 
 
2. In the drop-down list, select the layer where you want to create the polygon. 
3. Select either absolute or a relative start point by clicking on the 

corresponding radio button. 
  

 
Note 

The absolute start point is computed using the X and Y 
coordinates starting from the zero point. 
If you want to create more than one polygon you can make all 
polygons start from the same starting point using the “Absolute” 
start point option. 
The relative start point is variable. Once you have created a 
segment, the relative start point moves automatically to the end 
of this segment to serve as start point for the next segment to be 
created. 

 

 
Note 

Please note that the magenta-colored asterisk in the view 
always denotes the anchor point, not the zero point! 

 
4. Enter the X and Y value of the start point in millimeters. 
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Fig. 205: Creating 
a segment 

 
 
5. Enter the X and Y values of the segment. 
6. Click on [Set]. 

➨ The segment is created. 
 

 
Note 

Function of the “Apply” and “Set” buttons: 
Once you have created a segment you can finish your entries 
using either [Apply] or [Set]. 
If you use [Set] you can still remove the segment by clicking on 
[Remove last]. You can add as many segments as you like. 
If you use [Apply] for creating the segment, it can not be 
removed afterwards. You also cannot add any more segments. 

 
7. Repeat the steps above to create at least one more segment for creating 

the polygon area: 
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Fig. 206: Creating 
a second 
segment 

 
 
8. Click on [Apply] to combine the segments created to a polygon area. 
Or 
9. Press the right mouse button as an alternative. 

➨ The context menu is displayed: 

Fig. 207: Close 
polygon 

 
 
9. Click on “Close” in the context menu. 
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➨ The polygon is created: 

Fig. 208: Polygon 
area 

 
 
10. Click on [Close] in the dialog. 

➨ The dialog is closed. 
 The polygon is created. 

 

 
Tip 

Procedure without entering X and Y values: 
You can also create segments in CircuitPro PM without entering 
coordinates. You can just use the mouse pointer. 
1. Press the left mouse button at the start point of the segment. 
2. Move the mouse pointer to the desired position in the CAM 
view. 
3. Press the left mouse button. 
 The segment is created. 
• A left-click corresponds to clicking the [Set] button in the dialog. 
• Pressing the right mouse button opens the context menu and 
you can finish creating the polygon by clicking on “Close”. This 
corresponds to clicking on [Apply] in the dialog. 

 

 
Tip 

If you want to abort creating the polygon press the ESC key. 
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 Creating a polygon with arcs and line segments 
You can combine as many line segments and arcs as you like when creating a 
polygon. This example shows how to create a polygon area with two line 
segments and two arcs. 
1. Perform the steps 1 to 7 of “Creating a polygon with line segments”. 

➨ A line segment is created. 

Fig. 209: Creating 
a segment 

 
 
2. Activate the radio button “Make Arc” in the dialog. 
Or 
2. Press the right mouse button and select “Arc” in the context menu. 

Fig. 210: 
Selecting “Arc” in 
context menu 

 

 
3. Select whether the direction of the arc should be “Clockwise” or “Counter-

clockwise”. 
4. Enter the radius of the arc. 
5. Enter the opening angle of the arc. 
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Tip 

Creating arcs with the mouse pointer 
1. Activate the “Arc” option in the dialog or in the context menu. 
2. In the CAM view, click on the desired end point of the arc. 
3. Drag the mouse to the left or to the right until the arc has the 
desired size. 

 
6. Click on [Set]. 

➨ An arc is attached to the line segment: 

Fig. 211: Creating 
an arc 

 
 
7. Create another line segment: 



 
How to work with CircuitPro PM CircuitPro PM 2.3  

 
 

180 V1.1 – 11.2016 © 2016 LPKF AG 

5 

Fig. 212: 
Attaching a 
segment to an arc 

 
 
8. Insert another arc: 

Fig. 213: 
Attaching an arc 
to a segment 

 
 
9. To finish the polygon, click on “Apply” in the dialog or “Close” in the context 

menu. 
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Fig. 214: 
Selecting “Close” 
in context menu 

 
 

➨ The polygon is created: 

Fig. 215: Polygon 
area 

 
 
10. Click on [Close] in the dialog. 

➨ The dialog is closed. 
 The polygon with two line segments and two arcs is created. 
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 Rectangle 5.3.4

The “Rectangle” function lets you create rectangles of any size. 

Fig. 216: 
Rectangle 

 
 
There are different ways to create a rectangle: 
• Entering the X and Y values of the rectangle in the dialog. 
• Moving the mouse pointer to the desired position in the CAM view thus 

drawing the rectangle. Please ensure that the selection mode (arrow icon) 
is activated (see following figure): 

Fig. 217: 
Selection mode 
(arrow icon) 
activated 

 

  

 
Note 

You have to be in the CAM view of CircuitPro PM to be able to 
insert or modify geometrical forms (open paths, polygons, etc.) 
of the design! 
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 Creating a rectangle 
1. Click on Insert > Rectangle. 

➨ The following dialog is displayed: 

Fig. 218: Create 
Rectangle 

 
 
2. In the drop-down list, select the layer where you want to create the 

rectangle. 
3. Select either an absolute or a relative start point and end point by clicking 

on the corresponding radio button. 
 

 
Note 

The absolute start point is computed using the X and Y 
coordinates starting from the zero point. 
If you want to create more than one rectangle you can make all 
rectangles start from the same starting point using the “Absolute” 
start point option. 
The relative start point is variable. Once you have created a 
rectangle, the relative start point moves automatically to the end 
of this rectangle to serve as start point for the next rectangle to 
be created. 

 

 
Note 

Please note that the magenta-colored asterisk in the view 
always denotes the anchor point, not the zero point! 

 
4. Enter the X and Y value of the start point in millimeters. 
5. Enter the X and Y value of the end point in millimeters. 
6. Click on [Create]. 
 

 
Tip 

You can also create the rectangle using the mouse by clicking 
on the desired start point in the view and drawing the rectangle. 
Please ensure that the selection mode (arrow icon) is activated. 

 
7. Click on [Close]. 
 The rectangle is created. 
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 Circle 5.3.5

The “Circle” function lets you create circles of any size. 

Fig. 219: Circles 

 
 
There are different ways to create a circle: 
• Entering the circle center and the diameter in the dialog. 
• Moving the mouse pointer to the desired position in the CAM view thus 

drawing the circle. Please ensure that the selection mode (arrow icon) is 
activated (see following figure): 

Fig. 220: 
Selection mode 
(arrow icon) 
activated 

 

  

 
Note 

You have to be in the CAM view of CircuitPro PM to be able to 
insert or modify geometrical forms (open paths, polygons, etc.) 
of the design! 
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 Creating a circle 
1. Click on Insert > Circle. 

➨ The following dialog is displayed: 

Fig. 221: Create 
Circle 

 
 
2. In the drop-down list, select the layer where you want to create the circle. 
3. You can choose between the options “Absolute” and “Relative”: 
• Absolute: If “Absolute” is activated, the center point of the circle is 

computed using the X and Y coordinates starting from the zero point.  
 If, for example, the X and Y values are left at 0 mm and only a radius is 

entered, the center point of the circle is at the zero point. 
 If you enter an X and a Y value, the center point of the circle is computed 

from the zero point with the coordinates entered. 
Fig. 222: 
“Absolute” 
option 

 
 /1/ Zero point = anchor point /2/ New circle ( 10 mm) 

The figure above shows how a circle with a diameter of 10 mm is created. The 
center point of the circle (see /2/) is at the coordinates X=40 and Y=40 from the 
zero point (see /1/). 
 
• Relative to anchor point: If the option “Relative to anchor point” is 

activated, the center point of the circle is computed using the X and Y 
coordinates starting from the anchor point.  

2 

1 
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 If, for example, the X and Y values are left at 0 mm and only a radius is 
entered, the center point of the circle is set to the current anchor point. 

 If you enter an X and a Y value, the center point of the circle is computed 
from the current anchor point with the coordinates entered. 

Fig. 223: 
“Relative” option 

 
 /1/ Anchor point /2/ New circle ( 50 mm) 

 
4. Enter the X and Y value of the circle's center point in millimeters. 
5. Enter the circle's diameter in millimeters. 
 

 
Tip 

You can also create the circle using the mouse by clicking on the 
desired center point in the view and drawing the circle. 

 
6. Click on [Apply]. 
7. Click on [Close]. 
 The circle is created. 
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 Circle path 5.3.6

The “Circle path” function lets you create circle paths of any size. 

Fig. 224: Circle 
paths 

 
 
There are different ways to create a circle path: 
• Entering the circle center and the diameter in the dialog. 
• Moving the mouse pointer to the desired position in the CAM view thus 

drawing the circle path. Please ensure that the selection mode (arrow icon) 
is activated (see following figure): 

Fig. 225: 
Selection mode 
(arrow icon) 
activated 

 

  

 
Note 

You have to be in the CAM view of CircuitPro PM to be able to 
insert or modify geometrical forms (open paths, polygons, etc.) 
of the design! 
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 Creating a circle path 
1. Click on Insert > Circle path. 

➨ The following dialog is displayed: 

Fig. 226: Create 
circle path 

 
 
2. In the drop-down list, select the layer where you want to create the circle 

path. 
3. You can choose between the options “Absolute” and “Relative”: 
• Absolute: If “Absolute” is activated, the center point of the circle path is 

computed using the X and Y coordinates starting from the zero point.  
 If, for example, the X and Y values are left at 0 mm and only a radius is 

entered, the center point of the circle path is at the zero point. 
 If you enter an X and a Y value, the center point of the circle path is 

computed from the zero point with the coordinates entered. 
Fig. 227: 
“Absolute” 
option 

 
 /1/ Zero point = anchor point /2/ New circle path ( 10 mm) 

 
The figure above shows how a circle path with a diameter of 10 mm is created. 
The center point of the circle path (see /2/) is at the coordinates X=40 and Y=40 
from the zero point (see /1/). 
 
• Relative: If “Relative” is activated, the center point of the circle path is 

computed using the X and Y coordinates starting from the anchor point.  

2 1 
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 If, for example, the X and Y values are left at 0 mm and only a radius is 
entered, the center point of the circle path is set to the current anchor point. 

 If you enter an X and a Y value, the center point of the circle path is 
computed from the current anchor point with the coordinates entered. 

Fig. 228: 
“Relative” option 

 
 /1/ Anchor point /2/ New circle path ( 50 mm) 

 
4. Enter the X and Y value of the circle path's center point in millimeters. 
5. Enter the circle path's diameter in millimeters. 
  

 
Tip 

You can also create the circle path using the mouse by clicking 
on the desired center point in the view and drawing the circle 
path. 

  
6. Click on [Apply]. 
7. Click on [Close]. 
 The circle path is created. 
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 Flash 5.3.7

The “Flash” function lets you create flash objects on any layer. 
 

 
Note 

An aperture list library must be available for creating a flash 
object. For more information on the aperture list library see the 
corresponding chapter. 

 

 Creating a flash object 
1. Click on Insert > Flash. 

➨ The following dialog is displayed: 

Fig. 229: Create 
flash 

 
 
2. In the drop-down list, select the layer where you want to create the flash 

object. 
3. Select an aperture. 
4. Enter the X and Y value of the flash center point in millimeters. 

Fig. 230: Entering 
the flash 
coordinates 

 
 
5. Click on [Apply]. 
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➨ The newly created flash object is displayed in the CAM view: 

Fig. 231: New 
flash object 

 
 
The flashed object is at 10 mm in X direction and 5 mm in Y direction from the 
zero point. 
 

 
Note 

The above figure shows the flash object at a much larger scale 
for better illustration. The anchor point (magenta-coloured 
asterisk) was set to the zero point in order to illustrate the 
coordinates of the flash object. 

 
 The flash object is created. 
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 Text 5.3.8

The “Text” function lets you create any text object on the layers. 
 

 Defining a text 
1. Click on Insert > Text. 

➨ The following dialog is displayed: 

Fig. 232: Define 
text 

 

 /1/ Text attributes 
 

/2/ Input field 

2. Enter your text into the input field /2/. You can enter a maximum of 
1000 characters. 

3. Format your text if necessary using the available text attributes under /1/: 
• Bold 
• Italic 
• Underline 
• Strike through 
 

 
Note 

Please note that you can only format the whole text and not 
individual characters or words (in case of multiple words). 

 

 
Note 

The entered text appears in the drop-down list \Text object\. If 
you would like to enter another new text, please select <create 
new> here. 

4. In the drop-down list "Destination" select the layer onto which the text is to 
be placed. 

5. Select the text font. 

1 
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6. Select the mode: 
• "Filled Area": The text's characters are complete. 

LPKF CircuitPro 
• "Outline": only the outline of the text's characters is created. 

 
 
7. Select the character spacing.  
8. Select the line spacing. 
 

 
Note 

The input field only shows the entered text and the attributes 
(bold, italic, etc.) All other settings only become visible in the 
CAM view when you click [Apply]. 

 
9. Enter the X and Y coordinates of the text field. 
10. Determine the alignment of the text field. 
11. Enter a value for rotating the text if necessary. 
12. Click on [Apply]. 

➨ The view changes as follows: 

Fig. 233: Text 
rotated by 90° 

 

 
13. If you want to mirror the text object along the X or Y axis, select the 

corresponding value in the drop-down list next to /Rotation/ and click on 
[Apply]. 
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➨ The view changes as follows: 

Fig. 234: Text 
mirrored on the Y 
axis 

 

 
 The text is defined on the corresponding layer. 
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 Polygon with cutouts  5.3.9

Use the function ”Polygon with cutouts” to create cutouts of any form in a drawn 
polygon. 

Fig. 235: 
Polygons with 
cutouts 

 
 
To create a polygon as shown in the figure above, you need a simple polygon 
plus the geometric objects (rectangle, paths, circles etc.) that you want to cut 
from the polygon. 
 

 
Tip 

For the steps how to create a polygon see the corresponding 
chapter. 
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 Creating a polygon with cutouts 
The following steps show how to create a polygon with two circular cutouts. A 
polygon and two circles are needed for this: 

Fig. 236: Polygon 
and two circles 

 
 
1. Click on Insert > Polygon with cutouts. 

➨ The following dialog is displayed: 

Fig. 237: Create 
polygon with 
cutouts 

 
 

➨ The radio button {Outer} is active. 
2. Select the polygon that shall remain. 
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➨ The name of the polygon is displayed in \Outer\: 

Fig. 238: Select 
polygon 

 
 
3. Click on {Inner}. 
4. Select the two circles. 

➨ The names of the circles are displayed in \Inner\: 

Fig. 239: Select 
circles 

 
 
5. Click on [Apply]. 
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➨ The view changes as follows: 

Fig. 240: Polygon 
with two circular 
cutouts 

 
 
6. Click on [Close] in the dialog. 

➨ The dialog is closed. 
 The polygon with cutouts has been created. 

 

 
Tip 

If you do not want the objects that are used for the cutout 
process (in this case, the circles) to be deleted, please select the 
option "Keep cut objects." 
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 Copper pouring 5.3.10

Use the “Copper pouring” function to create isolated copper areas around 
conductive tracks. 

Fig. 241: Copper 
pouring example 

 
 
For creating a copper pouring around a conductive track as depicted in the 
figure above, you need 
• a geometric shape (rectangle, circle, polygon) that represents the copper 

area and 
• a path (closed or open) that represents the conductive track. 
  

 
Tip 

For information on creating geometric shapes and paths see the 
corresponding chapters.. 
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 Creating a copper pouring 
In the following steps, a rectangular copper area is created around a conductive 
track. A rectangle and an open path are needed for this: 

Fig. 242: Rectangle 
and open path 

 
 
1. Click on Insert > Copper pouring. 

➨ The following dialog is displayed: 

Fig. 243: Create 
copper pouring 

 
 

➨ The radio button {Outer} is active. 
2. Select the copper area (the rectangle in this case). 
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➨ The name of the rectangle is displayed in \Outer\: 

Fig. 244: Copper 
area (select 
rectangle) 

 
 
3. Click on {Inner}. 
4. Select the open path: 

➨ The name of the path is displayed in \Inner\: 

Fig. 245: Selecting 
the open path 
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5. Enter the offset value for the copper area. This value represents the width 
of the isolation. 

Fig. 246: Entering 
offset 

 
 
6. Click on [Apply]. 

➨ The area next to the conductive track is removed according to the offset 
value: 

Fig. 247: Isolated 
open path 

 
 
7. Click on [Close]. 

➨ The dialog is closed. 
 The copper pouring is created. 
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 Rubout area 5.3.11

Use the “Rubout” function to define areas of any shape for removal of 
unnecessary copper on the rubout layers, i.e., creating rubout areas. 
You can also create new rubout layers. 

Fig. 248: Rubout 
example 

 
 /1/ Layer BoardOutline (display mode “Thin 

Line”) 
/2/ Open path on BottomLayer 

/3/ Rubout area with toolpaths 
visible 

 
In order to create an area as depicted in the figure above, you need 
• a defined BoardOutline (e.g. by creating a rectangle on the BoardOutline 

layer) 
• at least one isolation object on the corresponding Top-/BottomLayer. 
 

 
Note 

In CircuitPro PM, all rubout areas on the rubout layers are 
rectangular. 

 
 

  

1 3 
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 Creating a rubout area 
1. Click on Insert > Rubout area > RuboutBottom. 
 

 
Note 

The number of rubout layers depends on the type of circuit 
board (single-sided/multi-layer) that you want to produce.  
In case of a single-sided circuit board, CircuitPro PM creates 
only the RuboutBottom layer automatically.  
In case of a double-sided circuit board, two rubout layers are 
created: RuboutBottom und RuboutTop. 

 

 
Note 

You can create the rubout area on any rubout layer or all 
rubout layers depending on your project.  
You can also create a new rubout layer for the process. 
To do this, click on Click on Insert > Rubout > Create new 
layer. 

 

➨ The following dialog showing the selected layer is displayed: 

Fig. 249: Create 
rubout area 

 
 

 
Note 

You can change the layer for creating the rubout area at any 
time.  
 Just click on the drop-down list and select the desired layer. 

 
2. Create the rectangle for the rubout area. 
 

 
Tip 

For the steps how to create a rectangle see the corresponding 
chapter. 
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Fig. 250: Create 
rectangle 

 
 
3. Click on [Apply]. 

➨ The rectangle for the rubout area is created. 
4. Click on [Close] in the dialog. 

➨ The dialog is closed. 
 

 
Note 

For creating the toolpath, you have to go to the “Technology 
dialog”. 
For more information on the menu item “Technology dialog” 
see corresponding chapter. 

 
5. Click on Toolpath > Technology dialog. 
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➨ The following dialog is displayed: 

Fig. 251: 
Technology 
dialog 

 
 
6. Click on the arrow buttons in the “Insulate” section until the isolation method 

“Partial rubout” or “Complete rubout” is displayed: 
 

Fig. 252: Partial 
rubout 

 
 

Fig. 253: 
Complete rubout 

 
 
7. Select one of the two methods depending on your requirements. 
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Note 

For more information on the settings in the “Technology dialog” 
see the corresponding chapter. 
If you want to create only the toolpath for the rubout area, 
deactivate the other processing steps (contour routing, convert 
to toolpath) by removing the check marks next to the 
respective functions. 

 

Fig. 254: 
Deactivated 
functions in the 
Technology 
dialog 

 
 
8. Click on [Start]. 
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➨ The rubout area is created. The computation results are displayed. 

Fig. 255: Rubout 
area computation 
results 

 
 
 The rubout area is created. 

 

 Creating a new rubout layer 
1. Click on Insert > Rubout area > Create new layer. 

➨ The following dialog is displayed: 

Fig. 256: Create 
new layer 

 
 

 
Note 

The name of the layer is assigned automatically by 
CircuitPro PM. 
The first new layer is named “Rubout”. For the following layers, 
the name has a counter that is incremented thus creating 
“Rubout_1”, “Rubout_2” etc. 

 
2. Perform the steps two to eight of “Creating a rubout area”. 
 A rubout area has been created on the new rubout layer. 
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 Fiducial 5.3.12

Fiducials are optical marks on the surface of the circuit board that are used for 
aligning the circuit board. The fiducials are drilled into the board and are 
recognised by the cameras of the ProtoMat systems. 
The sub-menu “Fiducial” lets you create fiducials and fiducial layers.  
The following figure shows four fiducials placed near the corners of the circuit 
board. 

Fig. 257: Circuit 
board with 
fiducials 

 
 

 
Note 

Creating fiducials corresponds to creating circles in CircuitPro. 
For more information on the creating circles see the 
corresponding chapter. 
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 Creating fiducials 
1. Click on Insert > Fiducial > Fiducial. 

➨ The following dialog is displayed: 

Fig. 258: Create 
circle 

 
 

 
Note 

The “Fiducial” layer is automatically created. If you have 
created other fiducial layers, these are displayed in the drop-
down list. 

 
2. Click on the position in the CAM view where you want to place the fiducial. 
Or 
2. Enter the coordinates for the center point of the circle in millimeters and 

click on [Apply]. 
 

 
Note 

Fiducials have a predefined diameter of 1.5 mm that cannot be 
changed. 

 

➨ The fiducials are created. 
3. Click on [Close] in the dialog. 
 The fiducials have been created. 

 

 Creating a new fiducial layer 
1. Click on Insert > Fiducial > Create new layer. 

➨ The following dialog is displayed: 

Fig. 259: Creating 
a new fiducial 
layer 

 
 

 
Note 

The name of the layer is assigned automatically by CircuitPro. 
The first new layer is named “Fiducial_1”. For the following 
layers, the name counter is incremented thus creating 
“Fiducial_2”, “Fiducial_3” etc. 

 
 The new fiducial layer has been created. 
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 Topography 5.3.13

The menu item “Topography” lets you define points on a separate topography 
layer that is used for determining the topography. Determining the topography is 
required for setting a defined distance between the dispenser needle and the 
surface of the material during the dispense process. 

Fig. 260: Circuit 
board with 
topography 
points 

 

 
 

 
Note 

Defining topography points corresponds to creating circles in 
CircuitPro PM. 
For more information on creating circles see the corresponding 
chapter. 
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 Defining topography points. 
1. Click on Insert > Topography > Topography. 

➨ The following dialog is displayed: 

Fig. 261: Defining 
topography 
points 

 
 

 
Note 

CircuitPro PM automatically creates a topography layer where 
you can define the points. 

 
2. Click on the position in the CAM view where you want to define the 

topography point(s). 
Or 
2. Enter the coordinates for the center point of the circle in millimeters and 

click on [Apply]. 
 

 
Note 

Topography points have a predefined diameter of 1.5 mm that 
cannot be changed. 

 

➨ The topography point(s) is (are) defined. 
3. Click on [Close] in the dialog. 
 
 The topography point(s) is (are) defined. 
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 Creating a new topography layer 
1. Click on Insert > Topography > Create new layer. 

➨ The following dialog is displayed: 

Fig. 262: Create 
new layer 

 

 

 
Note 

The name of the layer is assigned automatically by 
CircuitPro PM. 
The first new layer is named “Topography”. For the following 
layers, the name has a counter that is incremented thus 
creating “Topography_1”, “Topography_2” etc. 

 
2. Click on [Apply] in the dialog. 
 The topography layer is created. 
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 Drill hole 5.3.14

Use the function "Drill hole" to insert holes of different sizes into your layout. 
Fig. 263: Example 
for drilling holes 

 

 

 

 
Note 

The drill hole sizes correspond to the diameters of the 
available drilling tools. 

 

 
Tip 

• Place the holes that will be used for through-hole contact on 
the layer “Drill Plated”. 
• Place all other holes on the layer “Drill Unplated”. 
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 Creating a drill hole 
1. Click on Insert > Drill hole… 

➨ The following dialog is displayed: 

Fig. 264: Create 
drill hole 

 

 
2. First select the phase in which the whole is to be drilled during processing.  
3. In the drop-down menu \Layer\, select the layer in which the hole shall be 

drilled: 
Fig. 265: Select 
layer 
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4. In the drop-down menu \Tool\, select the drilling tool which is to be used to 
drill the hole: 

Fig. 266: Select 
tool 

 

 
5. If you do not want to add marking drills, uncheck the option “Add marking 

drill” and continue with step 7. 
6. In the dropdown list select a tool and a phase, the marking drills should be 

generated within. 
Fig. 267: Add 
marking drill 

 

 
7. In the CAM view, click on where you would like to drill the hole. 
Or 
7. Enter the coordinates for the center point of the circle in mm and click on 

[Apply]. 
 

 
Note 

The hole diameters correspond to the diameters of the drilling 
tools. 

 

➨ The holes are positioned. 
8. Click on [Close] in the dialog. 

➨ The dialog is closed. 
 The drill hole has been created. 
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 Milling curve  5.3.15

Using the function “Milling curve” you can convert open/closed paths directly 
into milling curves or manually insert milling curves directly into the layout. 
 

 
Note 

The technology dialog, used to create toolpaths, does not 
convert paths directly into milling curves. Either insulation or 
contours are generated around the paths.  

 

 Creating a milling curve 
1. Click on Insert > Milling curve… 

➨ The following dialog is displayed: 

Fig. 268: Create 
milling curve 

 

 
2. First select a phase in the field \Phase:\, in which the milling curve is to be 

created during processing. 
3. Select the layer in the field \Layer\, on which the milling curve is to be 

created. 
4. Select a tool in the field \Tool\, with which the milling curve is to be created. 
5. Select either an absolute or a relative starting point by clicking on the 

corresponding setting. 
 

 
Note 

The absolute start point  is computed using the X and Y 
coordinates starting from the zero point . 
If you want to create more than one open path you can make all 
paths start from the same starting point using the “Absolute” 
start point option. 
The relative start point  is variable. Once you have created a 
segment, the relative start point moves automatically to the end 
of this segment to serve as start point for the next segment to be 
created. 

  

 
Note 

For more information on creating paths, please refer to the 
relevant chapters “Open path” and “Closed path”. 

 
6. Enter the X and Y value of the starting point in mm. 
7. Activate the radio button “Arc” if you want to create an arc.  
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8. Enter the radius and the angle of the arc. 
Or 
8. Enter the X and Y coordinates of the segment. 
9. Click on [Apply]. 
 The milling curve has been created. 

 

 
Tip 

Procedure without entering X and Y values: 
You can also create segments in CircuitPro PM without entering 
coordinates. You can just use the mouse pointer. 
1. Press the left mouse button at the desired start point of the 
segment in the CAM view. 
2. Move the mouse pointer to the desired position in the CAM 
view. 
3. Press the left mouse button. 
 The segment is created. 
• A left-click corresponds to clicking the [Set] button in the dialog. 
• Pressing the right mouse button opens the context menu and 
you can finish creating the path by clicking on “End”. This 
corresponds to clicking on [Apply] in the dialog. 
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5.4 Menu Toolpath  

The “Toolpath” menu contains the functions for setting parameters and creating 
the paths for milling, routing, and dispensing solder paste. 
Click on the “Toolpath” menu item to open the submenu: 

Fig. 269: Menu 
“Toolpath” 

 
 
The following table contains short descriptions of the functions of the individual 
menu items: 

Table 33: 
“Toolpath” menu 
functions 

 

Menu item Description 

Dispense… Opens a dialog to create toolpaths for 
dispensing solder paste. 

2.5D milling… Creates toolpaths for 2.5D operations. 

Technology Dialog… Opens a dialog to create toolpaths for drilling 
and milling. 

 
Edit breakout tabs… Opens a dialog to modify the breakout tabs in 

the contour-routing toolpath. 
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 Dispense 5.4.1

The “Dispense” function lets you create solder paste paths  on a selected layer. 
Afterwards, You can place circuit components on the solder paste paths. 
Subsequently, the circuit boards can be soldered in a reflow oven (e.g. using 
the LPKF ProtoFlow). 

Fig. 270:Dispense 
paths created on 
pads 

 
 

 
Note 

The dispenser has to be mounted on the machine in order to 
create solder paste dots  on the circuit board! 

 
This dialog “Dispense” allows the following operations: 
• Creating new solder paste paths on the pads 
• Assigning new parameter sets to the dispense tools in the tool library 

[Add…] 
• Edit the parameters of the dispense tools [Edit…] 
• Edit details for creating solder paste paths [Show details] 
• Delete dispenser tools [Delete]. 
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 Creating a new solder paste path on the pads 
1. Click on Toolpath > Dispense. 

➨ The following dialog is displayed: 

Fig. 271: 
Dispense 

 
 /1/ List of the available dispense tools 

 
The table contains following columns: 

Table 34: 
Dispense 

 

Column Description 

Enabled Activates/deactivates the corresponding 
dispense tool with a check mark. 

Minimum size [µm] Shows the minimum pad size of the pad to be 
filled in µm. 

 
Dot distance [µm] Shows the dot distance between the individual 

solder paste dots in µm. 

 
Grid angle[°] Shows the rotation of the solder dot grid on the 

pad. 

 
Margin [µm] Shows the minimum distance of the solder 

paste dots to the boundary of the pad in µm. 

 Tool Shows the corresponding dispense tool. 

 
2. In the “Source” drop-down list, select the layer where you want to create the 

solder paste path. 
 

 
Tip 

Create the solder paste dots on the designated solder paste 
layers (SolderPasteTop or SolderPasteBottom). 

 
3. In the list, select the dispense tools that you want to use. 

  

1 
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Note 

Take care that you have activated a suitable dispense tool for 
each pad size of your design. 
Several tools can be used for creating the solder paste paths. 

 
4. Click on [Run]. 
5. Click on [Close]. 
 The solder paste path is created on the corresponding pads. 

 

 Adding new parameter sets for existing tools 
1. Click on [Add…] in the dialog. 

Fig. 272: Adding 
solder paste path 
parameters 

 

➨ The following dialog is displayed: 

Fig. 273: Pad size 
parameters 

 
 
2. Enter the minimum pad size of the pad in µm. 
3. Select a dispense tool. 
 

 
Note 

If the desired dispense tool is not in the list, you can create it in 
the tool library. 
For more information on adding tools to the tool library see the 
corresponding chapter. 

 
4. Enter the dot distance between the individual solder paste dots in µm. 
5. Enter a grid angle if necessary. 
6. Enter the margin width. 
7. Click on [OK]. 

➨ The new pad size parameters are displayed in the list. 
 The new pad size parameters are added. 
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 Editing existing pad size parameters 
1. Select the row where you want to edit the parameters and click on [Edit…]. 

Fig. 274: Editing 
pad size 
parameters 

 
 

➨ The dialog “Pad size parameters” with the details on pad size is displayed: 

Fig. 275: Pad size 
parameters 

 
 
2. Modify the parameters as desired. 
3. Click on [OK]. 

➨ The dialog “Pad size parameters” is closed. 
 The existing pad size parameters are modified. 
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 Deleting existing pad size parameters 
1. Select the row that you want to delete and click on [Delete]. 

Fig. 276: Deleting 
pad size 
parameters 

 
 
 The selected row of existing pad size parameters is deleted. 

 

 Showing details 
1. Click on [Show details] to display the global settings for creating solder 

paste dots: 
Fig. 277: Show 
details 
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➨ The view changes as follows: 

Fig. 278: Details 

 
 
The following global settings are possible: 

Table 35: Global 
settings 

Function Description 

Tolerance [mm] Defines the tolerance used when checking the 
distance of the solder dot to the pad boundary. 

Filling strategy If a pad is filled with more than one solder dot, 
the solder dots can be placed based on three 
filling strategies: 

 Cartesian grid 
 Hexagonal grid 
 Concentric 

 

Process direction Defines whether the pads are filled with solder 
paste “From center outwards” or “From 
boundary inwards”. 
Filling “From center outwards” is only available 
if you have selected the “Concentric” filling 
strategy. 

 

Apply smoothing This option is only active if you have selected 
the “Concentric” filling strategy. 
The solder paste dots are dispensed uniformly. 

 

Replace existing toolpath Replaces the existing solder paste path by the 
newly created solder paste path in the CAM 
view. 
If the option is deactivated, the new solder 
paste path is created over the existing one. 

 
2. Modify the parameters if necessary. 
3. Click on [Run]. 
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➨ The changes are stored. 
 

 
Note 

Changes made in these fields are valid for all dispense tools. 

 
4. Click on [Close]. 

➨ The dialog is closed. 
 The details were shown. 
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 Create 2.5D milling  5.4.2

To create a 3D part you need to create 2.5D toolpaths with a defined Z value.  
After creating your design in the CAM view Circuit Pro PM generates the 
necessary 2.5D toolpaths to start the processing of your 3D part.  
 

 Creating 2.5D milling  
1. Click on Toolpath > 2.5D milling… 

➨ The following dialog is displayed: 

Fig. 279: Create 
2.5D milling  

 

 /1/ Source 
/2/ Tool 

/3/ Options 

 
  

1 

2 

3 
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The sections contain following information/options: 
Table 36: Create 
2.5D milling 

Section Description 

Source Here the source object is displayed, the toolpaths are created 
for.  

Tool This list shows all available tools to generate 2.5D toolpaths.  

Options 

Generate on 
both sides 

In case of a double-sided object you can specify if the toolpaths 
should only be created on the top or bottom side. 
By default the toolpaths are generated on both sides of an 
object. 

 
Generate start 
drills 

Here you can specify if start drills should be created. The start 
drills are used by the milling tools to start milling a line.  

 
Replace existing 
toolpath 

Here you can specify if already existing toolpaths should be 
replaced. 

 

Generate 
fiducials 

Here you can specify if fiducials should be generated for the 
toolpaths.  
Source: 
Indicates the layer where the fiducials should be generated. 
Tool: 
Indicates the tool that should generate he fiducials. 
Phase: 
Indicates the phase where the fiducial should be generated. 
Tolerance: 
Indicates the tolerance that is used to calculate or check the 
position and the distances of the toolpaths. 

 
2. Activate the tool’s checkboxes that you want to use for creating the 2.5D 

toolpaths.  
3. Enable/disable the options you need for creating the toolpaths.  
 

 
Note 

Please note that at least one drilling tool must be enabled if 
you want to create start drills. 

 
4. Click on [OK]. 
 The 2.5D toolpaths are created.  
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 Technology Dialog 5.4.3

The technology dialog lets you create toolpaths that you can use in processing 
for the following steps: 

• Insulate 
• Contour routing 
• Drilling holes 
• Drilling fiducials 
• Milling pockets 

 Creating toolpaths 
1. Click on Toolpath > Technology Dialog. 

➨ The following dialog is displayed: 

Fig. 280: 
Technology 
Dialog 

 

 

 /1/ Material and processing settings 
/2/ Insulation options 

/3/ Contour routing options 
/4/ Options for creating holes, fiducials 
and pockets 

2. Select your material type in the corresponding drop-down list. 
3. If your project is a radio frequency application, activate the corresponding 

check box <RF application>. 

 
Note 

If you process the project with the enabled option “RF 
application” the penetration depth of the cutter is optimized and 
the Universal Cutter is replaced by the End Mill (RF). 

 
4. Activate the functions with check marks: 
 

1 

2 

3 

4 
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Insulate 

The “Insulate” section offers four different insulation methods: 
• Basic: Insulation with a single insulation channel and the shortest 
processing time. 
• Basic, pads double: Insulation with a single insulation channel and 
a double insulation channel for pads. Processing takes a little more 
time than the “Basic” method. 
• Partial rubout: Insulation with a single insulation channel and 
removal of copper in defined areas. 
• Complete rubout: Entire removal of unnecessary copper. This is 
the most precise insulation method. 

Fig. 281: Insulate 

 

 
 

Table 37: Insulate 

 
Function Description 

Source Defines the layers where the insulation will be 
created. 

Primary Shows the tool that is used as  primary tool for 
the insulation process. 

 
Available tools This list contains the tools that are used as 

default for creating the individual toolpaths. 

 
Insulation width Defines the width of the insulation channel in 

mm. 

 

Pads insulation Defines the width of the pads insulation if an 
insulation method with an extra pads insulation 
is selected. 

 channels Defines the number of additional insulations. 

 
Rubout Defines whether and on which layer a rubout is 

performed. In addition, you can select how the 
rubout area is going to be processed. 

 
Tolerance Defines the tolerance used for computing and 

checking the positions and distances of the 
toolpaths. 

 

Generate optimized 
rubout 

Optimizes the toolpaths for rubout areas with 
regard to the number of tools used. 
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Table 37: Insulate 

 
Function Description 

 

Remove Spikes Automatically remove residual copper that 
remains as spikes (e.g. between two 
connecting conductive tracks). This prevents 
that the copper in these areas is pulled off 
unintentionally by the cleaning pad during the 
final cleaning process. 

 

Force insulation Creates insulation paths for each individual 
insulation object. This guarantees insulation of 
every object even if the distance between two 
objects is smaller than the tool diameter. 

 
Perform inner insulation Defines for closed paths whether the inner 

contour is to be insulated in addition to the 
outer one. 

 
Replace existing toolpath If a toolpath already exists, it is replaced by the 

newly created one. 
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Contour Routing 

The “Contour Routing” section offers six different  routing methods: 
• Basic: Contour routing without gaps 
• Horizontal gaps: Contour routing with gaps on front and rear side. 
• Vertical gaps: Contour routing with gaps on left and right side 
• Edge gaps: Contour routing with one gap on each edge 
• Corner gaps: Contour routing with one gap in each corner 
• Equidistant gaps: Contour routing with equally spaced gaps 

Fig. 282: Contour 
Routing 

 

 
 

Table 38: Contour 
Routing 

 

Function Description 

Inside The toolpath is inside the drawn BoardOutline. 

Outside The toolpath is outside the drawn 
BoardOutline. 

 
Source Defines the layer(s) where the contour will be 

routed. 

 Tool Defines the tool used for contour routing. 

 
Tabs position Defines the positions of the tabs, i.e. gaps in 

the routing. 

 Gap width Defines the width of the tabs in mm. 

 
Distance Defines the distance of the tabs in mm.  

This value is only used in the “Equidistant 
gaps” routing method. 

 
Tolerance Defines the tolerance used for computing and 

checking the positions and distances of the 
toolpaths. 

 
Replace existing toolpath If a toolpath already exists, it is replaced by the 

newly created one. 

 
Generate start drills This option ensures that contour routing 

always starts with generating a start drill.  
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Drills 

The “Drills” options are for creating the toolpaths for holes in the circuit board. 
Fig. 283: Drills 

 

 
 

Table 39: Drills 

 
Function Description 

Source Defines the layer used for creating the holes. 

Tool Defines the tool used for drilling.  
 Usually, the tools are assigned to the holes 
automatically according to their diameters. 

 

Assign to Phase Defines the phase where the hole is created. 
 Usually, the holes are created in the phases 
“DrillingPlated” and “DrillingUnplated”. 

 
Tolerance Defines the tolerance used for computing and 

checking the positions and distances of the 
toolpaths. 

 
Replace existing toolpath If a toolpath already exists, it is replaced by the 

newly created one. 

 Create marking drills 

 Marking tool Defines the tool used for marking. 

 

Assign to Phase Defines the phase where the markings are 
created. 
 Usually, the markings are created in the 
phase “MarkingDrills”. 
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Fiducials 

The “Fiducials” options are for creating the toolpaths for fiducial holes in the 
circuit board. The fiducials are used for correct alignment of the circuit board 
after it has been turned over for example. 

Fig. 284: 
Fiducials 

 

 
 

Table 40: 
Fiducials 

 

Function Description 

Source Defines the layer used for creating the 
fiducials. 

Tool Defines the tool used for creating the fiducials.  
 The tool “Spiral Drill 1.5mm” is 
automatically used for creating the fiducials. 

 

Assign to Phase Defines the phase where the fiducials are 
created. 
 Usually, the fiducials are created in the 
phase “Drill Fiducial”. 

 
Tolerance Defines the tolerance used for computing and 

checking the positions and distances of the 
toolpaths. 

 
Replace existing toolpath If a toolpath already exists, it is replaced by the 

newly created one. 
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Pockets 

The “Pockets” options are for creating the toolpaths for pockets in the circuit 
board. 

Fig. 285: Pockets 

 

 
 

Table 41: Pockets 

 
Function Description 

Tool Defines the tool used for milling the pockets. 

Tolerance Defines the tolerance used for computing and 
checking the positions and distances of the 
toolpaths. 

 
Replace existing toolpath If a toolpath already exists, it is replaced by the 

newly created one. 

 
 
5. Click on [Start]. 

➨ The following message is displayed: 

Fig. 286: 
Computation 
results 

 

  
 

 
Note 

The work steps and results of creating the toolpaths are listed 
in this dialog. If necessary, you can save or print its contents. 

 



 
How to work with CircuitPro PM CircuitPro PM 2.3  

 
 

236 V1.1 – 11.2016 © 2016 LPKF AG 

5 

6. Click on [Close] in the dialog. 

➨ The dialog with the computation results of the technology dialog is closed. 
 The toolpaths are created. 
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 Edit breakout tabs 5.4.4

This function lets you modify the breakout tab positions in the contour-routing 
toolpath. 
The circuit board milled through the whole material thickness during contour 
routing. When creating the toolpath, you can define tabs that keep the circuit 
board initially fixed to the material.  
The dialog “Edit breakout tabs position” lets you 

• edit, 
• add or  
• remove the positions of the tabs. 

Fig. 287: 
Contours of the 
circuit board 

 
 /1/ Positions of the breakout tabs /2/ Contours 

 

 
Note 

The contours have to be already created in order to use this 
function. 

 

 
Note 

Ensure that the “Replace existing toolpath” check box is 
checked so that your changes are stored. 

 
  

1 2 

1 
 

2 
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 Editing a breakout tab position 
1. Click on Toolpath > Edit breakout tabs… 

➨ The display of the contours in the CAM view changes and the following 
dialog is displayed: 

Fig. 288: Edit 
breakout tabs 
position 

 
 
The circles on the contour lines in the CAM view represent the current positions 
of the breakout tabs. 
2. Enter the gap width in mm. 
3. Move the mouse pointer to the desired breakout tab position. 

➨ The mouse pointer changes into a hand symbol. 
4. While pressing the left mouse button, drag the circle to the position where 

you want to place the breakout tab. 
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➨ The X and Y values of the breakout tab position change accordingly: 

Fig. 289: X- and 
Y-values changed 

 

5. Release the left mouse button at the desired position. 

➨ The position of the breakout tab is changed. 
6. Click on [Apply]. 
7. Click on [Close]. 

➨ The dialog is closed. 
 The breakout tab position is changed. 
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 Adding a breakout tab 
1. Click on [Add break] in the dialog: 

Fig. 290: Add a 
breakout tab 

 

➨ A new breakout tab (circle) is created. 

 
Note 

New breakout tabs are always created at the same position 
and must be moved to the desired position manually using the 
mouse. 

 
2. Enter the gap width in mm. 
3. Drag the circle with the mouse to the desired position. 
4. Click on [Apply]. 
5. Click on [Close]. 

➨ The dialog is closed. 
 A new breakout tab is created. 
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 Removing a breakout tab position  
1. Select the circle at the desired breakout tab position. 
2. Click on [Remove break]. 

➨ The selected breakout tab is removed. 
3. Click on [Apply]. 
4. Click on [Close]. 

➨ The dialog is closed. 
 The breakout tab position is removed. 
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5.5 Menu Modify 

The menu “Modify” contains the functions to edit geometrical objects. 
Click on the “Modify” menu item to open the submenu: 

Fig. 291: Menu 
“Modify” 

  
 
The following table provides a brief description of the menu item’s functions: 

Table 42: 
“Modify” menu 
functions 

 

Menu item Description 

Close open path Closes an open path. 

Combine open paths Combines several open paths to a single open 
path. 

Reduce number of 
element 

Reduces the number of elements for opened 
and closed paths and polygons. 

Convert to polygon Converts a closed path into a polygon. 

Convert to closed path Converts a polygon into a closed path. 

Draw to flash Converts a drawn object into a flash object and 
creates a new aperture.      

Combine to flash Combines objects to a flash object and creates 
a new aperture. 

Compare to flash Converts all objects that have the same form 
and size and are on the same as the selected 
flash object. 

Explode flash Explodes complex flash objects into individual 
geometric forms. 
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Table 42: 
“Modify” menu 
functions 

 

Menu item Description 

2.5D operations Opens the 2.5D operations sub-menu. 
Convert to 2D: This menu item applies a Z 
value to 2D objects thus converting them to 
2.5D objects. 
Change Z value: This menu item allows you 
to change the Z value of a 2.5D object. 

Transform… Opens a dialog to translate, rotate, scale and 
invert objects. 

Rotate/Mirror relative Opens the Rotate/Mirror sub-menu. 
• Rotate 90° 
• Mirror horizontal 
• Mirror vertical 

 
Step Repeat… Opens a dialog to multiply the selected objects 

with a defined spacing and count in X and/or Y 
direction. 
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 Close open path 5.5.1

Use the function “Close open path” to convert open paths into closed paths. 
 

 Closing an open path 
1. Select the open path in the CAM view: 

Fig. 292:Selecting 
an open path 

 
 
2. Click on Modify > Close open path. 
Or 

  



 
How to work with CircuitPro PM CircuitPro PM 2.3  

 
 

244 V1.1 – 11.2016 © 2016 LPKF AG 

5 

2. Click on “Close open path” in the context menu: 
Fig. 293: Close 
open path 
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➨ The open path is closed: 

Fig. 294: Closed 
path 

 
 
 The open path has been closed. 
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 Combine open path 5.5.2

The function “Combine open paths” lets you combine two or more open paths 
into one open path. 
 

 
Note 

Please note that the distance between the open paths must not 
be larger than the tolerance value set in the options. 
You can find the tolerance value in the branch “Miscellaneous” 
in the “Options” dialog (menu item Extras > Options). 
If the distance is larger than the tolerance value, the open 
paths will not be combined! 

 

 Combining open paths 
1. Select at least two open paths in the CAM view: 

Fig. 295:Selecting 
open paths 

  
 
2. Click on Modify > Combine open paths. 
Or 
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2. Click on “Combine open paths” in the context menu. 
Fig. 296: 
Combining open 
paths 

  
 

➨ The two open paths are combined: 

Fig. 297: Closed 
path 

 
 
 The open paths have been combined. 
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 Convert to polygon  5.5.3

Use the function “Convert to polygon” to convert closed paths into polygon 
areas. 
 

 Converting to polygon 
1. Select the closed path in the CAM view: 

Fig. 298: 
Selecting the 
closed path 

 
 
2. Click on Modify > Convert to polygon. 
Or 
2. Click on “Convert to polygon” in the context menu. 

Fig. 299: Convert 
to polygon 

 
 

  



 
CircuitPro PM 2.3 How to work with CircuitPro PM 

   

© 2016 LPKF AG  V1.1 – 11.2016 249 

5 

➨ The closed path is converted into a polygon: 

Fig. 300: Polygon 

 
 
 The closed path has been converted into a polygon. 
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 Convert to closed path 5.5.4

Use the function “Convert to closed path” to convert polygons into closed paths. 

 Converting into a closed path 
1. Select the polygon in the CAM view: 

Fig. 301: Select 
polygon 

 
 
2. Click on Modify > Convert to closed path. 
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Or 
2. Click on “Convert to closed path” in the context menu. 

Fig. 302: Convert 
to closed path 

 
 

➨ The polygon is converted into a closed path: 

Fig. 303: Closed 
path 

 
 
 The polygon has been converted into a closed path. 
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 Draw to flash 5.5.5

Use “Draw to flash” to convert drawn objects (circles, circle paths, rectangles 
etc) into flash objects. 
 

 Converting a rectangle into a flash object 
1. Select the rectangle in the CAM view: 

Fig. 304: Select 
rectangle 

 
 
2. Click on Modify > Draw to flash. 

➨ The rectangle is converted into a flash object. In addition, an aperture is 
created that is displayed in the “Geometry” pane. 

Fig. 305: Flashed 
rectangle 
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 The rectangle is converted into a flash object. 
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 Combine to flash 5.5.6

The function “Combine to flash” lets you combine two or more drawn objects to 
one flash object. 
 

 Combining drawn objects to a flash object 
1. Select the objects in the CAM view: 
 

 
Note 

The objects do not have to be on the same layer. 
The flashed object is placed on the layer of the object drawn 
last. 

 
Fig. 306: Selected 
objects 

  

 
 
2. Click on Modify > Combine to flash. 

  

 
Tip 

You can see that an object is flashed by the defined center point 
of the object that is displayed after flashing. 
The object type in the “Properties” pane is also changed to 
“Flash/Drill”. 
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➨ The following dialog is displayed: 

Fig. 307: New 
Aperture 

  

 
 
3. Enter a name for the new aperture to be created. 
4. Select an aperture list for the new aperture to be created. 
5. Click on [Apply]. 

➨ The selected objects are combined to a flash object: 
 

Fig. 308: Objects 
combined to flash 

 

 
 

➨ A new aperture is created with the specified name in the selected aperture 
list. 

➨ The objects are now on the same layer and are combined to a flash object. 
The center point of the flash object is defined. 

 The drawn objects are combined to a flash object. 
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 Compare to flash 5.5.7

The function “Compare to flash” lets you convert objects of same shape (e.g. 
circles) into flash objects. 
If the objects have small differences in size or angle, you can have these 
converted into flash objects as well by entering tolerance values for size and 
angle. 
 

 
Note 

If the sizes of the objects differ from the size of the flash object, 
the size is adjusted. Thus, the drawn objects have the same 
size as the flash object after converting to flash. 

 
The following conditions must be met: 
• The objects to be compared must have the same shape as the flash object. 
• All objects must be on the same layer. 
 

Fig. 309: Initial 
situation  

 
 /1/ flashed object (length 550 mm) 

/2/ rectangle (length 500 mm) 
/3/ rectangle (length 550 mm) 
/4/ rectangle (length 550 mm, 45°) 

 
All objects are on the same layer. The rectangles (see /2/ to /4/) are to be 
compared with the flash object and converted into flash objects. 
As the rectangles are not identical (rectangle /2/ is only 500 mm long and 
rectangle /4/ is rotated by 45°), using the function would only convert the 
identical rectangle /3/ into a flash object. 
In this case, it is necessary to enter tolerances for size and angle. 

  

1 

2 

3 

4 
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 Comparing rectangles with a flash object 
1. Select the flash object (see /1/). 
2. Click on Modify > Compare to flash. 

➨ The following dialog is displayed: 

Fig. 310: 
Compare to flash 

 
 
3. Enter the tolerance value. 

➨ As the rectangle /2/ is 50 mm shorter than the flash object, enter at least 
“50” so that rectangle /2/ is also converted into a flash object. 

4. Enter the angle. 

➨ As the rectangle /4/ is rotated by 45°, enter at least “45” so that this 
rectangle is also converted into a flash object. 

Fig. 311: Enter 
values 

 
 
5. Click on [Apply]. 
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➨ The rectangles /2/ to /4/ are converted into flash objects: 

Fig. 312: Flashed 
rectangles 

 
 

➨ The “Properties” pane now shows all rectangles having the object type 
“Flash/Drill”. As soon as you select one of the rectangles the center point is 
also displayed. 

 The rectangles were compared with the flash object and converted into 
flash objects. 
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 Explode flash 5.5.8

This function lets you convert flash objects back into their original object types. 
 

  Exploding a flash object 
1. Select the flash object that you want to explode: 

Fig. 313: Flash 
object 

 

 
2. Click on Modify > Explode flash. 

➨  The flash object is converted into its original type, a circle. 

Fig. 314: Circle 

 

 
  The flash object is exploded. 
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 2.5D operations 5.5.9

The 2.5D operations in CircuitPro PM can apply a Z depth to any drawn  
2D object. Use these operations to create pockets  in a circuit board. 
You can also convert existing 2.5D objects in 2D objects. 
The following operations are available: 
• Convert to 2.5D 
• Change Z value 
• Convert to 2D 
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Convert to 2.5D 

The objects that you convert to 2.5D objects are created on layers PocketTop or 
PocketBottom depending on the project type (single-sided or double-sided 
circuit board). 
 

 Converting a drawn object into a 2.5D object 
1. Select the object to be converted: 

Fig. 315: Convert 
object 

 
 
2. Click on Modify > 2.5D operations > Convert to 2.5D… 

➨ The following dialog is displayed: 

Fig. 316: Convert 
into 2.5D 

 
 
3. Select the destination layer (PocketBottom or PocketTop). 
4. Enter the Z value of the object. 
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Note 

Create a copy 
If the option “Create a copy” is activated, the drawn 2D object 
is preserved on its source layer. The 2.5D object is created on 
the selected destination layer. 
If you deactivate the option “Create a copy”, the drawn 2D 
object is deleted from its source layer. Only the newly created 
2.5D object on the destination layer remains. 

 
5. Activate/deactivate the option “Create a copy” as desired. 
6. Click on [Apply]. 

➨ The 2.5D object is created according to the selected option: 

Fig. 317: 2.5D 
object with 
“Create a copy” 

 
 

Fig. 318: 2.5D 
object without 
“Create a copy” 

 
 
 The drawn 2D object is converted into a 2.5D object. 
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Change Z value  

If you want to change the Z value of a 2.5D object, you can use the function 
“Change Z value...”. 
 

 Changing the Z value of a 2.5D object 
1. Select the 2.5 object whose Z value you want to change. 
2. Click on Modify > 2.5D operations > Change Z value 

➨ The following dialog is displayed: 

Fig. 319: Change 
Z value 

 
 
3. Enter the Z value. 
4. Click on [Apply]. 

➨ The Z value of the object is changed. You can check this in the “Properties” 
pane of the 2.5D object. 

5. Click on [Close].  
 The Z value of the 2.5D object is changed. 
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Convert to 2D 

This function enables you to convert existing geometrical 2.5D objects in 2D 
objects.  

 Converting a 2.5D object into a 2D object 
1. Select the 2.5D object to be converted: 

Fig. 320: 
Selecting the 
object 

 
 
2. Click on Modify > 2.5D operations > Convert to 2D… 

➨ A drop down list containing all available layers, on which you can place your 
2D object, is displayed: 

Fig. 321: 
Selecting a 
destination layer 

 
 
3. Select the destination layer (in this case TopLayer). 
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➨ The 2D object is created on the selected destination layer: 

Fig. 322: 2D 
object on 
destination layer 

 
 
 The 2.5D object has been converted into a 2D object. 
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 Transform 5.5.10

The “Transform” dialog lets you perform the following operations on objects in 
the CAM view: 
• Translate 
• Rotate 
• Scale 
• Mirror 
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Tab Translate 

The “Translate” function lets you move objects in the CAM view as follows: 
• Absolute translation a to a specified point from the zero point 
• Relative translation of the object center 
• Relative translation by entering a translation vector 
 

 Moving objects 
1. Select the object to be moved. 
2. Click on Modify > Transform… 

➨ The following dialog is displayed: 

Fig. 323: 
Transform 

 
 
3. Activate the desired option. 
4. Enter the absolute/relative X value. 
5. Enter the absolute/relative Y value. 
6. Click on [Apply]. 
7. Click on [Close]. 

➨ The dialog is closed. 
 The object is moved. 
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Tab Rotate 

The “Rotate” function lets you rotate objects counter-clockwise in the following 
ways: 
• Rotate around the center of the group (if more than one object is selected) 
• Rotate around individual centers 
• Rotate around given point (selected) 
 

 Rotating objects 
1. Select the object or objects to be rotated. 
2. Click on Modify > Transform… 
3. Select the “Rotate” tab. 

➨ The following dialog is displayed: 

Fig. 324: Rotate 

 
 
4. Enter the value of the angle. 
5. Activate the desired option. 
 

 
Note 

If you activated the option “Rotate around given point” you 
have to enter the X and Y value of the point. As an alternative, 
you can set the desired point in the CAM view using the 
mouse. The object will be rotated around that defined point. 

 
6. Click on [Apply]. 
7. Click on [Close]. 

➨ The dialog is closed. 
 The object is rotated. 

Pos: 6.6.17 /ED _Technische_D okumentati on/2_Bedienungsanl eitung/Software/CircuitPr o 2.1/Kapitel 5_So ar beiten Sie mi t CircuitPro PM /6_Menü Änder n/11_Tr ans for mati on/04_Tr ansformati on_R egister Skalier ung @ 6\mod_1383660768592_2058.docx @ 127122 @ 5 @ 1  
 

  



 
CircuitPro PM 2.3 How to work with CircuitPro PM 

   

© 2016 LPKF AG  V1.1 – 11.2016 265 

5 

Tab Scale 

The “Scale” function lets you modify the size of the objects as follows: 
• Scale the group (if more than one object is selected) 
• Scale each object individually 
 

 Scaling objects 
1. Select the object or objects to be scaled. 
2. Click on Modify > Transform… 
3. Select the “Scale” tab. 

➨ The following dialog is displayed: 

Fig. 325: Scale 

 
 
4. Activate the desired option. 
• Scale group 
• Scale each object individually 
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Example: 
Your layout in the Cam view includes an open path and two circles: 

Fig. 326: Example 

 

 
If you select all objects, activate the option “Scale group” and enter a new size 
of 200%, your layout will change as follows: 

Fig. 327: Option 
“Scale group” 
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If you select all objects, activate the option “Scale each object individually” and 
enter a new size of 200%, your layout will change as follows: 
 

Fig. 328: Option 
“Scale each 
object 
individually” 

 

 

➨ The option “Scale each object individually” causes, that the objects’ 
positions are not recalculated when entering a new size. These objects 
remain in the original position and could therefore lead to an incorrect 
layout.  

 
5. Enter a scaling factor in percent. 
6. Click on [Apply]. 
7. Click on [Close]. 

➨ The dialog is closed. 
 The object is scaled. 
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Tab Mirror 

The “Mirror” function lets you mirror objects in the CAM view as follows: 
• Mirror along the X Axis 
• Mirror along the Y Axis 
• Mirror along an arbitrary axis 
 

 Mirroring an object 
1. Select the object or objects to be mirrored. 
2. Click on Modify > Transform… 
3. Select the “Mirror” tab. 

➨ The following dialog is displayed: 

Fig. 329: Mirror 

 
 
4. Activate the desired option. 
 

 
Note 

If you activate the option “Mirror X” or “Mirror Y”, you can use 
the mouse to select the X or Y axis in the CAM view along 
which the object is to be mirrored. 

 

 
Note 

If you activate the option “Mirror around arbitrary axis”, you can 
enter the X and Y values to define the arbitrary axis along 
which the object(s) is (are) to be mirrored. 
As an alternative, you can use the mouse in the CAM view to 
set two points that define the mirror axis. 

 
5. Click on [Apply]. 
6. Click on [Close]. 

➨ The dialog is closed. 
 The object is mirrored. 
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 Rotate/Mirror relative 5.5.11

The “Rotate/Mirror relative” function enables you to rotate objects in the CAM 
view by 90° or mirror along the X or Y axis: 
 

 Rotating an object by 90° 
1. Select the object to be rotated. 
2. Click on the object's point around which the object is to be rotated: 

Fig. 330: Rotate 
object by 90° 

 
 

 
Note 

CircuitPro PM rotates the object(s) around the current anchor 
point . 

 
3. Click on Modify > Rotate/Mirror relative > Rotate 90°. 
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➨ The object is rotated around the anchor point by 90°: 

Fig. 331: Object 
rotated by 90° 

 
 
 The object is rotated around the anchor point .by 90°. 

 

 
Note 

The above steps apply to all rotate functions in the sub-menu 
“Rotate/Mirror relative” accordingly. 
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 Mirroring objects along the X axis 
1. Select the object or objects to be mirrored. 
2. Click on the object point through which the mirror axis is to be placed. 
 

Fig. 332: Mirror 
object 

 
 

 
Note 

The figure above shows the anchor point of the object marked 
with a red arrow. This is where CircuitPro PM places the mirror 
axis. 
 

 
3. Click on Modify > Rotate/Mirror relative > Mirror X. 
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➨ The object(s) is (are) mirrored. 

Fig. 333:Object 
mirrored 

 
 
 The object(s) is (are) mirrored along the X axis. 

 

 
Note 

The above steps apply to the “Mirror Y” function in the sub-
menu “Rotate/Mirror relative” accordingly. 

 
Pos: 6.6.20 /ED _Technische_D okumentati on/2_Bedienungsanl eitung/Software/CircuitPr o 2.1/Kapitel 5_So ar beiten Sie mi t CircuitPro PM /6_Menü Änder n/13_Step and Repeat @ 6\mod_1383660739263_2058.docx @ 127026 @ 3 @ 1 
 

  



 
CircuitPro PM 2.3 How to work with CircuitPro PM 

   

© 2016 LPKF AG  V1.1 – 11.2016 273 

5 

 Step Repeat 5.5.12

The “Step Repeat” function lets you multiply the selected object(s) 
• by any number in X direction, 
• by any number in Y direction 
• using a defined step distance. 
 

 Multiplying an object 
1. Select the object that you want to multiply. 

Fig. 334: Step and 
Repeat initial 
object 

 
 
2. Click on Modify > Step Repeat… 

➨ The following dialog is displayed: 

Fig. 335: Step & 
Repeat dialog 

 
 
In this example, the object is to be multiplied by three in X direction and by two 
in Y direction with a step distance of 300 mm in x and Y direction. 
3. Enter the repetition values in X and Y direction. 
4. Enter the step distance in X and Y direction in mm. 
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Note 

If you check the option “Combine to flash”, the object or group 
to be multiplied is converted into a flash object. 
 You can select an aperture size for conversion into flash 
objects. The aperture list is displayed when you activate the 
option. 

 
5. Click on [Apply]. 

➨ The object is multiplied: 

Fig. 336: 
Multiplied objects 

 
 
6. Click on [Close]. 
 The object is multiplied. 
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5.6 Menu View 

The menu “View” allows you to show/hide the different panes and open the 
layouts. 
Click on the “View” menu item to open the submenu: 

Fig. 337: Menu 
“View” 

 
 
The following table provides a brief description of the menu item’s functions: 

Table 43: 
Menu 
functions 
“View” 

 

Menu item Description For more information, see 
chapter “Pane”  

Layers… Shows/hides the pane “Layers”. see page 46 

Geometry… Shows/hides the pane “Geometry”. see page 47 

Toolpath… Shows/hides the pane “Toolpath”. see page 47 

Processing… Shows/hides the pane 
“Processing”. 

see page 48 

Properties Shows/hides the pane “Properties”. see page 50 

Tool info Shows/hides the pane “Tool info”. see page 51 

CAM 2D… Opens the view “CAM 2D”. see page 27 

Machining 2D… Opens the view “Machining 2D”. see page 32, 33, 34, 35 

3D View Opens the view “3D View”. see page 38 

Navigation Shows/hides the pane 
“Navigation”: 

see page 52 

Messages… Shows/hides the pane “Messages”. see page 54 

Fault monitor… Shows/hides the pane “Fault 
Monitor”. 
 

see page 55 
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Table 43: 
Menu 
functions 
“View” 

 

Menu item Description For more information, see 
chapter “Pane”  

 

Layouts Opens the sub menu “Layouts”. 
Here you can open the different 
views with the different panes: 

 Standard CAM 
 Compact CAM 
 Machining 

 

 

 

Toolbars Opens the sub menu “Toolbars”.  
Here you can activate/deactivate 
the visibility of the individual 
toolbars: 

 Modify 
 STANDARD 
 Process 
 Insert 
 Custom 
 Status bar 

 

 

 
You find more information about the details of the different submenus in the 
corresponding topics of the chapter “Panes”. 
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5.7 Menu Select 

The menu “Select” allows you to define the elements on the object which should 
be selected/highlighted by the mouse.  
Click on the “Select” menu item to open the submenu 
: 

Fig. 338: Menu 
“Select” 

 
 
The following table provides a brief description of the menu item’s functions: 

Table 44: Menu 
functions 
“Select” 

 

Menu item Description 

By Polygon Enable this option to create polygons by using your 
mouse and to select objects within the polygon.  

Invert in 2D Enable this option to invert your selection in the CAM 
View. 

Select all Selects all objects.  

Open/Closed path Selects open/closed path objects. 

Polygon Selects polygons. 

Circle Selects circles. 

Rectangle Selects rectangles. 
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Table 44: Menu 
functions 
“Select” 

 

Menu item Description 

Text Selects text objects. 

Flash Selects flash objects. 

Toolpath Selects toolpaths. 

 Enable all Enables the selection of all objects. 

 Disable all Disables the selection for all objects in the CAM view. 
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5.8 Menu Wizards 

This menu contains several wizards to help you in PCB manufacturing. 
Click on the “Wizards” menu item to open the submenu: 

Fig. 339: Menu 
“Wizards” 

 
 

Table 45: Menu 
functions 

 

Menu item Description 

Equipment 
configuration wizard… 

Use the Equipment configuration wizard to define the 
existing equipment for the manufacturing of PCBs. 

Process planning 
wizard… 

Use this wizard to set the properties of the prototype 
project (for example: double sided with through 
plating). 

Board Production 
Wizard… 

This wizard guides you through every step of the PCB 
manufacturing. 

Dispense preparation 
wizard… 

Starts a wizard, which guides through the preparation 
of a dispense process. 

 
Dispense process 
wizard… 

Starts a wizard, which guides through a dispense 
process. 
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 Equipment configuration wizard 5.8.1

The equipment configuration wizard starts automatically when the program is 
started for the first time. This is where you define the equipment you are going 
to use. 
 

 Opening the Equipment configuration wizard dialog 
1. Click on Wizards > Equipment configuration wizard… 

➨ The dialog of the Equipment configuration wizard is displayed: 

Fig. 340: 
Equipment 
configuration 
wizard 

 

 /1/ List of configuration steps 
/2/ Section for descriptions or 
configuration options 

/3/ [Next] – Confirms the configuration 
step and switches to the next 
configuration step 
/4/ [Cancel] – Closes the Equipment 
configuration wizard without saving the 
settings 

 
2. Follow the prompts of the Equipment configuration wizard. 

  

1 2 3 4 
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➨ In the final step, the Equipment configuration wizard displays a summary of 
the settings you entered. 

Fig. 341: 
Equipment 
configuration 
wizard - Summary 
  

 

 
3. Click on [Done], to close the Equipment configuration wizard.  
 The Equipment configuration wizard is finished.  
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 Process planning wizard 5.8.2

Use the process planning wizard to define the process components you are 
going to use. 
 

 Opening the Process planning wizard dialog 
1. Click on Wizards > Process planning wizard… 

➨ The dialog of the process planning wizard is displayed: 

Fig. 342: Process 
planning wizard 

 

 /1/ Steps/Overview 
/2/ Section for descriptions or 
configuration options 

/3/ [Next] – Confirms the selection and 
switches to the next configuration step 
/4/ [Cancel] – Closes the process 
planning wizard without saving the 
settings 

 
2. Follow the prompts of the process planning wizard. 

  

1 2 3 4 
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➨ In the final step, the process planning wizard displays a summary of the 
settings you entered. 

Fig. 343: Process 
planning wizard - 
Summary 
  

 

 
3. Click on [Done] to close the Process planning wizard.  
 The Process planning wizard is finished. 
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 Board Production Wizard 5.8.3

The board production wizard guides you through the board production process. 
 

 Opening the Board Production Wizard dialog 
1. Click on Wizards > Board Production Wizard… 

➨ The dialog of the Board Production Wizard is displayed: 

Fig. 344: Board 
Production 
Wizard 

 

 /1/ List of the production phases 
/2/ Section for prompts and display of 
progress 

/3/ [Start] – Starts board production 
/4/ [Cancel] – Closes the board 
production wizard and aborts the 
production process. 

2. Follow the prompts of the board production wizard.  
  

1 2 3 4 
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➨ The progress of the current phase and the overall progress are displayed 
during the whole process of board production. 

Fig. 345: Board 
Production 
finished 
  

 

3. Click on [Finish], to close the Board Production Wizard. 
 The Board Production Wizard is finished. 
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 Dispense Preparation Wizard 5.8.4

 

 
Note 

Please note, that you can only use the Dispense preparation 
wizard with a ProtoMat S63/S103.  

 
The dispense preparation wizard guides you through the steps for preparing the 
dispense process. 

 Opening the dispense preparation wizard dialog 
1. Click on Wizards > Dispense preparation wizard…. 

➨ The dialog of the dispense preparation wizard is displayed: 

Fig. 346: 
Dispense 
preparation 
wizard 

 

 /1/ List of the steps in preparing the 
dispense process 
/2/ Section for prompts and display of 
progress 

/3/ [Next] – Confirms the operation and 
switches to the next preparation step 
/4/ [Cancel] – Closes the dispense 
preparation wizard without saving the 
settings 

2. Follow the prompts of the dispense preparation wizard. 
 

 
Note 

In order to determine the camera offset, 5 solder paste dots are 
applied. The last dot has a greater distance to the other dots. 
This last dot is used for measuring the offset. If this dot is not 
measured correctly the dispense process cannot be run 
correctly. Thus, it is essential that you check the camera image 
before confirming the offset in the wizard. 

  

1 2 3 4 
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The following scenarios may occur when measuring the camera offset: 
 
Scenario 1 

 The camera finds the last applied dot and centers it in the camera image. 
1. Click on [Accept Current Position] to apply the position. 

Fig. 347: Fiducial 
recognized 
automatically 

 
 
 The “Camera offset” phase is finished successfully. 

 
Scenario 2 

 The camera finds the last applied dot but does not center it in the camera 
image. 

1. Click on [Find and Center]. 

➨ The camera centers the dot. 
2. Click on [Accept Current Position]. 
 The “Camera offset” phase is finished successfully. 
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Scenario 3 

 The camera does not find the dot. 
1. Use the X and Y buttons (/1/) in the “Processing” pane to position the last 

applied dot approximately at the center of the camera image. 
2. Click on [Find and Center]. 

➨ The camera centers the dot. 
3. Click on [Accept Current Position]. 

Fig. 348: Fiducial 
not recognized 
automatically 

 
 /1/ X and Y buttons 

 
/2/ Camera image centered 

 The “Camera offset” phase is finished successfully. 

 
  

1 

2 
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Scenario 4 

 The camera finds one of the first four dots. 
1. Use the X and Y buttons (/1/) in the “Processing” pane to position the last 

applied dot approximately at the center of the camera image. 
2. Click on [Find and Center]. 

➨ The camera centers the dot. 
3. Click on [Accept Current Position]. 
 The “Camera offset” phase is concluded successfully. 

 
 
3. If the camera offset is successfully adjusted, follow the next instructions of 

the Dispense preparation wizard. 

➨ The following view is displayed, if the Dispense preparation wizard is 
finished: 

Fig. 349: 
Dispense 
preparation 
wizard finished 
  

 

 
4. Click on [Done], to close the Dispense preparation wizard. 
 
 The Dispense preparation wizard is finished. 
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 Dispense process wizard  5.8.5

The dispense process wizard guides you through the steps of the dispense 
process.  
 

 
Note 

Beforehand you must have created the solder paste paths and 
passed through the Dispense preparation wizard. 

 

 Opening the dispense process wizard dialog 
1. Click on Wizards > Dispense process wizard… 

➨ The dialog of the dispense process wizard is displayed: 

Fig. 350: 
Dispense process 
wizard 

 

 /1/ List of process steps 
/2/ Section for prompts and display of 
progress 

/3/ [Next] – Starts a new dispense 
process 
/4/ [Finish] – Closes the dispense 
process wizard 

 
2. Follow the prompts of the dispense process wizard. 

1 2 3 4 
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Fig. 351: 
Dispense process 
wizard finished 
  

 

 
3. Click on [Next board], if you want to dispense solder paste on another 

board.  
Or 
3. Click [Finish], if you want to close the Dispense process wizard.  
  The Dispense process wizard is finished. 
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5.9 Menu Machining 

The menu “Machining” allows you to start/stop the processing and to make 
settings for the PCB processing. 
Click on the “Machining” menu item to open the submenu: 

Fig. 352: Menu 
“Processing” 

 
 
The following table provides a brief description of the menu item’s functions: 

Table 46: Menu 
functions 
“Machining” 

 

Menu item Description 

Process all Starts the production. 

Stop processing Stops the production. 

Production 
phase… 

Opens the dialog “Create new phase”. Then you can create a 
new production phase. 

Placement… Opens the dialog “Placement“. 

Fiducials… Inserts fiducials as toolpath in the machining view. 

Measure milling 
width… 

Only with conical surface milling tools (Universal Cutter and 
Micro Cutter:  
the current milling width is measured. 

Alignment… Opens the dialog “Alignment”. 

Drill reference 
holes… 

Opens the dialog “Drill reference holes”. 

Service…  Access to service functions for service staff. 

 
Determine camera 
head offset… 

Starts a dialog, which guides you through the procedure to 
determine the camera head offset. 
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Table 46: Menu 
functions 
“Machining” 

 

Menu item Description 

 
Teach tool-holder 
positions… 

Measures the tool position by camera. 

 
Import settings Opens the dialog “Import settings” where you can import 

settings files of BoardMaster or CircuitPro. 

 
Export settings Opens the dialog “Export settings” where you can export the 

current machine settings. 

 

Connect… Opens the dialog “Connect…”. 
You can connect CircuitPro PM with a physically connected 
machine, disconnect a machine or switch between machines. 
You can also connect with a virtual machine. 
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 Process all 5.9.1

The menu item “Process all” starts the circuit board production. The individual 
production phases are processed one after the other. 
Click on Machining > Process all to start the board production. 

 Starting the process 
1. Click on Machining > Process all. 

➨ The folowing message is displayed: 
  

Fig. 353: Check 
tools 

 

  

 
2. Check the tools. 
3. Click on [Proceed] if the tools are operational. 
or 
4. Click on [Cancel] if the tools are damaged and insert new tools. 
 The processing has been started. 
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 Stop processing 5.9.2

Use “Stop processing” in order to stop the current processing of the circuit 
board. The current phase is not completed. The milling head moves to the 
pause position. 
To stop the machine processing the material, click on 
Machining > Stop processing. 
If you want to resume processing the circuit board you have the following 
options: 
• Restarting the whole phase where the process was interrupted [Resume]. 
• Continue the process from the selected phase onwards [Ignore]. 
•  Cancel the process [Cancel]. 

Fig. 354: 
Processing 
aborted 
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 Production phase  5.9.3

You can create new production phases for the circuit board production. 
These will be displayed in the “Phases” branch in the “Toolpath” pane. 

 Creating a new phase 
1. Click on Machining > Production phase… 

➨ The following dialog is displayed: 

Fig. 355: Create 
new Phase 

 
 
2. Enter a name for the new phase. 
3. Select a processing step. 
4. Select a linked phase if necessary. 
5. Select the processing order. This field defines when your newly created 

phase will be processed. 
 

 
Note 

Option “The data are mirrored (bottom side data)” 
Activate this check box if the phase to be created shall be 
processed after the circuit board has been turned over. The 
data are mirrored to achieve this. 

 

 
Note 

Option “The phase contains toolpath data” 
Activate this check box if the phase to be created shall contain 
toolpaths. 

 
6. Click on [Apply]. 

➨ The new phase is created and is displayed in the “Toolpath” pane. 
7. Click on [Close]. 
 The new phase has been created. 
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 Placement  5.9.4

Use “Placement” to move and/or multiply the processing data in the Machining 
view of CircuitPro PM. 
Click on Machining > Placement to open the dialog. 
The section “Relative translation” lets you move the whole circuit board design 
within the machining view. 
 

 
Note 

Please note that you can move the processing data only as a 
whole and not individual toolpaths etc. 

 
The “Step and Repeat” section lets you multiply the circuit board design as 
desired in X and Y direction with a defined step distance. Thus you can produce 
several circuits on one panel. 

Fig. 356: 
Placement 

 
 

 Moving the processing data (relative translation) 
1. Enter a dX value. 
2. Enter a dY value. 
3. Click on [Apply]. 
 

 
Tip 

Procedure without entering X and Y values 
You can also move the processing data in the Machining view 
using your mouse. 
To do this, click on the processing data and while pressing the 
left mouse button drag the circuit frame to the position where 
you want to place the circuit design. 
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➨ The circuit board date are placed at the corresponding position. 
 

 
Note 

If you want to move the processing data to the center of the 
working area, click on [Set center]. 

  
4. Click on [Close]. 
 The processing data are moved. 

 

 Rotating the processing data 
1. Enter the angle in the field \Angle\. 
2. Click on the buttons beside to rotate the processing data in the desired 

direction.  
 The processing data was rotated.  

 

 Multiplying the processing data 
1. Enter the number of circuits that are to be produced in X and Y direction. 
2. Enter the step distance of the circuits in X and Y direction. 
3. Click on [Apply]. 

➨ The circuits are created according to the values entered. 
4. Click on [Close]. 
 The processing data are multiplied. 

 

 
Note 

If you apply changes in the technology dialog that modify the 
bounding box of the current job (e.g. deactivating the contour 
routing or the fiducials) after having multiplied the circuit, you 
can adjust the job to the original placement values. 
The following warning is displayed if the toolpaths are 
recomputed in the technology dialog prompting you to execute 
the placement again. 

 
 Click on [Reset] in the placement dialog. The current design 
is adjusted to the original placement values. 
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 Fiducials 5.9.5

Using the function "Fiducials," you can set the optical markings in the machining 
view of CircuitPro PM. These fiducials are only inserted into the layout as 
toolpaths and are not present as geometrical objects. This means that in the 
CAM view of CircuitPro PM, the fiducials which were created by this function 
are not displayed. 
 

 
Note 

In order to be able to perform this function, you must first 
generate the toolpaths so that the layout can be displayed in 
the machining view. 

 
Using the function "Fiducials” you can 

• set the fiducials in the machining view, 
• process the fiducials in the machining view and 
• delete the fiducials in the machine view. 
 

 Inserting fiducials 
 

 
Tip 

Ideally, set four fiducials in order to align the top and bottom side 
to each other. 
However, you can also work with two fiducials. In this case, 
these should be diagonally aligned to one another.  

 
1. Click on Machining > Fiducials… 

➨ The machining view of CircuitPro PM is activated. 

➨ The following dialog is displayed: 

Fig. 357: 
Fiducials 

 

 
2. Select the processing phase in the field \Phase\, in which the fiducials are to 

be generated. 
3. Select the drilling tool in the field \Tool\ for generating the fiducials. 
4. If not active, activate the mode {Insert}. 
5. Enter the X and Y coordinates of the fiducials and click on [Set coordinates]. 
Or 
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5. Using your mouse, on the machining view, click where you would like to 
place the fiducials. 

➨ The fiducial is inserted in the appropriate position in the machining view. 
 

 
Note 

Editing the coordinates of the fiducials 
If you would like to change the coordinates of a fiducial, proceed 
as follows: 

1. Activate the mode "Edit". 
 The coordinates of the last fiducial set are shown.  
2. Change the coordinates and click on [Set coordinates]. 
or 
2.   Select the fiducial and move this to the desired position 
in the machining view. 
 The coordinates have been edited. 

 

 
Note 

Delete fiducial 
If you would like to delete a fiducial, proceed as follows: 

1. Activate the mode "Edit". 
 The coordinates of the last fiducial set are shown.  
2. Select the fiducial to be deleted. 
3. Click on [Remove]. 

 
!!! If you have deleted the coordinates of the fiducial, the 
coordinates of the fiducial set previously are shown 
automatically!!! 
 

 The fiducial has been deleted. 

 
6. Please repeat step 5 until you have generated the desired number of 

fiducials. 
  



 
How to work with CircuitPro PM CircuitPro PM 2.3  

 
 

300 V1.1 – 11.2016 © 2016 LPKF AG 

5 

➨ A rectangle, which highlights the position of the fiducials, is created around 
the layout: 

Fig. 358: Fiducial 
marks in the 
machining view. 

 

 /1/ Fiducials /2/ Rectangle 

 
7. Click on [Close]. 

➨ The dialog is closed. 
 The fiducials have been inserted. 
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 Measure milling width ProtoMat E33/E34/S43/X60 5.9.6

The menu item “Measure milling width” lets you mill a line in the base material 
and measure the milling width with a microscope. 

 Measuring the milling width 
1. Click on Machining > Measure milling width… 

➨ The following dialog is displayed: 
Fig. 359: Measure 
milling width 

 
 
2. Click on the position in the Machining view where you want to mill the line. 
3. Enter the length of the line to be milled. 
4. Select an option: 

• Horizontal milling line 
• Vertical milling line 

5. Click on [Mill a Line]. 
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➨ The line is milled at the selected position.  
6. Check the milling width with a microscope: 
 

 
Note 

To determine the correct milling width, put on the microscope 
at the lower, inner edges of the copper: 

 

 
7. Click on [Accept Width], if the milling width is okay. 
or 
7. Adjust the tool manually and mill a line again until the result of the milling 

width is okay. 
or 
7. Install a new tool. 
8. Click on [Try New Tool]. 
9. Repeat the steps 1 to 6. 
 The milling width has been measured. 
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 Measure milling width ProtoMat S63/S103/H100 5.9.7

The menu item “Measure milling width” lets you mill a line in the base material 
and measure the milling width with the camera. 

 
Hinweis 

Measuring the milling width with the camera is only possible for 
lines that have been milled with a Universal Cutter. Lines that 
have been milled with the Micro Cutter are measured with a 
microscope (see 5.9.10 on page 306). 

 Measuring the milling width 
1. Click on Machining > Measure milling width…. 

➨ The following dialog is displayed: 
Fig. 360: Measure 
milling width 

 
 
2. Click on the position in the Machining view where you want to mill the line. 
3. Enter the length of the line to be milled. 
4. Select an option: 

• Horizontal milling line 
• Vertical milling line 

5. Click on [Start]. 

➨ The line is milled at the selected position. The Camera pane displays the 
milled line. 

➨ The following dialog with the measurement results is displayed: 

Fig. 361: Result 
of milling width 
check 

 
 
6. Click on [Close]. 
 The milling width has been measured. 
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 Measure milling width ProtoMat E44 5.9.8

The menu item “Measure milling width” allows you mill a line in the base 
material and measure the milling width with the camera. 

 
Hinweis 

Measuring the milling width with the camera is only possible for 
lines that have been milled with a Universal Cutter. Lines that 
have been milled with the Micro Cutter are measured with a 
microscope (see 5.9.10 on page 306). 

 

 Measuring the milling width 
1. Click on Machining > Measure milling width…. 

➨ The following dialog is displayed: 
Fig. 362: Measure 
milling width 

 
 
2. Click on the position in the “Machining view” where you want to mill the line. 
3. Enter the length of the line to be milled. 
4. Select an option: 

• Horizontal milling line 
• Vertical milling line 

5. Click on [Mill a Line]. 

➨ The line is milled at the selected position. The “Camera” pane displays the 
milled line. 

➨ The following dialog with the measurement results is displayed: 

Fig. 363: Result 
of milling width 
check 

 
 
6. Click on [Accept Width]. 
 The milling width has been measured. 



 
CircuitPro PM 2.3 How to work with CircuitPro PM 

   

© 2016 LPKF AG  V1.1 – 11.2016 305 

5 

 Measure milling ProtoMat D104 5.9.9

The menu item “Measure milling width” enables you to mill a line in the base 
material and measure the milling width with the camera. 

 
Hinweis 

Measuring the milling width with the camera is only possible for 
lines that have been milled with a Universal Cutter. Lines that 
have been milled with the Micro Cutter are measured with a 
microscope (see 5.9.10 on page 306). 

 Measuring the milling width 
1. Click on Machining > Measure milling width…. 

➨ The following dialog is displayed: 
Fig. 364: Measure 
milling width 

 
 
2. Click on the position in the “Machining view” where you want to mill the line. 
3. Enter the length of the line to be milled. 
4. Select an option: 

• Horizontal milling line 
• Vertical milling line 

5. Click on [Start]. 

➨ The line is milled at the selected position. The “Camera” pane displays the 
milled line. 

➨ The following dialog with the measurement results is displayed: 

Fig. 365: Result 
of milling width 

 
 
6. Click on [Close]. 
 The milling width has been measured. 
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 Measuring the milling width (Micro Cutter) 5.9.10

Use the function "Measure milling width" to to mill a line into the base material 
which milling width is subsequently measured with the microscope. 
 

 Measuring the milling width 
1. Click on Machining > Measure milling width.... 

➨ The following dialog is displayed:  
Fig. 366: 
Measuring the 
milling width 
(Micro Cutter) 

 
 
2. Click on the position in the Machining view where you want to mill the line. 
3. Enter the length of the line to be milled. 
4. Select an option: 

Horizontal milling line 
Vertical milling line 

5. Click on [Start]. 

➨ The line is milled at the selected position.  

➨ The dialog with the results is displayed: 

Fig. 367: Results  

 
 

 
Hinweis 

If the option Adjust width manual for micro cutter is set to 
False, the milling width is measured with the camera and 
measurement with the microscope is omitted. The option Adjust 
width manual for micro cutter can be found in Extras > 
Options under the item “Machine”. 
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6. Measure the milling width by using a microscope. 
 

Note 

To determine the correct milling width, put on the 
microscope at the lower, inner edges of the copper: 

 
 
7. Enter the measured value into the field \ Measured width \. 

Note 

If there is a difference between the desired milling width and the 
measured width CircuitPro PM automatically proposes a 
correction value. 

 

Note 

You can manually enter a correction value if you do not want to 
apply the value proposed by CircuitPro PM. 

 
8. Increase or decrease the value of the proposed correction by using the two 

arrow buttons. 
9. To mill the line with the entered proposed correction, click on [Repeat]. 

➨ The new line is milled onto the base material with a slight offset and the 
dialog with the results is displayed: 

Fig. 368: Results  

 
 
10. Measure the milling width by using a microscope. 
11. Enter the measured value into the field \ Measured width \. 
12. Repeat steps 6 - 12 until the desired milling width is reached. 
or 
9. Click on [Store correction] to apply the proposed value. 

➨ The correction value for the current tool has been applied. The dialog is 
closed. 
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Note 

If you do not want to apply any correction click on [Cancel]. 

 
 The milling width has been checked. 
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 Alignment (only if camera is present)  5.9.11

The dialog “Alignment” allows you modify the settings for the “ReadFiducials” 
phase. 

 Modifying the settings for phase “DrillFiducial” 
1. Click on Machining > Alignment. 

➨ The following dialog is displayed: 

Fig. 369: 
Alignment 

 
 
2. Select the existing fiducials in the design that are to be used in the 

“DrillFiducials” phase.  
3. Modify the individual parameters for the “DrillFiducial” phase as necessary. 
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Table 47: 
Alignment 

 

Option Description 

Fiducials for step-
and-repeat 

If the project has been multiplied with “Step and 
Repeat”, the fiducials are multiplied as well. 
 
Use fiducials of original project only 

 
 
Use outer fiducials of entire multiplied project 

 
Diameter Tolerance Defines the tolerance for the diameter of the fiducial. 

Search Area Length Defines the size of the search area. 

 
Minimum Fiducial 
Quality 

Defines the quality level that a found fiducial must 
meet in order to be centered. 

 
Distance for Direct 
Acceptance 

Defines how precisely the fiducial must be centered 
in the camera image. 

 
Show Fiducial Time Defines the time that the camera remains on a 

found fiducial before continuing the process. 

 
Maximum No. of 
centering Tries 

Defines the maximum number of tries to center a 
found fiducial in the camera image. 

 
Manual Centering If 
Not Found 

If no fiducial is found, a dialog for manual centering 
is displayed. 

 
Ask for 
Confirmation 

After finding and centering a fiducial, the fiducial 
must be confirmed. 

4. Modify the settings as desired. 
5. Click on [OK]. 
 The settings for the “DrillFiducial” phase have been modified. 
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 Drill reference holes 5.9.12

Use “Drill reference holes” to drill the holes for the reference pins. 
 

 
Note 

The reference hole system can be used for aligning the board 
if no camera is available. 
The reference hole system is not used if a vacuum table is 
mounted. 

 
Click on Machining > Drill reference holes to open following dialog: 

Fig. 370: Drill 
reference holes 

 
 
There are three options for drilling reference holes to choose from: 
• Drill Both Reference Holes: One reference hole is drilled at the home 

position and one opposite to the home position. 
• Drill Reference Hole at Home Position: A reference hole is drilled at the 

home position. 
• Drill Reference Hole Opposite To Home Position: A reference hole is 

drilled at the position opposite to the home position. 
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 Drilling reference holes 
1. Select the desired option for drilling the reference holes in the “Operations” 

section. 
 

 
Note 

The “Parameters” section contains LPKF standard settings. 
These settings are activated by default. If you want to use 
different values, remove the check mark at <Use LPKF 
Standard Settings>. 

 
2. Enter the offset value and the distance between the reference holes in the 

“Parameters” section if necessary. 
3. Click on [Start]. 

➨ The milling head moves to the corresponding position(s) and drills the 
reference hole(s). 

 

 
Note 

The reference holes are drilled using a Spiral Drill 2.95 mm. 
This tool must be present in the tool magazine or, in case of 
machines without tool magazine, must be inserted manually 
into the clamp (when prompted). 

 
 The reference holes are drilled. 
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 Service 5.9.13

Only qualified personnel authorized by LPKF can activate the “Service” menu 
item by entering a password. 
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 Determining the camera head offset 5.9.14

This function lets you measure the offset between the camera and the milling 
head. 
Click on Machining > Determine camera head offset… 

➨ The following dialog is displayed: 

Fig. 371: 
Determine 
camera-to-
milling-head 
offset 

 

 
 
You can choose between determining the X/Y-Offset and the Z-Focus-Offset. 
The Z-Focus-Offset is used to determine the material height for 2.5D 
operations. 
 

 Determining the X/Y-Offset 
1. Put the base material onto the table. 
2. Click on [Determine X/Y-Offset]. 

➨ The following dialog is displayed in the machining view: 

Fig. 372: 
Determine 
camera-to-
milling-head 
offset 

 

 
3. Follow the instructions in the dialog window. 
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4. Click on [Apply]. 

➨ A hole is drilled at the selected position. The camera moves to this drill hole 
and measures the position (see “Camera” pane). 

➨ The following dialog is displayed: 

Fig. 373: Offset 
determined 

 

 
5. Click on [OK]. 

➨ The following dialog is displayed: 

Fig. 374: Save 
results 

 

 
6. Click on [Save]. 

➨ CircuitPro synchronizes the results with the machine. A corresponding 
message is displayed: 

Fig. 375: 
Synchronizing 
the results 

 

 
 The X/Y-Offset is determined.  

 

 Determining the Z-Focus offset 
1. Click on [Determine Z-Focus-Offset]. 

➨ The following message is displayed: 

Fig. 376: 
Dismount the 
depth limiter 

 

 

 
Note 

For more information about dismounting the depth limiter, please 
refer to the delivered ProtoMat S manual. 
 

 
2. Confirm the message by clicking on [OK]. 
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➨ The following dialog is displayed: 

Fig. 377: Teach Z-
Focus Offset 

 

 
3. Follow the instructions in the dialog. 
4. Click on [OK]. 

➨ The following dialog is displayed: 

Fig. 378: Refining 
Z position 

 

 
5. Follow the instructions in the dialog. 
6. Click on [OK]. 

➨ The following dialog is displayed: 

Fig. 379: Teach Z-
Focus Offset 

 

 
7. Follow the instructions in the dialog. 
8. Click on [OK]. 

➨ The following message is displayed: 

Fig. 380: Auto-
focusing in 
progress 
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➨ The result of the measurement procedure is displayed: 

Fig. 381: Results 

 

 
9. Follow the instructions in the dialog. 
10. Click on [Yes] to set the proposed offset as current value. 

➨ The following message is displayed: 

Fig. 382: Save 
results to 
machine 

 

 
11. Click on [Save] to save the results into the machine memory. 

➨ The following message is displayed: 

Fig. 383: 
Synchronising 
the results 

 

 
 The Z-Focus offset is determined. 
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 Teach tool-holder positions  5.9.15

Use the menu item “Teach tool-holder positions” to measure the tool-holder 
positions of the ProtoMat machine. 

 Measuring tool-holder positions and storing to machine memory 
1. Click on Machining > Teach tool-holder positions… 

➨ The following dialog is displayed: 

Fig. 384: Teach 
Tool-holder 
Positions 

 

 
 
The processing head moves to the position of the first tool holder. The camera 
focuses automatically and displays the following image in the “Camera” pane: 

Fig. 385: Camera 
image of tool-
holder position 

 

 
 

  



 
How to work with CircuitPro PM CircuitPro PM 2.3  

 
 

318 V1.1 – 11.2016 © 2016 LPKF AG 

5 

2. Move the cross-hairs to the center of the tool-holder position (black circle) 
using the X and Y buttons in the “Processing” pane: 

Fig. 386: X/Y 
buttons 

 

 
 
3. Click on [Set current camera position as position of first holder]. 

➨ The position is stored as the first position. The processing head moves to 
the position of the last tool holder. 

4. Repeat step 2. 
5. Click on [Set position]. 

➨ The position is stored as the last position. The camera moves to all tool-
holder positions one after the other. 
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➨ The following dialog showing the results is displayed: 

Fig. 387: Results 

 
 
The dialog allows the following operations: 
• Restart teaching the tool-holder positions [Restart teaching] 
• Stop the current operation (e.g. when storing or performing the measuring 

again) [Stop] 
• Store the measurement results [Save and close] 
• Abort all operations and close the dialog [Cancel] 
 
6. Click on [Save and close]. 

➨ The following message is displayed: 

Fig. 388: Save 
results to 
machine 

 
 
7. Click on [Yes] in order to store the results to the machine's memory. 

➨ CircuitPro PM synchronizes the measurement results with the machine's 
memory. A corresponding message is displayed. 

 The tool-holder positions have been measured and stored to the machine's 
memory. 
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 Teach tool-holder position H100 5.9.16

Use the menu item “Teach tool-holder positions” to measure the tool-holder 
positions of the ProtoMat H100 machine. 

 Measuring tool-holder positions and storing to machine memory 
1. Click on Machining > Teach tool-holder Positions. 

➨ The processing head moves to the position of the first tool holder and the 
following dialog is displayed: 

Fig. 389: Teach 
first tool-holder 
position 

 
 
2. Insert a tool into the first tool-holder position. 
3. Check whether the center of the auxiliary collet is centered on the tool’s 

center by manually moving the tool magazine upwards. 
4. If the auxiliary collet and the tool are not aligned to each other, move the 

processing head and repeat step 3. 
5. Click on [Set position]. 
6. Click on [Save and close]. 

➨ The processing head moves to position 30 of the tool holder and the 
following dialog is displayed: 

Fig. 390: Teach 
last tool-holder 
position 

 
 
7. Insert a tool into position 30 of the tool-holder. 
8. Check whether the center of the auxiliary collet is centered on the tool’s 

center by manually moving the tool magazine upwards. 
9. If the auxiliary collet and the tool are not aligned to each other, move the 

processing head and repeat step 8. 
10. Click on [Set position]. 
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➨ The following dialog is displayed: 

Fig. 391: Results 

 
 
This dialog allows the following operations: 
• Restart teaching the tool-holder positions [Restart teaching] 
• Stop the current operation (e.g. when storing or performing the measuring 

again) [Stop] 
• Store the measurement results [Save and close] 
• Abort all operations and close the dialog [Cancel] 
11. Click on [Save and close]. 

➨ CircuitPro PM calculates the tool-holder positions and saves the settings. 
 The tool-holder positions have been measured and stored to the machine's 

memory. 

 Importing settings 5.9.17

The function “Import settings” imports BoardMaster machine settings (*.ini) or 
machine settings that have been previously exported from CircuitPro PM in 
XML format. 

 Importing settings 
1. Click on Machining > Import settings. 

➨ The following dialog is displayed: 
  

Fig. 392: 
Importing 

 

  

 
2. Select the desired file (*.ini or *.xml). 
3. Click on [Open]. 

➨ The machine settings are imported and the dialog is closed. 
 The settings have been imported.  
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 Exporting settings 5.9.18

The function “Export settings” exports the machine settings into an XML file. 

 Exporting settings 
1. Click on Machining > Export settings. 

➨ The following dialog is displayed: 
  

Fig. 393: 
Exporting 

 

  

 
2. Select a folder for storing the machine settings. 
3. Click on [OK]. 
➨ The machine settings are saved and the dialog is closed. 
 The settings have been exported. 
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 Connect 5.9.19

The menu item “Connect” allows the following operations: 
• Connect CircuitPro PM with an LPKF ProtoMat machine [Connect]. 
• Disconnect CircuitPro PM from the LPKF ProtoMat machine [Disconnect]. 
• If CircuitPro PM is currently connected to an LPKF ProtoMat machine: 

Select a different machine type [Switch To]. 
 

 
Note 

This step is only necessary if you switch on the ProtoMat 
machine after starting CircuitPro PM 
or  
if you want to connect CircuitPro PM to a ProtoMat machine 
that differs from the one configured previously. 

 

 Connecting CircuitPro PM with an LPKF ProtoMat machine 
1. Click on Machining > Connect… 

➨ The following dialog is displayed: 

Fig. 394: Connect 
the machine 

 
 
2. Select your machine type in the drop-down list. 
 

 
Tip 

CircuitPro PM provides a virtual machine for simulating 
processes. You can connect CircuitPro PM to the virtual 
machine at any time, even when no real machine is connected 
to the PC. 

 
3. Click on [Connect]. 
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➨ The following message window is displayed: 

Fig. 395: 
Connection steps 

 
 
4. Check if a tool is clamped and specify the position of the tool magazine. 
5. Click on [OK]. 
 CircuitPro PM is connected to the LPKF ProtoMat machine. 

 

 Disconnecting CircuitPro PM from the LPKF ProtoMat machine  
1. Click on Machining > Connect… 
2. Click on [Disconnect]. 
 CircuitPro PM is disconnected from the LPKF ProtoMat machine. 

 

 Switching CircuitPro PM to a different LPKF ProtoMat machine 
1. Select the machine type in the drop-down list. 
2. Click on [Switch To]. 

➨ The message window for the connection steps is displayed. 
 The connection of CircuitPro PM is switched to the other machine. 
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5.10 Menu Camera 

 
  

 
Note 

The menu “Camera” is only visible if you are using a machine 
that is equippede with a camera. 

  

 
The menu “Camera” allows you to change the settings of the camera. 
Click on the “Camera” menu item to open the submenu: 

Fig. 396: Menu 
“Camera” 

 
 
The following table provides a brief description of the menu item’s functions: 

Table 48: Menu 
functions 
“Camera” 

 

Menu item Description 

Options Opens the submenu “Options”. 

Actions Opens the submenu “Actions”. 

Movement Opens the submenu “Movement”. 

Overlay Opens the submenu “Overlay”. 

 Search Opens the submenu “Search”. 
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 Options 5.10.1

The menu item “Options” allows you to modify the image acquisition settings of 
the camera. 
Click on Camera > Options to open the following cascading menu: 

Fig. 397: Camera 
> Options 

 
 

The following functions are available in the “Options” sub-menu: 
• Image settings 
• Camera light 
• Save settings 
• Save parameter set 
• Load parameter set 
• Create parameter set 
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5.10.1.1 Image settings 

The sub-menu “Image settings” allows you to modify specific camera settings. 
Click on Camera > Options > Image settings to open the following dialog: 

Fig. 398: Image 
acquisition 
settings 

 
 
The following settings are available: 

Table 49: Image 
acquisition 
settings 

 

Setting Description 

Miscellaneous 

Gain (master) Adjusts the signal amplification of the camera. 

Brightness [%] Adjusts the brightness of the camera image. 

Contrast [%] Adjusts the contrast of the camera image. 

Exposure [%] Adjusts the exposure time of the camera. 

Backlight comp. [%] Adjusts the backlight compensation. 

Sharpness [%] Adjusts the sharpness of the camera image. 

Gamma corr. [%] Adjusts the gamma correction of the camera image. 

Mirror / Rotate Allows to mirror and/or rotate the camera image. 

Frame rate [1/s] Sets the frame rate of the camera. 

ROI [Pixel] 

Offs X Adjusts the offset of the region of interest within the 
camera image in X direction. 

Offs Y Adjusts the offset of the region of interest within the 
camera image in Y direction. 

Size X Sets the size of the camera image in X direction in 
pixels. 

 
Size Y Sets the size of the camera image in Y direction in 

pixels. 

 
Digital gain Allows to enter a value for digital amplification of the 

camera image. 

 DirectShow camera selection 

 
Select Allows to select the active camera. 

 



 
How to work with CircuitPro PM CircuitPro PM 2.3  

 
 

328 V1.1 – 11.2016 © 2016 LPKF AG 

5 

Table 49: Image 
acquisition 
settings 

 

Setting Description 

 Calibration 

 X, Y, Angle Shows the calibration factors of the camera. 

 Calibrate 

 
X distance [mm] Sets the size of the object in X direction that is to be 

used for calibration. 

 
Y distance [mm] Sets the size of the object in y direction that is to be 

used for calibration. 

 
Angle offset Sets the angle of the objects that are to be used for 

calibration. 

 
X count Sets the number of objects in X direction that are to 

be used for calibration. 

 
Y count Sets the number of objects in Y direction that are to 

be used for calibration. 

 
Snap and calibrate Starts the calibration and computes the calibration 

factors. 

 Parameter sets 

 Add Adds camera parameter sets. 

 
Load Loads an existing camera parameter set or creates 

a new one. 

 
Save Saves the changed settings into the selected 

camera parameter set. 

 
Load all Loads all existing camera parameter sets into the 

drop-down list. 

 Save all Saves the settings of all camera parameter set. 
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5.10.1.2 Camera light 

The sub-menu “Camera light” allows you to change the brightness of camera 
light. 
Click on Camera > Options > Camera light to open the following dialog: 

Fig. 399: Camera 
light  

 
 
You can change the brightness of the camera light as follows: 
• Moving the slider using the mouse. 
• Entering a value into the input field and confirming the value with the “Enter” 

key. 
• Clicking on the scroll buttons. 
 

 
Note 

The camera light value is automatically reset to 2 when the 
program is restarted. 

 
Pos: 6.11.2.4 /ED _Technische_D okumentati on/2_Bedienungsanl eitung/Softwar e/CircuitPr o 2.1/Kapitel 5_So ar beiten Sie mit  CircuitPro PM /11_M enü Kamer a/2_Optionen/04_Einstellungen speicher n @ 5\mod_1378804604780_2058.docx @ 111963 @ 4 @ 1  

5.10.1.3 Save settings 

The sub-menu “Save settings” allows you to save specific camera settings. 

 Saving the camera settings 
1. Click on Camera > Options > Save settings. 
 The camera settings are saved. 
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5.10.1.4 Save parameter set 

The sub-menu “Save parameter set” allows you to save specific camera 
settings. 
 

 Saving the current parameter set 
1. Click on Camera > Options > Save parameter set. 
 The parameter set is saved. 
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5.10.1.5 Load parameter set 

The sub-menu “Load parameter set” allows you to select specific camera 
parameter sets. 

 Loading a camera parameter set 
1. Click on Camera > Options > Load parameter set. 

➨ The following dialog is displayed: 

Fig. 400: Load 
parameter set 

 
 
2. Click on the arrow button to open the list of camera parameter sets. 

Fig. 401: Load 
parameter set - 
drop-down list 

 
 
3. Select a camera parameter set: 
 
The following pre-sets are available: 

Table 50: Pre-sets 

 
Pre-set Description 

drillHole_default Pre-set for recognizing fiducials 

millingLineWidth_5um_default Pre-set for acquiring milled lines (5 µm copper 
thickness) 

millingLineWidth_18um_default Pre-set for acquiring milled lines (18 µm copper 
thickness) 
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Table 50: Pre-sets 

 
Pre-set Description 

millingLineWidth_35um_default Pre-set for acquiring milled lines (35 µm copper 
thickness) 
 

millingLineWidth_70um_default Pre-set for acquiring milled lines (70 µm copper 
thickness) 

toolHolderRecognition_default Pre-set for teaching the tool-holder positions 

drillHole_glasmaster_default Pre-set for recognizing fiducials on the glass 
master 

default Pre-set with default settings 

 

 
Note 

If you have created other camera parameter sets, these are 
also displayed in the drop-down list. 

 
4. Click on [OK]. 
 The camera parameter set is loaded. 
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5.10.1.6 Create Camera Parameter Set 

The sub-menu “Create parameter set” allows you to create new camera 
parameter sets. 

 Creating a camera parameter set 
1. Click on Camera > Options > Create parameter set. 

➨ The following dialog is displayed: 

Fig. 402: Create 
parameter set 

 
 
2. Select a camera parameter set type: 
The following parameter set types are available: 

Table 51: Create 
parameter set 

 

Parameter set type Description 

Select type of parameter set 

Active Currently loaded parameter set 

Fiducial Search Parameter set for searching fiducials 

Line Width Finder Parameter set for measuring the width of a milled 
line 

Tool Holder Recognition Parameter set for teaching the tool-holder 
positions 

Standard Standard parameter set 

Suffix used User-defined suffix for the name 

  

 Full Name Type name + user-defined suffix 

 
3. Confirm by clicking on [OK]. 
Or  
3. Close the dialog by clicking on [Cancel]. 
 The camera parameter set has been created. 
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 Actions 5.10.2

The sub-menu “Actions” allows you to perform specific camera actions. 
Click on Camera > Actions to open the following cascading menu: 

Fig. 403: Camera 
> Actions 

 
 
The following functions are available: 

 Measuring Mode 

 Set fiducial parameters 

 Find fiducial 

 Calibrate camera 

 Auto focus 

 Save image 

 Show cameras 
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5.10.2.1 Measuring mode 

The sub-menu “Measuring mode” allows you to perform measurements. 
Click on Camera > Measuring mode to open the following cascading menu: 

Fig. 404: Camera 
> Actions > 
Measuring mode 

 

 
The following functions are available: 
• None 
• Point to point 
• Milling width 
• Circle diameter 
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None 

This option deactivates all measurement options. 
 

 Deactivating the measurement options 
1. Click on Camera > Actions > Measuring Mode > None 
 The measurement options are deactivated. 
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Point to Point 

The “Point to Point” function lets you measure the distance between two points 
of your choice. 
 

 Measuring point to point 
1. Click on Camera > Actions > Measuring Mode > Point to Point. 
2. In the camera pane, click on the point that you want to use as the starting 

point for the measurement. 
3. In the camera pane, click on the point that you want to use as the end point 

for the measurement. 

➨ CircuitPro PM connects the two points with a line. 
 

 
Note 

The “Camera” pane displays the following values: 
• Distance in X direction (DX) 
• Distance in Y direction (DY) 
• Direct distance (DXY) 
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➨ The “Camera” pane displays the following image: 

Fig. 405: Point to 
Point 

 

 /1/ Starting point of the measurement 
/2/ End point of the measurement 

/3/ Measurement result 

 
 The point-to-point measurement is finished. 

 
  

 
Note 

For removing the overlay items in the “Camera” pane, please 
click on Camera > Overlay > Clear overlay. 
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Milling width 

The “Milling width” function lets you measure the distance between two lines in 
the camera image. 

 Measuring the width of the milled channel 
1. Click on Camera > Actions > Measuring Mode > Milling width. 
2. Mark one edge of the milled channel to be measured by clicking on two 

points of the edge. 
3. Click on a point on the opposite edge of the milled channel to be measured. 

➨ CircuitPro PM computes the perpendicular line. The length of the 
perpendicular line represents the width of the milled channel: 

Fig. 406: Width of 
milled channel 

 

 /1/ Measurement result 
/2/ End point of the measurement 

/3/ Line on edge of milled channel 

 The width of the milled channel has been measured. 

 
  

 
Note 

For removing the overlay items in the “Camera” pane, please 
click on Camera > Overlay > Clear overlay. 
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Circle Diameter 

The “Circle Diameter” function lets you measure the diameter of a circle in the 
camera image. 

 Measuring the diameter of a circle  
1. Click on Camera > Actions > Measuring Mode > Circle Diameter. 
2. In the camera pane, click on a point on the outer edge of the circle whose 

diameter you want to measure. 
3. Repeat step 2 twice. 
 

 
Tip 

Select the points on the outer edge of the circle in such a way 
that they can form a virtual triangle (see following figure). 
 

 

➨ CircuitPro PM connects the three points and computes the center, 
circumference, and diameter of the circle. 

➨ The measurement results are displayed in the “Camera” pane: 

Fig. 407: Circle 
Diameter 

 

 /1/ Measurement points 

 
/2/ Measurement result 

 The diameter of the circle is measured. 

 
  

 
Note 

For removing the overlay items in the “Camera” pane, please 
click on Camera > Overlay > Clear overlay. 
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5.10.2.2 Set fiducial parameters 

The sub-menu “Set fiducial parameters” allows you to set the fiducial 
parameters. 

 Setting the fiducial parameters 
1. Click on Camera > Actions > Set fiducial parameters. 

Fig. 408: Set 
fiducial 
parameters 

 
 
The following settings are available in the “Fiducial search configuration” 
category: 

Table 52: Set 
fiducial 
parameters 

 

Property Description 

Fiducial search configuration 

Best fitting fiducial only True: Display the fiducial that fits the settings 
best. 
False: Display all fiducials that meet the set 
limits. 

Fiducial Diameter Nominal diameter of the fiducial 

Fiducial form factor Factor for similarity to a circle 

Maximum fiducial diameter Maximum allowable diameter of the fiducial 

Minimum contour length Minimum contour length of an object in pixels 
required to be recognized as a fiducial 

Minimum Fiducial Diameter Minimum allowable diameter of the fiducial 

Minimum fiducial quality (%) Tolerance value in percent for the fiducial 
diameter 

Search ROI  Allows you to define a region of interest, to 
search for fiducials. 

Threshold factor Factor for the brightness threshold to 
distinguish objects from the background. 
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Table 53: Buttons 

 
Buttons Description 

Apply Applies the settings in the current selected 
fiducial parameter set. 

Apply and save Applies and saves the settings for the next 
start of CircuitPro.  

Close Closes the dialog. 

 
2. Modify the settings as desired. 
3. Click on [Apply]. 
Or 
3. Click on [Apply and Save]. 
4. Click on [Close]. 

➨ The dialog is closed. 
 The fiducial parameters have been set. 
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5.10.2.3 Find Fiducial 

The “Find Fiducial” function lets you find fiducials in the camera image. 
 

 Finding a fiducial 
1. Click on Camera > Actions > Find Fiducial 

➨ The camera searches for fiducials. When the search is finished the results 
are displayed in a dialog: 

Fig. 409: Fiducial 
search result 

 
 

➨ The found fiducial is marked accordingly in the “Camera” pane: 

Fig. 410: Fiducial 
marked 

 
 
 The fiducial has been found. 
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Note 

For removing the overlay items in the “Camera” pane, please 
click on Camera > Overlay > Clear overlay. 
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5.10.2.4 Calibrate camera 

The sub-menu “Calibrate camera” allows you to calibrate the camera. 

 Calibrating the camera 
1. Click on Camera > Actions > Calibrate camera. 

➨ The following dialog is displayed: 

Fig. 411: 
Calibrate camera 

 
 

 
Note 

An object of defined size, e.g. a hole of known diameter, 
should be visible in the camera image for calibrating the 
camera. 
Enter the diameter or the size of the object in the fields “X 
distance” and “Y distance” and click on [Snap and calibrate]. 

 
  



 
CircuitPro PM 2.3 How to work with CircuitPro PM 

   

© 2016 LPKF AG  V1.1 – 11.2016 341 

5 

The “Calibration” group contains the following settings: 
Table 54: 
Calibration 

Setting Description 

 Calibration 

 X, Y, Angle Shows the calibration factors of the camera. 

 Calibrate 

 
X distance [mm] Sets the size of the object in X direction that is 

to be used for calibration. 

 
Y distance [mm] Sets the size of the object in y direction that is 

to be used for calibration. 

 
Angle offset Sets the angle of the objects that are to be 

used for calibration. 

 
X count Sets the number of objects in X direction that 

are to be used for calibration. 

 
Y count Sets the number of objects in Y direction that 

are to be used for calibration. 

 
Snap and calibrate Starts the calibration and computes the 

calibration factors. 

 
2. Modify the settings as desired. 
3. Click on [Snap and calibrate]. 
 The camera has been calibrated. 
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5.10.2.5 Auto Focus 

The “Auto Focus” function starts the automatic focusing of the camera. 
 

 Starting the automatic focusing procedure 
1. Click on Camera > Actions > Auto Focus. 

➨ The camera focuses automatically so that a crisp camera image is 
displayed. 

 The automatic focusing procedure is finished. 
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5.10.2.6 Save image 

The “Save image” function lets you save the current camera image. 

 Saving the current camera image 
1. Click on Camera > Actions > Save image. 

➨ The following dialog is displayed: 

Fig. 412: Save 
image 

 
 
2. Enter a file name and select a folder. 
3. Click on [Save]. 
 The current camera image is saved. 
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5.10.2.7 Show cameras 

The “Show cameras” function shows you all cameras that are available to you. 
Click on Camera > Actions > Show cameras to open the following dialog: 

Fig. 413: Select 
camera 

 
 

 Selecting a camera 
1. Click on the arrow button to open the drop-down list of the available 

cameras. 
2. Click on a camera in the drop-down list. 
3. Click on [Select]. 
4. Click on [Close]. 
 The camera has been selected. 
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 Movement 5.10.3

The menu item “Movement” allows you change height settings and move the 
camera and milling head. 
Click on Camera > Movement to open the following cascading menu: 

Fig. 414: Camera 
> Movement 

 
The following functions are available: 
• Set focus height 
• Move to focus 
• Move camera >> head 
• Move head >> camera 
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5.10.3.1 Set focus height 

The function “Set focus height” lets you set the current camera height as the 
focus height. 
 

 
Tip 

This function is best used after using the “Auto focus” function. 

  

 Setting the current height as the focus height 
1. Click on Camera > Movement > Set focus height. 
 The current height is stored as the focus height. 
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5.10.3.2 Move to focus  

The function “Move to focus” lets you move the camera to the set focus height. 

 Moving to the focus height 
1. Click on Camera > Movement > Move to focus. 
 The camera moves to the set focus height. 
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5.10.3.3 Move camera >> head 

The function “Move camera >> head” lets you move the camera to the current 
position of the milling head. 
 

 
Tip 

This function is useful for e.g. checking drilled holes. 

  

 Moving the camera to the current position of the milling head 
1. Click on Camera > Movement > Move camera >> head. 
 The camera moves to the current position of the milling head. 
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5.10.3.4 Move head >> camera 

The function “Move head >> camera” lets you move the milling head to the 
current position of the camera. 

 Moving the milling head to the current position of the camera 
1. Click on Camera > Movement > Move head >> camera. 
 The milling head moves to the current position of the camera. 
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 Overlay 5.10.4

The menu item “Overlay” allows you to modify the settings for the camera pane. 
Click on Camera > Overlay to open the following cascading menu: 

Fig. 415: Camera 
> Overlay 

 

 
The following functions are available in the “Overlay” cascading menu: 
• Switch Crosshair State 
• Clear Overlay 
• Set Color 

Pos: 6.11.5.1.2 /ED _Technische_D okumentati on/2_Bedienungsanl eitung/Softwar e/CircuitPr o 1.5/H andbuch/Kapitel_4_Aufbau der Bedienoberfläche/5_M enüs /11_M enü Kamer a/5_Ü berlager ung/02_Fadenkreuz_ei n_ausschalten @ 2\mod_1325775910229_2058.docx @ 51814 @ 4 @ 1  
 

  



 
CircuitPro PM 2.3 How to work with CircuitPro PM 

   

© 2016 LPKF AG  V1.1 – 11.2016 345 

5 

5.10.4.1 Switch Crosshair State  

The “Switch Crosshair State” function lets witch on or off the display of the 
crosshair in the “Camera” pane. 
 

 Switching the crosshair on/off 
1. Click on Camera > Overlay > Switch Crosshair State. 

➨ The view in the “Camera” pane changes as follows: 

Fig. 416: 
Crosshair 

 
 
 The crosshair serving as a centering aid is displayed/hidden in the 

“Camera” pane. 
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5.10.4.2 Clear Overlay 

The “Clear Overlay” function lets you clear the camera pane of overlaid 
elements. 

 Clearing the camera image of overlays 
1. Click on Camera > Overlay > Clear Overlay. 

➨ Overlaid elements are removed from the “Camera” pane: 

Fig. 417: Clear 
Overlay 

   
 /1/ Camera pane with overlay  

 
/2/ Camera pane without overlay 

 The overlays are cleared. 
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5.10.4.3 Set color 

The menu item “Set color” allows you to set the colors of the camera overlays. 

 Setting the overlay color 
1. Click on Camera > Overlay > Set color. 

➨ The following dialog is displayed: 

Fig. 418: Set 
color 

 
 
2. Click on the arrow to open the drop-down list of the settings: 

Fig. 419: Set 
color available 
settings 

 
 
3. Select a setting: 
The following settings are available: 

Table 55: Set 
color 

 

Setting Description 

Overlay Display color of the crosshair 

Circle Color for displaying the results of a fiducial search 

Measure Display color of the measure function 

 
4. Confirm your selection by clicking on [OK]. 

➨ The following dialog for selecting the color is displayed: 

Fig. 420: Color 
selection 
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5. Select a color. 
  

 
Tipp 

For a wider choice of colors click on  
[More colors…]. 

  

 
6. Click on [OK]. 
 The color has been set. 
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 Search 5.10.5

The sub-menu “Search” allows you to set parameters the search functions and 
to perform search operations. 
Click on Camera > Search to open the following cascading menu: 

Fig. 421: Camera 
> Search 

 
 
The following functions are available in the “Search” sub-menu: 
• Find Circles 
• Find Lines 
• Spiral Search 
• Find Corner 
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5.10.5.1 Find Circles 

The “Find Circles” function lets you find circles in the camera image. 

 Finding circles 
1. Click on Camera > Search > Find Circles. 

➨ The number of circles found and their parameters are displayed in a dialog 
(/2/). In addition, the circle is displayed in the camera pane (/1/): 
 

Fig. 422: Find 
Circles 

 
 /1/ Circle in camera pane /2/ Message Find Circles Results 

 
 The circles have been found in the camera image. 

 

 
Note 

For removing the overlay items in the “Camera” pane, please 
click on Camera > Overlay > Clear overlay. 
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5.10.5.2 Find Lines 

The “Find Lines” function lets you find lines in the camera image. 

 Finding lines 
1. Click on Camera > Search > Find lines. 

➨ The following message is displayed, showing the results if the line search 
and their parameters. 

Fig. 423: Find 
Lines 

 
 

➨ In addition, the line is displayed in the camera pane: 

Fig. 424: Find 
Lines Camera 
pane 

 
 
 The lines have been found in the camera image. 

 
  

 
Note 

For removing the overlay items in the “Camera” pane, please 
click on Camera > Overlay > Clear overlay. 
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5.10.5.3 Spiral Search 

The “Spiral search” function lets you search in a spiral over an area to find 
fiducials. 

 Starting a spiral search 
1. Click on Camera > Search > Spiral search. 

➨ The following dialog is displayed: 

Fig. 425: Spiral 
Search 

 
 
2. If necessary, modify the settings in category “Spiral search parameters”. 
The following settings are available: 

Table 56: Spiral 
Search 

 

Setting Description 

Spiral search parameters 

Ask for acceptance Specifies whether the user has to accept every 
found fiducial. 

Backlash avoid distance Specifies the distance that the camera head 
moves before centering the fiducial in order to 
avoid errors due to backlash. 

X Distance in X direction 

Y Distance in Y direction 

Diameter tolerance Specifies the allowable absolute size 
difference from the nominal diameter for the 
minimum and maximum recognized diameter. 

Fiducial display time Specifies the time the head rests over the 
fiducial after recognition. 

Force manual centering Specifies whether the dialog for manual 
centering is displayed even if a fiducial has 
been recognized. 

Manual centering on fail Specifies whether the dialog for manual 
centering is displayed if automatic centering 
has failed. 

Max tries for centering Specifies the maximum tries for centering until 
the fiducial is specified as not found. 

Minimum valid quality Defines the minimum quality that has to be 
reached at the start of the spiral search. 
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Table 56: Spiral 
Search 

 

Setting Description 

 
Minimum quality improvement Specifies the minimum quality improvement 

necessary for continuing the centering. 

 
Search area size Specifies size of the area around the start 

location where the fiducial is searched. 

 
Threshold distance Specifies the threshold distance for accepting 

the fiducial directly without further centering. 

 
3. Click on [Start]. 

➨ The camera searches for fiducials in spirals. When a fiducial is found, the 
following message is displayed: 

Fig. 426: Spiral 
Search Result - 
fiducial found 

 
 

➨ If no fiducial is found the following message is displayed: 

Fig. 427: Spiral 
Search Result - 
fiducial not found 

 
 

 
Note 

Fiducial not found 
Check whether the camera head is really above the fiducials 
that are to be found. Otherwise move the head manually to that 
area and adjust the size of the search area “Search area size” 
if necessary. 

 
 The spiral search for fiducials is finished. 

 

 
Note 

Click on Camera > Overlay > Clear overlay to clear the 
“Camera” pane of the overlays. 
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5.10.5.4 Find Corner 

The “Find corner” function lets you find corners. 

 Finding a corner 
1. Click on Camera > Search > Find corner. 

➨ The number of corners found and their parameters are displayed in a dialog 
(/2/). In addition, the corner is displayed in the camera pane (/1/): 

Fig. 428: Find 
corner 

 
 /1/ Corner in camera pane /2/ Message Find corner 

 
 The corners have been found in the camera image. 

 
  

 
Note 

For removing the overlay items in the “Camera” pane, please 
click on Camera > Overlay > Clear overlay. 
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5.11 Menu Extras 

The menu “Extras” allows you to change the program settings. 
Click on the “Extras” menu item to open the submenu: 

Fig. 429: Menu 
“Extras” 

 
 
The following table provides a brief description of the menu item’s functions: 

Table 57: Menu 
functions 
“Extras” 

 

Menu item Description 

Options… Opens the dialog “Options”. 

 Customize… Opens the dialog “Customize”. 
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 Options 5.11.1

The “Options” dialog allows you to modify specific program settings. 
Click on Extras > Options to open the following dialog: 

Fig. 430: Extras > 
Options 
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The following settings are available: 
Table 58: Options 
“General” 

 

Property Description 

Application 

User level Choice between “Advanced user” and “Service”. 

Use OS culture Choice between “True” and “False”. 

Language Sets the language of the application interface. 
Choice is only available if “Use OS culture” is set to 
“False”. 
• Deutsch (Deutschland) 
• español (España) 
• suomi (Suomi) 
• français (France) 
• italiano (Italia) 
• 日本語(日本) 
• polski (Polska) 
• português (Portugal) 
• русский (Россия) 
• slovenski (Slovenija) 
• svenska (Sverige) 
• English (United States) 

• 中文(简体) 

Units Units used in the application. 
Choice is only available if “Use OS culture” is set to 
“False”. 
• Meters [m] 
• Centimeters [cm] 
• Millimeters [mm] 
• Micrometers [µm] 
• Inches [inch] 
• Mils [mil] 

Decimal separator Choice between dot (.) and comma (,) if “Use OS 
culture” is set to “False”. 

Auto save 

Time interval (min) Defines the time until a document is saved. 

Auto save mode Switches auto saving on or off 

Undo/Redo 

Undo/Redo level Undo/Redo level 

User and license information 

User name User name in the current application session 

Organization User organization of the current application runtime 
license. 

Location Organization location of the current application 
runtime license. 

 
Serial number Serial number of the current application runtime 

license 

http://en.wiktionary.org/wiki/espa%C3%B1ol
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Table 58: Options 
“General” 

 

Property Description 

 
Enabling code Enabling code of the current application runtime 

license. 

 
Table 59: Options 
“General” 
buttons 

 

Button Description 

OK Closes the dialog and stores the settings. 

Cancel Closes the dialog without storing the settings. 

 Check box Description 

 
Use document preferences Activate this check box if you want to use the 

standard settings stored the document. 

 
You can modify further settings in the following categories: 
• Display 
• Measurement 
• Import/Export 

• Import Assignments 
• Export configurations 
• Formats 

• Gerber 
• Excellon 
• LMD 
• HPGL 
• DXF 
• STEP 

• Miscellaneous 
• CAM settings 
• Machine 
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Use the categories tree that is displayed in the left section of the dialog to 
navigate to the desired options (see the following figure). 

Fig. 431: 
Categories tree 
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Display 

Click on “Display” in the “Options” dialog to display the following view: 
Fig. 432: Extras > 
Options 
“Display” 

 
 
The following settings are available: 

Table 60:Options 
“Display” 

 

Property Description 

2D CAM view 

Background color Sets the background color of the CAM view. 

Pan & zoom rectangle color Sets the color of the visible-area rectangle in the 
Navigation view. 

Show grid Activates/deactivates grid in CAM view. Choice 
between “True” and “False” 

Show page outlines Display how the printed region will be divided into 
several pages. 

Snap to grid Sets whether the cursor "sticks to" grid nodes in 
CAM view or not (only active if “Show grid” is set to 
“True”). 

Spacing X Sets the grid spacing in X direction in the CAM view. 

Spacing Y Sets the grid spacing in Y direction in the CAM view. 

Transparency of major lines Sets the transparency of the major lines 

Transparency of minor lines Sets the transparency of the minor lines. 

2D Machining view 

Auxiliary board length Defines the length of rectangle of auxiliary board 
during dispensing operation. 
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Table 60:Options 
“Display” 

 

Property Description 

Auxiliary board rectangle 
color 

Defines the color of the rectangle of the auxiliary 
board during dispensing operation. 

Auxiliary board width Defines the width of the rectangle of the auxiliary 
board during the dispensing operation. 

Background color Sets the background color of the 2D machining 
view. 

Camera area color Sets the display color of the camera area. 

Camera area line style Sets the line style of the boundary of the camera 
area. 

Material area color Sets the display color of the material area. 

Material area line style Sets the line style of the material area boundary. 

Max processing area color Sets the display color of the maximum processing 
area. 

Max processing area line 
style 

Sets the line style of the maximum processing area 
boundary. 

Placement rectangle color Defines the color for the rectangle of production 
data during placement operation. 

Reference hole color  Sets the color of the positions where the reference 
holes have been drilled. 

Show material Activate/deactivate display of material area, max 
processing area and tool magazine. 

Tool ramp color Sets the color for the milling-width adjustment ramp. 

Topography points color Sets the color for displaying the points for a “Read 
topography” phase when the operation is active 

Working area color Sets the display color of the working area. 

 
Working area line style Sets the line style of the boundary of the working 

area. 

 3D View 

 Background color Sets the background color of the 3D view. 

 Common 

 
Dynamic highlighting Sets the tracking mode of objects under the mouse 

cursor in graphic views, also known as dynamic 
highlighting. 

 
Performance and quality 
settings 

Sets the priority for speed versus precision. 

 
Show jumps in toolpath Activate/deactivate display of jumps between 

toolpath lines. 
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Measurement 

Click on “Measurement” in the “Options” dialog to display the following view: 
Fig. 433: Extras > 
Options 
“Measurement” 

 
 
The following settings are available: 

Table 61: Options 
“Measurement” 

 

Property Description 

Measurement settings 

Coordinate system Coordinate system used in the application: 
Cartesian or Polar. 

Coordinates Input of coordinates in the application: absolute or 
relative values. 
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Import / Export 

Click on “Import / Export in the “Options” dialog to display the following view: 
Fig. 434: Extras > 
Options “Import / 
Export” 

 
 
The following settings are available: 

Table 62: Options 
“Import / Export” 

 

Property Description 

Import 

Compact data If set to “True”, geometrical objects that are composed 
of a lot of smaller objects are replaced with a single 
polygon that fills the same area. 

Reduce number of elements If set to “True”, the number of elements for open/closed 
paths and polygons is reduced. 

 Preview 

 New layer's color Preview color for objects that are assigned to the new 
layer. 

 Watch changes 

 
Time interval (min) Defines the time interval for checking for changes in the 

source files. 

 

Watch mode If set to “ON”, the imported source file is periodically 
checked for changes according to the defined time 
interval. 
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Import assignments 

Click on “Import assignments” in the “Options” dialog to display the following 
view: 

Fig. 435: Extras > 
Options “Import 
assignments” 

 
 
The following settings are available: 

Table 63: Extras > 
Options “Import 
assignments” 

Property Description 

Aperture Templates Selects the path of an existing aperture template 
file. 

 
Import Assignments Selects the path of an existing assignments file. 

You can also select a new XML file by entering a 
new file name. 
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Fig. 436: Creating 
assignment rules 

 
 

Table 64: 
Columns 

 

Column Description 

File name Defines the file extension for assignment. 

Format Assigns the format for the import. 

 Layer/Template Defines the destination layer for the import. 

 Aperture/Tool List Defines the aperture / tool list. 

 
Table 65: Import 
Assignments - 
buttons 

 

Button Description 

Add Allows to create new assignment rules. These 
assignment rules are written to the selected XML 
file. Thus, you can define for example that imported 
files having specific file extensions are always 
assigned to a specific layer. 

Remove Removes the selected assignment rule(s). 

 
Table 66: Options 

 
Options Description 

Adjust Excellon files This option affects the format settings of the 
Excellon file. 
CircuitPro PM automatically selects the settings that 
cause the best fit to those of the Gerber X data. 
Attention! If the Gerber X files contain further 
information (e.g. crosshairs or bounding box) except 
the PCB, the drill data could be scaled incorrectly. In 
such cases disable this option or adjust the format 
settings manually. 
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Export configurations 

Click on “Export configurations” in the “Options” dialog to display the following 
view: 

Fig. 437: Export 
configurations 

 

 
The following settings are available: 

Table 67: Export 
configurations 

 

Section Description 

Configurations file Enter the path to the configuration file. 
You can select/change the path by clicking the 
button next to it. 

Configurations The available configurations that are located in the 
current configuration file are listed. 
You can add or remove configurations by clicking 
the buttons “Add” and “Remove”. 

 Parameters 

 
File Name Enter the file name with which the file is to be 

exported. 

 
Format Enter the file format in which the file is to be 

exported. 

 
Source objects Enter the source objects which are to be exported 

in the file. 
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Gerber 

Click on “Formats > Gerber” in the “Options” dialog to display the following view: 
Fig. 438: 
Extras>Options 
“Gerber” 

 
 
The following settings are available: 

Table 68: 
Extras>Options 
“Gerber” 

 

Property Description 

Import 

Set 360 interpolation as 
default 

Activate/deactivate 360-degree interpolation as 
default. 

Rotate AM octagon Always align octagon borders to axes. 

Rotate Square Activate/deactivate automatic rotation of square 
objects during Gerber import. 

Step and repeat to flash Activate/deactivate combining object collections to 
flash objects for step-and-repeat commands. 

Use layer name Use the layer name defined in the Gerber file. 

Use layer polarity Activate/deactivate analysis of layer polarity during 
Gerber import. 
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Excellon 

Click on “Formats > Excellon” in the “Options” dialog to display the following 
view: 

Fig. 439: 
Extras>Options 
“Excellon” 

 
 
The following settings are available: 

Table 69: 
Extras>Options 
“Excellon” 

 

Property Description 

Import 

Fiducial diameter Sets the diameter of fiducial objects when importing 
Excellon files. 

Pin hole diameter Sets the diameter of the pin hole when importing 
Excellon files. 
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LMD 

Click on “Formats > LMD” in the “Options” dialog to display the following view: 
Fig. 440: Extras > 
Options “LMD” 

 
 
The following settings are available: 

Table 70:Options 
“LMD” 

 

Property Description 

Tools conversion file Defines the path of the file for tool conversion. 
You can also select a new XML file by entering a 
new file name. 

Tool to be replaced Defines the tool to be replaced. 

Tool to be used Defines the tool to be used instead. 
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HPGL 

Click on “Formats > HPGL” in the “Options” dialog to display the following view: 
Fig. 441: Extras > 
Options “HPGL” 

 
 
The following settings are available: 

Table 71: Options 
“HPGL” 

 

Property Description 

Import 

Data type Defines how to import the HPGL data: as 
geometrical objects or toolpaths 

Plotter resolution Defines the plotter resolution used by the HPGL file. 

Resolution unit Defines the resolution units (mm or inch). 
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DXF 

Click on “Formats > DXF” in the “Options” dialog to display the following view: 
Fig. 442: Extras > 
Options “DXF” 

 
 
The following settings are available: 

Table 72:Options 
“DXF” 

 

Property Description 

Import 

Default font The default font is used to replace fonts defined in a 
DXF file that are not installed on this PC. 
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STEP 

Click on “Formats > STEP” in the “Options” dialog to display the following view: 
Fig. 443: Extras > 
Options “STEP” 
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Miscellaneous 

Click on “Miscellaneous” in the “Options” dialog to display the following view: 
Fig. 444: Extras > 
Options 
“Miscellaneous” 

 
 
The following settings are available: 

Table 
73:Options 
“Miscellaneous” 

 

Property 
 

Description 

Common 

Bounding box if number of objects 
greater 

Show a bounding box when moving 
objects in the CAM view if the number 
of objects exceeds this value. 

Maximal printed pages Defines the maximal count of pages 
that can be printed. 

Message pop-up Sets the types of messages shown as 
pop-up message boxes (in addition to 
a record in the Message View). 

Message pop-up w/o Message View Sets types of messages shown as pop-up 
message box when the Message view is 
closed. 

Show conductor objects Activates/deactivates (default) the display 
of conductor objects in the Geometry data 
view. 

Store last choice of delete object 
operation: with dependent objects or 
without. 

Defines whether the last choice of the 
“delete object operation: with dependent 
objects or without“ is stored. Used when 
the warning delete dialog is not shown. 
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Table 
73:Options 
“Miscellaneous” 

 

Property 
 

Description 

Fiducial 

Diameter Defines the diameter of fiducials. 

 Logging 

 

Verbose If “Verbose” is set to true, the 
application diagnostic messages are 
listed in the Message View as “Service 
messages”. 

 Read Topography 

 
Grid spacing X Sets the spacing of the grid in X direction 

for the operation 'Read topography'. 

 
Grid spacing Y Sets the spacing of the grid in Y direction 

for the operation 'Read topography' 

 Tolerances 

 

Accuracy for curve modifications Precision value used for curve 
modification operations (all modify 
geometry operations, Close path, 
Convert to path, Combine open paths, 
Convert to polygon, Draw to flash). 

 

Curve combine Defines the tolerance for the 
maximum distance between two 
objects that are to be combined. 

 Tool library  

 

Save tools inside document True: 
All settings in the tool library are 
stored in the project's corresponding 
document file. 
False: 
All settings in the tool library are 
stored in the common 
“ToolLibrary.xml” file and are thus 
available to all projects. 

 
Standard tool library file Path of the standard tool library file 

(ToolLibrary.xml), used for new projects. 

 
Tool instances library file Path of the tool library file that contains 

descriptions of real machine tools. 

 Toolpath generation 

 Circular arc approximation Defines whether arc elements are 
approximated 

 Default spike angle Sets the default spike angle for the 
insulation algorithm. 

 Default spike width Sets the default spike width for the 
insulation algorithm.  

 Default tolerance Sets the default tolerance for toolpath 
generation algorithms. 

 Max cutting link length Defines the maximum length of a cutting 
link between toolpath sections. 
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Table 
73:Options 
“Miscellaneous” 

 

Property 
 

Description 

 
Max joinable pin length Defines the maximum pin movement 

length that is joined without jump to the 
adjacent curve. 

 Maximum size of remaining part Maximum size of remaining part 
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CAM settings 

Click on “CAM settings” in the “Options” dialog to display the following view: 
Fig. 445: Extras > 
Options “CAM 
settings” 

 
 
The following settings are available: 

Table 74: 
Extras > 
Options “CAM 
settings” 

Property Description 

2.5D mode settings 

Maximum Z level (2.5D milling) Defines the maximum value for the Z level 
for 2.5D milling. 
 

 

Maximum Z level (pocketing) Defines the maximum value for the Z level 
for pocketing. 
 

Overlap distance Defines the additional distance that the tool 
moves at the end of a closed milling path 
to overlap the start. The value is in percent 
of the tool diameter. 0% means that start 
and end only touch. 
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Table 74: 
Extras > 
Options “CAM 
settings” 

Property Description 

Ramp distance 
 

Defines the height to lift the tool above a 
surface already cut when the tool does a 
jump between cutting movements within a 
pocket. 

 

Safety distance Defines the height to lift the tool above the 
horizontal surface when the tool does a 
jump between cutting movements. 

Tolerance Tolerance used for computation. 

Tool rotation Defines the direction of tool rotation. 

 Contour routing settings 

 
Burr removal This function reduces burrs when contour 

routing. An additional toolpath is generated 
on the top and bottom sides. 

 Rubout settings 

 
Overlap laser toolpath [No. of tracks] Defines the count of overlaps of laser 

toolpaths with milling toolpaths 
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Machine 

Click on “Machine” in the “Options” dialog to display the following view: 
Fig. 446: Extras > 
Options 
“Machine” 

 
 
The following settings are available: 

Table 75: 
Extras > 
Options 
“Machine” 

 

Property Description 

Machine settings 

2.5D fixture plate thickness Thickness of fixture plate below the 
material. Only used in 2.5D jobs. 

Camera lens type If you are using an upgrade or replacement 
camera, you need to set your camera type 
here to work with the correct camera 
calibration parameters. 

Default end mill depth This is the default end mill depth. It is for 
uncalibrated end mills only. The real depth 
my vary up to ±15 µm. 

Extraction system monitoring If the extraction system is monitored, the 
machine stops processing if the extraction 
system is off. This is not possible with all 
types of extraction systems. 

MKHP plate height Defines the thickness of the MKHP plate. 

MKHP plate mounted Defines whether the MKHP plate is 
mounted or not. 

Sinter plate thickness Defines the thickness of the sinter plate. 

Underlay plate thickness Defines the thickness of the underlay plate. 

Vacuum table mounted Defines whether the vacuum table is 
mounted or not. 
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Table 75: 
Extras > 
Options 
“Machine” 

 

Property Description 

Vacuum-system turn-off delay Defines the time that the vacuum system 
keeps running after end of processing. 

 Process settings 

 
Dust reduction Reduces the dust produced during contour 

routing. This option will increase the 
processing time. 

 
Keep tool during optical alignment Determines whether the tool is kept in the 

clamp during optical alignments. 
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 Customize 5.11.2

The menu item “Customize” allows you to adapt the operation of the program to 
your needs. 
Click on Extras > Customize to open the following dialog: 

Fig. 447: Extras > 
Customize… 
  

 

/1/ List of available settings /2/ Tabs 

The dialog has 5 tabs with corresponding settings: 
• Commands 
• Toolbars 
• Keyboard 
• Options 
• Layouts 
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Commands tab 

Click on the “Commands” tab in the “Customization” dialog to display the 
following view: 

Fig. 448: Extras > 
Customize…> 
Commands 
  

 

 
The “Commands” tab allows you to customize the toolbars to your needs. 
When you click on a category the corresponding command lists are displayed. 
You can drag and drop the commands to the desired position in any toolbar. 
Thus you can have fast and easy access to frequently used functions in the 
toolbar. 
 
Example: 

 Inserting the “Polygon” command into the toolbar 
1. Click in “Category“ on “Insert”. 

➨ The corresponding command list is displayed. 
2. Click in “Command” on “Polygon”. 
3. Drag the mouse pointer with the left mouse button pressed to the desired 

position in the toolbar. 



 
How to work with CircuitPro PM CircuitPro PM 2.3  

 
 

378 V1.1 – 11.2016 © 2016 LPKF AG 

5 

➨ The mouse pointer is displayed as follows: 

Fig. 449: Inserting 
Polygon into the 
toolbar 
  

 

 /1/ Mouse pointer with the left mouse button pressed 

4. Release the left mouse button. 

➨ The ”Polygon” icon is displayed at the desired position in the toolbar: 

Fig. 450: Polygon 
icon in toolbar 
  

 

 /1/ Separator in toolbar /2/ “Polygon” icon in toolbar 

 

1 

1 

2 
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Tip 

You can insert separators between the icons in the toolbar by 
using the [Separator] button and drag and drop. 
Click on [Separator] and drag the mouse pointer with the left 
mouse button pressed to the desired position in the toolbar. 

 
 The “Polygon” command has been inserted into the toolbar. 
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Toolbars tab 

Click on the “Toolbars” tab in the “Customization” dialog to display the following 
view: 

Fig. 451: Extras > 
Customize…> 
Toolbars 
  

 

 /1/ Activation of the toolbars 
/2/ [New…] - creates a new toolbar 
/3/ [Rename] - renames the selected 
toolbar 

/4/ [Delete] - deletes the selected 
toolbar 
/5/ [Close] - Closes the “Customization” 
dialog. 
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Keyboard tab 

Click on the “Keyboard” tab in the “Customization” dialog to display the following 
view: 

Fig. 452: Extras > 
Customize…> 
Keyboard 
  

 
 

 /1/ Lists the menu items with their sub-
menus and their assigned keyboard 
shortcuts 
/2/ [Assign] - assigns a new shortcut 
/3/ [Delete] - deletes the shortcut  

/4/ Description of the menu item 
currently selected in /1/ 
/5/ [Close] - Closes the “Customization” 
dialog. 

 

  

 
Pos: 6.12.3.5 /ED _Technische_D okumentati on/2_Bedienungsanl eitung/Softwar e/CircuitPr o 2.1/Kapitel 5_So ar beiten Sie mit  CircuitPro PM /12_M enü Extras /3_Anpassen/05_R egister _Opti onen @ 5\mod_1378806578047_2058.docx @ 112514 @ 5 @ 1 
 

Options tab 

Click on the “Options” tab in the “Customization” dialog to display the following 
view: 

Fig. 453: Extras > 
Customize…> 
Options 
 

 

 /1/ Setting for the icon size 
/2/ Display mode of the toolbars 
(with/without text/icon) 

/3/ Activate/deactivate display of 
tooltips in toolbars 
/4/ Activate/deactivate display of 
keyboard shortcuts in tooltips 
/5/ [Close] - Closes the “Customization” 
dialog. 
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Layouts tab 

Click on the “Layouts” tab in the “Customization” dialog to display the following 
view: 

Fig. 454: Extras > 
Customize…> 
Layouts 
  

 
 

 /1/ List of existing layouts 
/2/ [Save current] - saves the current 
layout under its current name 
/3/ [Rename] - saves the layout under a 
new name 
 

/4/ [Delete selected] - deletes the 
selected layout 
/5/ [Close] - closes the “Customization” 
dialog 

 

 

This view allows you to save the settings made in the other tabs under a new 
layout name. 
 

 
Note 

You can find the layouts at View > Layouts where you can 
switch to the desired screen layout. 
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5.12 Menu Help 

The menu “Help” provides information about the current software version. 
Click on the “Help” menu item to open the submenu: 

Fig. 455: Menu 
“Help” 

 
 
The following table provides a brief description of the menu item’s functions: 

Table 76: Menu 
functions “Help” 

 

Menu item Description 

Help Opens the CircuitPro PM offline help. 

About… Opens the dialog “About this program“ that contains 
information about CircuitPro PM. 

 
System 
information… 

Contains information about the computer that CircuitPro PM 
is installed on. 
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 Help 5.12.1
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 About 5.12.2

The menu item “About” contains information about the program. 
1. Click on Help > About… 

➨ The following dialog is displayed: 

Fig. 456: About 
this program 

 
 

/1/ Program list including file name and 
version 
/2/ Button [License Contract] 
/3/ Button [Third party] 

/4/ Button [Copy Info] 
/5/ Button [Close] 

 
• Click on [License Contract] to view the license contract. 
• Click on [Third party] to view the list of third party licenses used by Circuit 

Pro PM. 
• Click on [Copy Info] to copy the program list to the clipboard. 
• Click on [Close] to close the dialog. 
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 System information 5.12.3

The menu item “System information“ contains information about your computer.  
Click on Help > System information. 
The following dialog is displayed: 

Fig. 457: System 
information 
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6 Appendix 
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6.3 Index 

2,5D 
Material placement ............................... 90 

2.5D 
create milling ....................................... 227 

2.5D milling ........................................... 227 
3D shape 

import .................................................... 73 
3D view 

activate ................................................ 275 
alignment ............................................... 309 
Anchor ................................................... 148 
anchor point ......................... 161, 269, 270 

set ....................................................... 145 
Anchor point 

to the center point ............................... 148 
aperture ................................................... 68 

library .................................................. 137 
arc 

create .................................................. 164 
auto focus ............................................. 341 
breakout tab 

add new position ................................. 239 
change position ................................... 237 
remove position................................... 240 

CAM view ................................................. 27 
activate .......................................... 44, 275 
toolbar ................................................... 28 

camera overlay 
clear .................................................... 346 

camera parameter set 
create .................................................. 332 
load ..................................................... 330 

camera search 
circle .................................................... 349 
corners ................................................ 353 
fiducial ................................................. 351 
lines ..................................................... 350 
spiral search ........................................ 351 

contour routing ... see Technology Dialog 
copper area 

isolate .................................................. 199 
copper pouring ..................................... 199 
crosshair ............................................... 345 

dispense 
preparation ......................................... 286 
select head ........................................... 48 
set distance .................... see Topography 
start..................................................... 290 
tool ...................................................... 128 
tool list ................................................ 221 

Dispense Preparation Wizard ............. 286 
Dispense process wizard .................... 290 
Drills ..................... see Technology Dialog 
DXF .................................................. 65, 369 
Edit breakout tabs ................................ 236 
engraving ................................................ 93 
Equipment configuration wizard .......... 24 
Excellon .......................................... 65, 366 
fiducial .......................................... 209, 234 

create ................................................. 210 
create new layer ................................. 210 
find ...................................................... 339 
not recognized automatically .............. 288 
recognized automatically .................... 287 
set parameters ................................... 338 
spiral search ....................................... 351 

fiducial phase "DrillFiducials" ............ 309 
Fiducials ............................................... 298 
flash object 

create ................................................. 251 
explode ............................................... 257 
from multiple objects .......................... 252 

focus height 
move to focus ..................................... 343 
set ....................................................... 343 

front panel .............................................. 93 
geometry 

aperture list ........................................... 47 
Gerber ............................................. 65, 365 
GerberX ................................................... 65 
HPGL ............................................... 65, 368 
insert 

milling curve ....................................... 217 
installation information ......................... 16 
insulate ................ see Technology Dialog 
language 

set ....................................................... 354 
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layer ......................................................... 46 
match up layers................................... 151 
move layer to zero .............................. 149 

LMD .................................................. 65, 367 
machining view 

activate .......................................... 44, 275 
ProtoMat D104 ...................................... 35 
ProtoMat E33/E34/E44 ......................... 32 
ProtoMat H100 ...................................... 31 
ProtoMat S43 ........................................ 33 
ProtoMat S63/S103 .............................. 34 
ProtoMat X60 ........................................ 30 

Marking drills ...... see Technology Dialog 
Material placement ................................. 90 
Material properties ................................. 89 
material settings ..................................... 93 
measuring mode ................................... 333 
milled channel 

measuring the width ............................ 336 
milling curve ......................................... 217 

insert ................................................... 217 
pad size parameters 

add ...................................................... 222 
delete .................................................. 224 
edit ...................................................... 223 

path 
close .................................................... 243 
closed .................................................. 166 
combine .............................................. 246 
convert ................................................ 249 
insert ........................................... 160, 166 
open .................................................... 160 

phase 
create .................................................. 295 
list .......................................................... 47 

placement .............................................. 296 
pocket .................................................... 258 
pocketing ............. see Technology Dialog 
polygon 

convert to ............................................ 248 
insert ................................................... 173 
selection ................................................ 28 
with cutouts ......................................... 195 

processing area 
ProtoMat D104 ...................................... 35 
ProtoMat E33/E34/E44 ......................... 32 
ProtoMat H100 ...................................... 31 

ProtoMat S43 ....................................... 33 
ProtoMat S63/S103 .............................. 34 
ProtoMat X60 ....................................... 30 

production phase ...................... see phase 
reference hole 

drill ...................................................... 311 
reference hole ...................................... 311 
reference hole 

choose color ....................................... 359 
reference point ..................................... 147 
Referenzpunkt ...................................... 147 
rubout area ................................... 203, 229 
Safety note .............................................. 13 
segment 

create ................................................. 161 
setup wizard ........................................... 16 
Sieb&Meyer ............................................ 65 
solder paste .......................................... 220 

apply .................................... see dispense 
solder paste dot ................................... 220 
solder paste path ................................. 220 

generate ............................................. 221 
start point 

absolute .............................................. 161 
relative ................................................ 161 

STEP ...................................................... 370 
ProtoMat S43/E33 .............................. 112 

Technology Dialog ............................... 229 
contour routing ................................... 232 
Drills.................................................... 233 
insulate ............................................... 230 
Marking drills ...................................... 233 
pockets ............................................... 235 

tool holder 
machining view ............................... 34, 35 
selection list .................................. 98, 115 
teach position ..................................... 317 
teach position H100............................ 320 

tool library ............................................ 128 
options ................................................ 372 

tool life .................................. 111, 114, 127 
tool magazine 

machining view ............................... 34, 35 
ProtoMat S43/E33 .............................. 112 
ProtoMat S63/S103/H100 .................. 114 
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Tool magazine 
ProtoMat D104 ...................................... 96 

toolpath .....................................38, 47, 219 
create ................... see Technology Dialog 
import .................................................... 74 
selection mode ...................................... 28 

Topography 

set topography points ......................... 211 
user level .............................................. 354 
Z value 

change ................................................ 260 
Z value ................................................... 260 
zero point ...................... 147, 149, 161, 167 

set ....................................................... 147 
 

=== Ende der Liste für Textmar ke Inhalt ===  
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